summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAngelo D'Autilia (sYdRo) <sydro@salug.it>2010-03-05 15:35:56 +0000
committerAngelo D'Autilia (sYdRo) <sydro@salug.it>2010-03-05 15:35:56 +0000
commited84e8349ef0c2f08f07384eabf808e9e9f03905 (patch)
tree13fb0f8ee7f568e6a2830a6185e3a017e045bd86 /dev-games/game-editor
parentdev-db/mongodb: Version bump (diff)
downloadsunrise-ed84e8349ef0c2f08f07384eabf808e9e9f03905.tar.gz
sunrise-ed84e8349ef0c2f08f07384eabf808e9e9f03905.tar.bz2
sunrise-ed84e8349ef0c2f08f07384eabf808e9e9f03905.zip
dev-games/game-editor: New ebuild for bug 289276
svn path=/sunrise/; revision=10237
Diffstat (limited to 'dev-games/game-editor')
-rw-r--r--dev-games/game-editor/ChangeLog8
-rw-r--r--dev-games/game-editor/Manifest4
-rw-r--r--dev-games/game-editor/files/game-editor-9999.patch76
-rw-r--r--dev-games/game-editor/game-editor-9999.ebuild31
-rw-r--r--dev-games/game-editor/metadata.xml5
5 files changed, 124 insertions, 0 deletions
diff --git a/dev-games/game-editor/ChangeLog b/dev-games/game-editor/ChangeLog
new file mode 100644
index 000000000..0c0c8a262
--- /dev/null
+++ b/dev-games/game-editor/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for dev-games/game-editor
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+ 05 Mar 2010; Angelo D'Autilia (sYdRo) <sydro@salug.it>
+ +game-editor-9999.ebuild, +files/game-editor-9999.patch, +metadata.xml:
+ New ebuild for bug 289276
+
diff --git a/dev-games/game-editor/Manifest b/dev-games/game-editor/Manifest
new file mode 100644
index 000000000..f1b251ae2
--- /dev/null
+++ b/dev-games/game-editor/Manifest
@@ -0,0 +1,4 @@
+AUX game-editor-9999.patch 3517 RMD160 5d9844a237253b550e40ecbe59a8dad35a136949 SHA1 83870269457213db01334de9bb9e073a9f3761cb SHA256 707c20fbe065d302554da963e2e781f6bb2c9aa4c1859689ab83a7a179dc4c74
+EBUILD game-editor-9999.ebuild 608 RMD160 b5294239e1ac4bbdcc4499049c2c08707529f639 SHA1 956d4ce2bfdbf3b93de5326ee140c804603902d2 SHA256 6e3a52e388d1e9d26ee99895c049dc7f25559c2e8042b0a7b383252ffd0309b2
+MISC ChangeLog 282 RMD160 8617238d510d475d7f067464606f1f74be942bb9 SHA1 fe8d1354ba37eb40ed61ea42a16f70a3d814c8b8 SHA256 68dc8402df43f6a6c351a04e40a724e99211340f74e1d34bfe701d999dfb0811
+MISC metadata.xml 170 RMD160 645927a396fdc21cdeb089fe42c5397332420ea6 SHA1 ac7f48a14fec325926f9ce1be8fbf1f311b4f2e4 SHA256 d797a2ec6f9dc516c9f9c1a758ee87ad3e8c43101b5dc76c2f872d5bd4639b42
diff --git a/dev-games/game-editor/files/game-editor-9999.patch b/dev-games/game-editor/files/game-editor-9999.patch
new file mode 100644
index 000000000..12a655480
--- /dev/null
+++ b/dev-games/game-editor/files/game-editor-9999.patch
@@ -0,0 +1,76 @@
+diff -ruN -x .svn game_editor-origin/gameEditor/FunctionPanel.cpp game_editor-fixed/gameEditor/FunctionPanel.cpp
+--- game_editor-origin/gameEditor/FunctionPanel.cpp 2010-03-02 15:50:39.000000000 +0100
++++ game_editor-fixed/gameEditor/FunctionPanel.cpp 2010-03-02 15:41:02.000000000 +0100
+@@ -210,7 +210,7 @@
+ EditorDirectory editDir;
+
+ TiXmlDocument doc;
+- if(!doc.LoadFile("functions.xml")) return false;
++ if(!doc.LoadFile("/usr/share/games/game-editor/functions.xml")) return false;
+
+ //Check tree
+ TiXmlElement* root = NULL;
+@@ -1213,4 +1213,4 @@
+ }
+
+
+-#endif
+\ No newline at end of file
++#endif
+diff -ruN -x .svn game_editor-origin/gameEditor/makefile.editor game_editor-fixed/gameEditor/makefile.editor
+--- game_editor-origin/gameEditor/makefile.editor 2010-03-02 15:50:39.000000000 +0100
++++ game_editor-fixed/gameEditor/makefile.editor 2010-03-02 15:46:13.000000000 +0100
+@@ -10,7 +10,7 @@
+ CFLAGS = $(INCS) $(TARGET) -DNO_STDIO_REDIRECT -DNO_LONG_LONG -DNO_DIRENT -DNO_FCNTL -DNO_STAT -DNO_UNISTD -DNO_TERMIOS -DNO_PIPE -DNO_POSIX -DNO_LONGLONG -DNO_HISTORY $(BUILD_TYPE) $(GAMEEDITOR_TYPE)
+
+ ifeq (,$(findstring LLVM,$(TARGET)))
+- LIBSYSTEM = -lstdc++ -lpthread -lX11 /usr/lib32/libXext.so
++ LIBSYSTEM = -lstdc++ -lpthread -lX11 /usr/lib/libXext.so
+ CL=$(CC)
+ CLFLAGS=$(CFLAGS)
+ else
+diff -ruN -x .svn game_editor-origin/gameEngine/EditBox.cpp game_editor-fixed/gameEngine/EditBox.cpp
+--- game_editor-origin/gameEngine/EditBox.cpp 2010-03-02 15:52:30.000000000 +0100
++++ game_editor-fixed/gameEngine/EditBox.cpp 2010-03-02 15:43:46.000000000 +0100
+@@ -264,7 +264,7 @@
+ EditorDirectory dir;
+
+ icon = new Actor("ged_VariableSelector_icon", this);
+- icon->AddAnimation("icon", "b_xy.png", 1, 1);
++ icon->AddAnimation("icon", "/usr/share/games/game-editor/b_xy.png", 1, 1);
+ icon->SetPos(9 + (Width() - icon->Width()) / 2, 10 + (Height() - icon->Height()) / 2);
+ icon->getSprite()->SetHitTest(false);
+ }
+diff -ruN -x .svn game_editor-origin/gameEngine/GameControl.cpp game_editor-fixed/gameEngine/GameControl.cpp
+--- game_editor-origin/gameEngine/GameControl.cpp 2010-03-02 15:52:30.000000000 +0100
++++ game_editor-fixed/gameEngine/GameControl.cpp 2010-03-02 15:42:06.000000000 +0100
+@@ -859,7 +859,7 @@
+
+ #define EDITOR_FRAME_RATE 120 //Use >= 60 to avoid flick in editor mode
+
+-gedString EDITOR_DAT("editor.dat");
++gedString EDITOR_DAT("/usr/share/games/game-editor/editor.dat");
+
+ gedString AXIS_NAME("Axis");
+ gedString REGION_NAME("gedRegion");
+diff -ruN -x .svn game_editor-origin/wxGameEditor/Behavior/wxJigsawEditor/wxJigsawEditorMainFrame.cpp game_editor-fixed/wxGameEditor/Behavior/wxJigsawEditor/wxJigsawEditorMainFrame.cpp
+--- game_editor-origin/wxGameEditor/Behavior/wxJigsawEditor/wxJigsawEditorMainFrame.cpp 2010-03-02 15:52:23.000000000 +0100
++++ game_editor-fixed/wxGameEditor/Behavior/wxJigsawEditor/wxJigsawEditorMainFrame.cpp 2010-03-02 15:40:36.000000000 +0100
+@@ -535,7 +535,7 @@
+
+ void wxJigsawEditorMainFrame::LoadConfig()
+ {
+- wxString configFileName = wxT("config.xml");
++ wxString configFileName = wxT("/usr/share/game/game-editor/config.xml");
+ if(wxFileExists(configFileName))
+ {
+ m_XmlIO.DeserializeFromXml(configFileName);
+@@ -544,7 +544,7 @@
+
+ void wxJigsawEditorMainFrame::SaveConfig()
+ {
+- wxString configFileName = wxT("config.xml");
++ wxString configFileName = wxT("/usr/share/game/game-editor/config.xml");
+ m_XmlIO.SerializeToXml(configFileName, true);
+ }
+
diff --git a/dev-games/game-editor/game-editor-9999.ebuild b/dev-games/game-editor/game-editor-9999.ebuild
new file mode 100644
index 000000000..3af6d9fcd
--- /dev/null
+++ b/dev-games/game-editor/game-editor-9999.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+
+inherit games subversion
+
+DESCRIPTION="2D Game editor"
+HOMEPAGE="http://game-editor.com"
+ESVN_REPO_URI="https://game-editor.svn.sourceforge.net/svnroot/game-editor/trunk"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+DEPEND="x11-libs/libXext
+ x11-libs/libxcb"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}.patch
+}
+
+src_install() {
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins gameEditor/res/* || die
+ dogamesbin output/editor/gameEditor || die
+ prepgamesdirs
+}
diff --git a/dev-games/game-editor/metadata.xml b/dev-games/game-editor/metadata.xml
new file mode 100644
index 000000000..7e3286984
--- /dev/null
+++ b/dev-games/game-editor/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>maintainer-wanted</herd>
+</pkgmetadata>