summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-games/game-editor/game-editor-9999.ebuild')
-rw-r--r--dev-games/game-editor/game-editor-9999.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-games/game-editor/game-editor-9999.ebuild b/dev-games/game-editor/game-editor-9999.ebuild
new file mode 100644
index 000000000..3af6d9fcd
--- /dev/null
+++ b/dev-games/game-editor/game-editor-9999.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+
+inherit games subversion
+
+DESCRIPTION="2D Game editor"
+HOMEPAGE="http://game-editor.com"
+ESVN_REPO_URI="https://game-editor.svn.sourceforge.net/svnroot/game-editor/trunk"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+DEPEND="x11-libs/libXext
+ x11-libs/libxcb"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}.patch
+}
+
+src_install() {
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins gameEditor/res/* || die
+ dogamesbin output/editor/gameEditor || die
+ prepgamesdirs
+}