aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2019-03-27 20:40:46 +0100
committerFabian Groffen <grobian@gentoo.org>2019-03-27 20:40:46 +0100
commit8313efaff478fdec6b736a6cdef31e37ce00be9c (patch)
tree3e745157a219ce3bd61b625c69b0981a8ccfaa0a /configure
parentbuild: compile applets as separate objects (diff)
downloadportage-utils-8313efaff478fdec6b736a6cdef31e37ce00be9c.tar.gz
portage-utils-8313efaff478fdec6b736a6cdef31e37ce00be9c.tar.bz2
portage-utils-8313efaff478fdec6b736a6cdef31e37ce00be9c.zip
configure: ignore expansion undefined warnings for gnulib
Signed-off-by: Fabian Groffen <grobian@gentoo.org>
Diffstat (limited to 'configure')
-rwxr-xr-xconfigure75
1 files changed, 75 insertions, 0 deletions
diff --git a/configure b/configure
index e538b3ea..ec5426d5 100755
--- a/configure
+++ b/configure
@@ -34929,6 +34929,81 @@ else
fi
+ { $as_echo "$as_me:${as_lineno-$LINENO}: checking whether C compiler accepts -Wno-format-nonliteral" >&5
+$as_echo_n "checking whether C compiler accepts -Wno-format-nonliteral... " >&6; }
+if ${ax_cv_check_cflags___Wno_format_nonliteral+:} false; then :
+ $as_echo_n "(cached) " >&6
+else
+
+ ax_check_save_flags=$CFLAGS
+ CFLAGS="$CFLAGS -Wno-format-nonliteral"
+ cat confdefs.h - <<_ACEOF >conftest.$ac_ext
+/* end confdefs.h. */
+
+int
+main ()
+{
+
+ ;
+ return 0;
+}
+_ACEOF
+if ac_fn_c_try_compile "$LINENO"; then :
+ ax_cv_check_cflags___Wno_format_nonliteral=yes
+else
+ ax_cv_check_cflags___Wno_format_nonliteral=no
+fi
+rm -f core conftest.err conftest.$ac_objext conftest.$ac_ext
+ CFLAGS=$ax_check_save_flags
+fi
+{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $ax_cv_check_cflags___Wno_format_nonliteral" >&5
+$as_echo "$ax_cv_check_cflags___Wno_format_nonliteral" >&6; }
+if test "x$ax_cv_check_cflags___Wno_format_nonliteral" = xyes; then :
+ as_fn_append CFLAGS " -Wno-format-nonliteral"
+else
+ :
+fi
+
+
+ { $as_echo "$as_me:${as_lineno-$LINENO}: checking whether C compiler accepts -Wno-expansion-to-defined" >&5
+$as_echo_n "checking whether C compiler accepts -Wno-expansion-to-defined... " >&6; }
+if ${ax_cv_check_cflags___Wno_expansion_to_defined+:} false; then :
+ $as_echo_n "(cached) " >&6
+else
+
+ ax_check_save_flags=$CFLAGS
+ CFLAGS="$CFLAGS -Wno-expansion-to-defined"
+ cat confdefs.h - <<_ACEOF >conftest.$ac_ext
+/* end confdefs.h. */
+
+int
+main ()
+{
+
+ ;
+ return 0;
+}
+_ACEOF
+if ac_fn_c_try_compile "$LINENO"; then :
+ ax_cv_check_cflags___Wno_expansion_to_defined=yes
+else
+ ax_cv_check_cflags___Wno_expansion_to_defined=no
+fi
+rm -f core conftest.err conftest.$ac_objext conftest.$ac_ext
+ CFLAGS=$ax_check_save_flags
+fi
+{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $ax_cv_check_cflags___Wno_expansion_to_defined" >&5
+$as_echo "$ax_cv_check_cflags___Wno_expansion_to_defined" >&6; }
+if test "x$ax_cv_check_cflags___Wno_expansion_to_defined" = xyes; then :
+ as_fn_append CFLAGS " -Wno-expansion-to-defined"
+else
+ :
+fi
+
+
+# gnulib triggers this a lot, just to silence:
+# -Wno-format-nonliteral
+# -Wno-expansion-to-defined
ac_config_files="$ac_config_files Makefile libq/Makefile autotools/gnulib/Makefile tests/atom_explode/Makefile tests/copy_file/Makefile tests/mkdir/Makefile tests/rmspace/Makefile"