aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2019-03-27 11:53:58 +0100
committerFabian Groffen <grobian@gentoo.org>2019-03-27 11:53:58 +0100
commitd0a8d231167adddb80a73849d3bc70edbfda3507 (patch)
tree387e1ffea50f8da37063ce5be638fe35f7397712 /configure
parentlibq: split out cache-related funcs from main/qsearch (diff)
downloadportage-utils-d0a8d231167adddb80a73849d3bc70edbfda3507.tar.gz
portage-utils-d0a8d231167adddb80a73849d3bc70edbfda3507.tar.bz2
portage-utils-d0a8d231167adddb80a73849d3bc70edbfda3507.zip
build: compile applets as separate objects
Instead of including everything from a single file, compile each applet separately. This standardises things somewhat, and allows for parallel compilation. Signed-off-by: Fabian Groffen <grobian@gentoo.org>
Diffstat (limited to 'configure')
-rwxr-xr-xconfigure108
1 files changed, 0 insertions, 108 deletions
diff --git a/configure b/configure
index ce1fbdee..e538b3ea 100755
--- a/configure
+++ b/configure
@@ -34569,42 +34569,6 @@ else
fi
- { $as_echo "$as_me:${as_lineno-$LINENO}: checking whether C compiler accepts -Wno-missing-prototypes" >&5
-$as_echo_n "checking whether C compiler accepts -Wno-missing-prototypes... " >&6; }
-if ${ax_cv_check_cflags___Wno_missing_prototypes+:} false; then :
- $as_echo_n "(cached) " >&6
-else
-
- ax_check_save_flags=$CFLAGS
- CFLAGS="$CFLAGS -Wno-missing-prototypes"
- cat confdefs.h - <<_ACEOF >conftest.$ac_ext
-/* end confdefs.h. */
-
-int
-main ()
-{
-
- ;
- return 0;
-}
-_ACEOF
-if ac_fn_c_try_compile "$LINENO"; then :
- ax_cv_check_cflags___Wno_missing_prototypes=yes
-else
- ax_cv_check_cflags___Wno_missing_prototypes=no
-fi
-rm -f core conftest.err conftest.$ac_objext conftest.$ac_ext
- CFLAGS=$ax_check_save_flags
-fi
-{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $ax_cv_check_cflags___Wno_missing_prototypes" >&5
-$as_echo "$ax_cv_check_cflags___Wno_missing_prototypes" >&6; }
-if test "x$ax_cv_check_cflags___Wno_missing_prototypes" = xyes; then :
- as_fn_append CFLAGS " -Wno-missing-prototypes"
-else
- :
-fi
-
-
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking whether C compiler accepts -Wwrite-strings" >&5
$as_echo_n "checking whether C compiler accepts -Wwrite-strings... " >&6; }
if ${ax_cv_check_cflags___Wwrite_strings+:} false; then :
@@ -34857,42 +34821,6 @@ else
fi
- { $as_echo "$as_me:${as_lineno-$LINENO}: checking whether C compiler accepts -Wno-format-nonliteral" >&5
-$as_echo_n "checking whether C compiler accepts -Wno-format-nonliteral... " >&6; }
-if ${ax_cv_check_cflags___Wno_format_nonliteral+:} false; then :
- $as_echo_n "(cached) " >&6
-else
-
- ax_check_save_flags=$CFLAGS
- CFLAGS="$CFLAGS -Wno-format-nonliteral"
- cat confdefs.h - <<_ACEOF >conftest.$ac_ext
-/* end confdefs.h. */
-
-int
-main ()
-{
-
- ;
- return 0;
-}
-_ACEOF
-if ac_fn_c_try_compile "$LINENO"; then :
- ax_cv_check_cflags___Wno_format_nonliteral=yes
-else
- ax_cv_check_cflags___Wno_format_nonliteral=no
-fi
-rm -f core conftest.err conftest.$ac_objext conftest.$ac_ext
- CFLAGS=$ax_check_save_flags
-fi
-{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $ax_cv_check_cflags___Wno_format_nonliteral" >&5
-$as_echo "$ax_cv_check_cflags___Wno_format_nonliteral" >&6; }
-if test "x$ax_cv_check_cflags___Wno_format_nonliteral" = xyes; then :
- as_fn_append CFLAGS " -Wno-format-nonliteral"
-else
- :
-fi
-
-
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking whether C compiler accepts -Wsequence-point" >&5
$as_echo_n "checking whether C compiler accepts -Wsequence-point... " >&6; }
if ${ax_cv_check_cflags___Wsequence_point+:} false; then :
@@ -35001,42 +34929,6 @@ else
fi
- { $as_echo "$as_me:${as_lineno-$LINENO}: checking whether C compiler accepts -Wno-expansion-to-defined" >&5
-$as_echo_n "checking whether C compiler accepts -Wno-expansion-to-defined... " >&6; }
-if ${ax_cv_check_cflags___Wno_expansion_to_defined+:} false; then :
- $as_echo_n "(cached) " >&6
-else
-
- ax_check_save_flags=$CFLAGS
- CFLAGS="$CFLAGS -Wno-expansion-to-defined"
- cat confdefs.h - <<_ACEOF >conftest.$ac_ext
-/* end confdefs.h. */
-
-int
-main ()
-{
-
- ;
- return 0;
-}
-_ACEOF
-if ac_fn_c_try_compile "$LINENO"; then :
- ax_cv_check_cflags___Wno_expansion_to_defined=yes
-else
- ax_cv_check_cflags___Wno_expansion_to_defined=no
-fi
-rm -f core conftest.err conftest.$ac_objext conftest.$ac_ext
- CFLAGS=$ax_check_save_flags
-fi
-{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $ax_cv_check_cflags___Wno_expansion_to_defined" >&5
-$as_echo "$ax_cv_check_cflags___Wno_expansion_to_defined" >&6; }
-if test "x$ax_cv_check_cflags___Wno_expansion_to_defined" = xyes; then :
- as_fn_append CFLAGS " -Wno-expansion-to-defined"
-else
- :
-fi
-
-
ac_config_files="$ac_config_files Makefile libq/Makefile autotools/gnulib/Makefile tests/atom_explode/Makefile tests/copy_file/Makefile tests/mkdir/Makefile tests/rmspace/Makefile"