aboutsummaryrefslogtreecommitdiff
path: root/net-fs
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2022-07-19 13:34:56 -0400
committerAnthony G. Basile <blueness@gentoo.org>2022-07-19 13:34:56 -0400
commit12687968650c38f13b313c63bfb9ce552e8c5522 (patch)
tree652264a8bf43ed2a62369a30f9e50d3cc367da46 /net-fs
parentnet-fs/samba: sync with tree (diff)
downloadmusl-12687968650c38f13b313c63bfb9ce552e8c5522.tar.gz
musl-12687968650c38f13b313c63bfb9ce552e8c5522.tar.bz2
musl-12687968650c38f13b313c63bfb9ce552e8c5522.zip
net-fs/samba: add missing signal.h
Signed-off-by: Anthony G. Basile <blueness@gentoo.org>
Diffstat (limited to 'net-fs')
-rw-r--r--net-fs/samba/files/add-missing_signal_h.patch11
-rw-r--r--net-fs/samba/files/fix-musl-lib-without-innetgr.patch42
-rw-r--r--net-fs/samba/samba-4.15.7.ebuild2
3 files changed, 12 insertions, 43 deletions
diff --git a/net-fs/samba/files/add-missing_signal_h.patch b/net-fs/samba/files/add-missing_signal_h.patch
new file mode 100644
index 00000000..b6ea71c7
--- /dev/null
+++ b/net-fs/samba/files/add-missing_signal_h.patch
@@ -0,0 +1,11 @@
+diff -Naur samba-4.15.7.orig/source3/printing/samba-bgqd.c samba-4.15.7/source3/printing/samba-bgqd.c
+--- samba-4.15.7.orig/source3/printing/samba-bgqd.c 2022-03-15 09:19:34.136201100 -0400
++++ samba-4.15.7/source3/printing/samba-bgqd.c 2022-07-19 13:27:56.069779404 -0400
+@@ -15,6 +15,7 @@
+ * along with this program; if not, see <http://www.gnu.org/licenses/>.
+ */
+
++#include <signal.h>
+ #include "replace.h"
+ #include "system/filesys.h"
+ #include "lib/util/server_id.h"
diff --git a/net-fs/samba/files/fix-musl-lib-without-innetgr.patch b/net-fs/samba/files/fix-musl-lib-without-innetgr.patch
deleted file mode 100644
index fb12a10e..00000000
--- a/net-fs/samba/files/fix-musl-lib-without-innetgr.patch
+++ /dev/null
@@ -1,42 +0,0 @@
-From fcb8ecd530b2d151e373974741601483326f7528 Mon Sep 17 00:00:00 2001
-From: Changqing Li <changqing.li@windriver.com>
-Date: Thu, 27 Jun 2019 11:09:47 +0800
-Subject: [PATCH] samba: fix musl lib without innetgr
-
-Upstream-Status: Pending
-
-Signed-off-by: Changqing Li <changqing.li@windriver.com>
----
- lib/util/access.c | 2 +-
- source3/auth/user_util.c | 2 +-
- 2 file changed, 2 insertion(+), 2 deletion(-)
-
-diff --git a/lib/util/access.c b/lib/util/access.c
-index 7da0573..b94949e 100644
---- a/lib/util/access.c
-+++ b/lib/util/access.c
-@@ -112,7 +112,7 @@ static bool string_match(const char *tok,const char *s)
- return true;
- }
- } else if (tok[0] == '@') { /* netgroup: look it up */
--#ifdef HAVE_NETGROUP
-+#if defined(HAVE_NETGROUP) && defined(HAVE_INNETGR)
- DATA_BLOB tmp;
- char *mydomain = NULL;
- char *hostname = NULL;
-diff --git a/source3/auth/user_util.c b/source3/auth/user_util.c
-index a76b5d4..30f523d 100644
---- a/source3/auth/user_util.c
-+++ b/source3/auth/user_util.c
-@@ -148,7 +148,7 @@ static void store_map_in_gencache(TALLOC_CTX *ctx, const char *from, const char
-
- bool user_in_netgroup(TALLOC_CTX *ctx, const char *user, const char *ngname)
- {
--#ifdef HAVE_NETGROUP
-+#if defined(HAVE_NETGROUP) && defined(HAVE_INNETGR)
- static char *my_yp_domain = NULL;
- char *lowercase_user = NULL;
-
---
-2.7.4
-
diff --git a/net-fs/samba/samba-4.15.7.ebuild b/net-fs/samba/samba-4.15.7.ebuild
index 46fa6428..9ecb3bbf 100644
--- a/net-fs/samba/samba-4.15.7.ebuild
+++ b/net-fs/samba/samba-4.15.7.ebuild
@@ -183,7 +183,7 @@ src_prepare() {
if use elibc_musl ; then
eapply "${FILESDIR}"/add_missing___compar_fn_t.patch
- eapply "${FILESDIR}"/fix-musl-lib-without-innetgr.patch
+ eapply "${FILESDIR}"/add-missing_signal_h.patch
eapply "${FILESDIR}"/getpwent_r.patch
eapply "${FILESDIR}"/missing-headers.patch
eapply "${FILESDIR}"/musl_rm_unistd_incl.patch