aboutsummaryrefslogtreecommitdiff
path: root/net-fs
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2022-07-19 12:54:17 -0400
committerAnthony G. Basile <blueness@gentoo.org>2022-07-19 12:54:17 -0400
commit62cb1b05cdc491e2f8b3d641bb4890660c371670 (patch)
treec89010f2b66a697c2e3d8157cf12e4a514dd9954 /net-fs
parentsys-libs/tevent: in tree version 0.11.0 works (diff)
downloadmusl-62cb1b05cdc491e2f8b3d641bb4890660c371670.tar.gz
musl-62cb1b05cdc491e2f8b3d641bb4890660c371670.tar.bz2
musl-62cb1b05cdc491e2f8b3d641bb4890660c371670.zip
net-fs/samba: sync with tree
Signed-off-by: Anthony G. Basile <blueness@gentoo.org>
Diffstat (limited to 'net-fs')
-rw-r--r--net-fs/samba/Manifest2
-rw-r--r--net-fs/samba/metadata.xml5
-rw-r--r--net-fs/samba/samba-4.15.7.ebuild (renamed from net-fs/samba/samba-4.14.10-r1.ebuild)58
3 files changed, 28 insertions, 37 deletions
diff --git a/net-fs/samba/Manifest b/net-fs/samba/Manifest
index 43d9473c..03fe0620 100644
--- a/net-fs/samba/Manifest
+++ b/net-fs/samba/Manifest
@@ -1 +1 @@
-DIST samba-4.14.10.tar.gz 19134066 BLAKE2B c6daebc7abbf2ed371ed694e4478d05875d55f7c5a9f83461932eebd7fe9089ff15e0530555d468e64f897d4cadab86e8c0acbfbd20938b3be842cb4324486e2 SHA512 0e1dd386d185cf77a2be4155646e98b3218316b5c290358684ec8eed747ffea67aa7db0937edc971fb791dc47f0f51306db33eb3b8cb65cca8787f18fd4b7f1c
+DIST samba-4.15.7.tar.gz 19290930 BLAKE2B 4a295f79d38212d4c6917ed61a22e4204b5ea3d5e26f30b65d1e7e81842e92405870dd40fd4d05ec1126a532bdb1ddea300848387a4c64370ba5c2c1354ee8e5 SHA512 beffb09b5bcd62991398d39c7a8aec5fed0c51d550e2f0fb42b2e0a09094f4c6a8f29adf708c4969db12329f5c7343d2debd04315107b79bef59e99a4a7e4ce4
diff --git a/net-fs/samba/metadata.xml b/net-fs/samba/metadata.xml
index e871aa57..f0f5b091 100644
--- a/net-fs/samba/metadata.xml
+++ b/net-fs/samba/metadata.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="project">
<email>samba@gentoo.org</email>
@@ -10,17 +10,14 @@
</longdescription>
<use>
<flag name="addc">Enable Active Directory Domain Controller support</flag>
- <flag name="addns">Enable AD DNS integration</flag>
<flag name="ads">Enable Active Directory support</flag>
<flag name="ceph">Enable support for Ceph distributed filesystem via <pkg>sys-cluster/ceph</pkg></flag>
<flag name="client">Enables the client part</flag>
<flag name="cluster">Enable support for clustering</flag>
- <flag name="dmapi">Enable support for DMAPI. This currently works only in combination with XFS.</flag>
<flag name="glusterfs">Enable support for Glusterfs filesystem via <pkg>sys-cluster/glusterfs</pkg></flag>
<flag name="gpg">Use <pkg>app-crypt/gpgme</pkg> for AD DC</flag>
<flag name="json">Enable json audit support through <pkg>dev-libs/jansson</pkg></flag>
<flag name="iprint">Enabling iPrint technology by Novell</flag>
- <flag name="ntvfs">Enable support for NTVFS fileserver</flag>
<flag name="profiling-data">Enables support for collecting profiling data</flag>
<flag name="quota">Enables support for user quotas</flag>
<flag name="regedit">Enable support for regedit command-line tool</flag>
diff --git a/net-fs/samba/samba-4.14.10-r1.ebuild b/net-fs/samba/samba-4.15.7.ebuild
index 3e4cf54a..46fa6428 100644
--- a/net-fs/samba/samba-4.14.10-r1.ebuild
+++ b/net-fs/samba/samba-4.15.7.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{8..9} )
+PYTHON_COMPAT=( python3_{8..10} )
PYTHON_REQ_USE="threads(+),xml(+)"
inherit python-single-r1 waf-utils multilib-minimal linux-info systemd pam tmpfiles
@@ -16,24 +16,22 @@ if [[ ${PV} = *_rc* ]]; then
SRC_URI="mirror://samba/rc/${MY_P}.tar.gz"
else
SRC_URI="mirror://samba/stable/${MY_P}.tar.gz"
- KEYWORDS="amd64 arm arm64 ppc ppc64 x86"
+ KEYWORDS="amd64 arm arm64 ppc ppc64 x86"
fi
S="${WORKDIR}/${MY_P}"
LICENSE="GPL-3"
SLOT="0"
-IUSE="acl addc addns ads ceph client cluster cups debug dmapi fam glusterfs
-gpg iprint json ldap ntvfs pam profiling-data python quota +regedit selinux
+IUSE="acl addc ads ceph client cluster cpu_flags_x86_aes cups debug fam
+glusterfs gpg iprint json ldap pam profiling-data python quota +regedit selinux
snapper spotlight syslog system-heimdal +system-mitkrb5 systemd test winbind
zeroconf"
REQUIRED_USE="${PYTHON_REQUIRED_USE}
addc? ( python json winbind )
- addns? ( python )
- ads? ( acl ldap winbind )
+ ads? ( acl ldap python winbind )
cluster? ( ads )
gpg? ( addc )
- ntvfs? ( addc )
spotlight? ( json )
test? ( python )
!ads? ( !addc )
@@ -66,17 +64,16 @@ COMMON_DEPEND="
dev-libs/popt[${MULTILIB_USEDEP}]
dev-perl/Parse-Yapp
>=net-libs/gnutls-3.4.7[${MULTILIB_USEDEP}]
- net-libs/libnsl:=[${MULTILIB_USEDEP}]
- sys-libs/e2fsprogs-libs[${MULTILIB_USEDEP}]
- >=sys-libs/ldb-2.3.2[ldap(+)?,${MULTILIB_USEDEP}]
- <sys-libs/ldb-2.4.0[ldap(+)?,${MULTILIB_USEDEP}]
+ >=sys-fs/e2fsprogs-1.46.4-r51[${MULTILIB_USEDEP}]
+ >=sys-libs/ldb-2.4.2[ldap(+)?,${MULTILIB_USEDEP}]
+ <sys-libs/ldb-2.5.0[ldap(+)?,${MULTILIB_USEDEP}]
sys-libs/libcap[${MULTILIB_USEDEP}]
sys-libs/liburing:=[${MULTILIB_USEDEP}]
sys-libs/ncurses:0=
sys-libs/readline:0=
- >=sys-libs/talloc-2.3.2[${MULTILIB_USEDEP}]
- >=sys-libs/tdb-1.4.3[${MULTILIB_USEDEP}]
- >=sys-libs/tevent-0.10.2[${MULTILIB_USEDEP}]
+ >=sys-libs/talloc-2.3.3[${MULTILIB_USEDEP}]
+ >=sys-libs/tdb-1.4.4[${MULTILIB_USEDEP}]
+ >=sys-libs/tevent-0.11.0[${MULTILIB_USEDEP}]
sys-libs/zlib[${MULTILIB_USEDEP}]
virtual/libcrypt:=[${MULTILIB_USEDEP}]
virtual/libiconv
@@ -85,7 +82,7 @@ COMMON_DEPEND="
dev-python/dnspython:=[\${PYTHON_USEDEP}]
dev-python/markdown[\${PYTHON_USEDEP}]
)
- addns? (
+ ads? (
dev-python/dnspython:=[\${PYTHON_USEDEP}]
net-dns/bind-tools[gssapi]
)
@@ -96,11 +93,10 @@ COMMON_DEPEND="
cluster? ( net-libs/rpcsvc-proto )
cups? ( net-print/cups )
debug? ( dev-util/lttng-ust )
- dmapi? ( sys-apps/dmapi )
fam? ( virtual/fam )
- gpg? ( app-crypt/gpgme )
+ gpg? ( app-crypt/gpgme:= )
json? ( dev-libs/jansson:= )
- ldap? ( net-nds/openldap[${MULTILIB_USEDEP}] )
+ ldap? ( net-nds/openldap:=[${MULTILIB_USEDEP}] )
pam? ( sys-libs/pam )
python? (
sys-libs/ldb[python,${PYTHON_SINGLE_USEDEP}]
@@ -110,7 +106,7 @@ COMMON_DEPEND="
)
snapper? ( sys-apps/dbus )
system-heimdal? ( >=app-crypt/heimdal-1.5[-ssl,${MULTILIB_USEDEP}] )
- system-mitkrb5? ( >=app-crypt/mit-krb5-1.15.1[${MULTILIB_USEDEP}] )
+ system-mitkrb5? ( >=app-crypt/mit-krb5-1.19[${MULTILIB_USEDEP}] )
systemd? ( sys-apps/systemd:0= )
zeroconf? ( net-dns/avahi[dbus] )
"
@@ -144,9 +140,6 @@ BDEPEND="${PYTHON_DEPS}
PATCHES=(
"${FILESDIR}/${PN}-4.4.0-pam.patch"
-
- # https://bugs.gentoo.org/828063
- "${FILESDIR}/${P}-winbindd_regression_fix.patch"
)
#CONFDIR="${FILESDIR}/$(get_version_component_range 1-2)"
@@ -223,20 +216,19 @@ multilib_src_configure() {
--nopyc
--nopyo
--without-winexe
+ --accel-aes=$(usex cpu_flags_x86_aes intelaesni none)
$(multilib_native_use_with acl acl-support)
$(multilib_native_usex addc '' '--without-ad-dc')
- $(multilib_native_use_with addns dnsupdate)
$(multilib_native_use_with ads)
$(multilib_native_use_enable ceph cephfs)
$(multilib_native_use_with cluster cluster-support)
$(multilib_native_use_enable cups)
- $(multilib_native_use_with dmapi)
+ --without-dmapi
$(multilib_native_use_with fam)
$(multilib_native_use_enable glusterfs)
$(multilib_native_use_with gpg gpgme)
$(multilib_native_use_with json)
$(multilib_native_use_enable iprint)
- $(multilib_native_use_with ntvfs ntvfs-fileserver)
$(multilib_native_use_with pam)
$(multilib_native_usex pam "--with-pammodulesdir=${EPREFIX}/$(get_libdir)/security" '')
$(multilib_native_use_with quota quotas)
@@ -264,16 +256,16 @@ multilib_src_configure() {
myconf+=( --with-shared-modules=DEFAULT,!vfs_snapper )
fi
- CPPFLAGS="-I${SYSROOT}${EPREFIX}/usr/include/et ${CPPFLAGS}" \
+ PYTHONHASHSEED=1 CPPFLAGS="-I${ESYSROOT}/usr/include/et ${CPPFLAGS}" \
waf-utils_src_configure ${myconf[@]}
}
multilib_src_compile() {
- waf-utils_src_compile
+ PYTHONHASHSEED=1 waf-utils_src_compile
}
multilib_src_install() {
- waf-utils_src_install
+ PYTHONHASHSEED=1 waf-utils_src_install
# Make all .so files executable
find "${ED}" -type f -name "*.so" -exec chmod +x {} + || die
@@ -350,7 +342,9 @@ pkg_postinst() {
elog "controller work previously known as 'samba4'."
elog
fi
- elog "For further information and migration steps make sure to read "
- elog "https://samba.org/samba/history/${P}.html "
- elog "https://wiki.samba.org/index.php/Samba4/HOWTO "
+ if [[ "${PV}" != *_rc* ]] ; then
+ elog "For further information and migration steps make sure to read "
+ elog "https://samba.org/samba/history/${P}.html "
+ elog "https://wiki.samba.org/index.php/Samba4/HOWTO "
+ fi
}