aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2020-01-31 16:54:58 +0100
committerSebastian Pipping <sping@gentoo.org>2020-01-31 17:05:31 +0100
commit66dafddb0a92fbd670e6ca2dbe6d28282510898e (patch)
tree2e276bad1b6e85df43ff9785b429a22f5ca56a9f
parentMerge branch 'py3' (diff)
downloadmetagen-66dafddb0a92fbd670e6ca2dbe6d28282510898e.tar.gz
metagen-66dafddb0a92fbd670e6ca2dbe6d28282510898e.tar.bz2
metagen-66dafddb0a92fbd670e6ca2dbe6d28282510898e.zip
Add and integrate simple markdown readme for PyPI
Signed-off-by: Sebastian Pipping <sping@gentoo.org>
-rw-r--r--README.md66
-rwxr-xr-xsetup.py5
2 files changed, 71 insertions, 0 deletions
diff --git a/README.md b/README.md
new file mode 100644
index 0000000..8ae31b0
--- /dev/null
+++ b/README.md
@@ -0,0 +1,66 @@
+# About
+
+**metagen** is a command line utility to ease generation of
+[`metadata.xml` files](https://devmanual.gentoo.org/ebuild-writing/misc-files/metadata/index.html)
+for Gentoo packages.
+It is licensed under the
+[GPL v2 license](https://www.gnu.org/licenses/old-licenses/gpl-2.0.en.html)
+and hosted at
+[gitweb.gentoo.org](https://gitweb.gentoo.org/proj/metagen.git/).
+Please use [Gentoo's Bugzilla](https://bugs.gentoo.org/)
+to report bugs about **metagen**.
+
+
+# Example
+
+```
+# metagen -e 'somebody@gentoo.org' -n 'Some Body' -t person -f -q
+./metadata.xml written
+
+# cat metadata.xml
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata
+ SYSTEM 'http://www.gentoo.org/dtd/metadata.dtd'>
+<pkgmetadata>
+ <maintainer type="person">
+ <email>somebody@gentoo.org</email>
+ <name>Some Body</name>
+ </maintainer>
+</pkgmetadata>
+```
+
+
+# Usage
+
+```
+# metagen --help
+usage: metagen [-h] [--version] [--email EMAIL] [--name NAME] [--echangelog]
+ [--desc DESC] [--type TYPE] [--long LONG] [--output OUTPUT]
+ [--force] [--verbose] [--quiet] [-Q]
+
+optional arguments:
+ -h, --help show this help message and exit
+ --version show program's version number and exit
+
+maintainer arguments:
+ --email EMAIL, -e EMAIL
+ Maintainer's email address
+ --name NAME, -n NAME Maintainer's name
+ --echangelog, -m Use name and email address from ECHANGELOG_USER
+ environmental variable. This is a shortcut for -e
+ <email> -n <name>
+ --desc DESC, -d DESC Description of maintainership
+ --type TYPE, -t TYPE Maintainer type as of GLEP 67; valid values are:
+ "person", "project", "unknown"
+
+package arguments:
+ --long LONG, -l LONG Long description of package.
+
+operation arguments:
+ --output OUTPUT, -o OUTPUT
+ Specify location of output file.
+ --force, -f Force overwrite of existing metadata.
+ --verbose, -v Verbose. Output of file to stdout. (default)
+ --quiet, -q Squelch output of file to stdout.
+ -Q Do not write file to disk.
+```
diff --git a/setup.py b/setup.py
index 838c27a..e73d16a 100755
--- a/setup.py
+++ b/setup.py
@@ -51,11 +51,16 @@ def main():
name = pkgname,
version = version,
description = description,
+ long_description = open('README.md').read(),
+ long_description_content_type = 'text/markdown',
author = author,
author_email = author_email,
url=url,
license = license,
+ setup_requires = [
+ 'setuptools>=38.6.0', # for long_description_content_type
+ ],
install_requires = [
'lxml',
],