summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2022-04-01 16:49:40 +0200
committerUlrich Müller <ulm@gentoo.org>2022-04-01 16:49:40 +0200
commit2882817698fe548de56694c926162c6ec9e7475f (patch)
tree0b3d2269f8b8ba93d3ab42659cb101b3c7c15ac8
parentdev-lisp/clsql: Drop dependency on dev-db/oracle-instantclient-basic (diff)
downloadlisp-2882817698fe548de56694c926162c6ec9e7475f.tar.gz
lisp-2882817698fe548de56694c926162c6ec9e7475f.tar.bz2
lisp-2882817698fe548de56694c926162c6ec9e7475f.zip
dev-lisp/cl-plus-ssl: Drop ~sparc because of unkeyworded dependencies
Minor touchups to the ebuild. Signed-off-by: Ulrich Müller <ulm@gentoo.org>
-rw-r--r--dev-lisp/cl-plus-ssl/cl-plus-ssl-20081104.ebuild14
-rw-r--r--dev-lisp/cl-plus-ssl/cl-plus-ssl-9999.ebuild5
2 files changed, 9 insertions, 10 deletions
diff --git a/dev-lisp/cl-plus-ssl/cl-plus-ssl-20081104.ebuild b/dev-lisp/cl-plus-ssl/cl-plus-ssl-20081104.ebuild
index b6bf606f..31cd4b0a 100644
--- a/dev-lisp/cl-plus-ssl/cl-plus-ssl-20081104.ebuild
+++ b/dev-lisp/cl-plus-ssl/cl-plus-ssl-20081104.ebuild
@@ -1,21 +1,20 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit common-lisp-3 eutils multilib
+inherit common-lisp-3
MY_PN=cl+ssl
MY_P=${MY_PN}-${PV:0:4}-${PV:4:2}-${PV:6:2}
DESCRIPTION="A simple Common Lisp interface to OpenSSL."
-HOMEPAGE="http://common-lisp.net/project/cl-plus-ssl/"
-SRC_URI="http://common-lisp.net/project/cl-plus-ssl/download/${MY_P}.tar.gz"
+HOMEPAGE="https://cl-plus-ssl.common-lisp.dev/"
+SRC_URI="https://cl-plus-ssl.common-lisp.dev/download/${MY_P}.tar.gz"
LICENSE="MIT"
SLOT="0"
-KEYWORDS="~x86 ~sparc ~amd64 ~ppc"
-IUSE=""
+KEYWORDS="~amd64 ~ppc ~x86"
RDEPEND=">=dev-lisp/cffi-0.9.2_p20080723
dev-lisp/trivial-gray-streams
@@ -39,5 +38,6 @@ src_prepare() {
src_install() {
common-lisp-install-sources *.lisp
common-lisp-install-asdf
- dohtml index.{css,html}
+ docinto html
+ dodoc index.{css,html}
}
diff --git a/dev-lisp/cl-plus-ssl/cl-plus-ssl-9999.ebuild b/dev-lisp/cl-plus-ssl/cl-plus-ssl-9999.ebuild
index 862fe18f..fdfa828f 100644
--- a/dev-lisp/cl-plus-ssl/cl-plus-ssl-9999.ebuild
+++ b/dev-lisp/cl-plus-ssl/cl-plus-ssl-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -6,12 +6,11 @@ EAPI=6
inherit common-lisp-3 git-r3
DESCRIPTION="A simple Common Lisp interface to OpenSSL."
-HOMEPAGE="http://common-lisp.net/project/cl-plus-ssl/"
+HOMEPAGE="https://cl-plus-ssl.common-lisp.dev/"
EGIT_REPO_URI="https://github.com/${PN}/${PN}"
LICENSE="MIT"
SLOT="0"
-IUSE=""
RDEPEND=">=dev-lisp/cffi-0.9.2_p20080723
dev-lisp/trivial-garbage