summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2022-04-01 16:45:20 +0200
committerUlrich Müller <ulm@gentoo.org>2022-04-01 16:45:20 +0200
commitae2a13cdadc6ebc66c2a0a3d37f5a42e786c4e9b (patch)
tree64370c605a382a2e805181f1eab2ac2ee52ec8dd
parentdev-lisp/timer: Drop ~sparc because of unkeyworded dependencies (diff)
downloadlisp-ae2a13cdadc6ebc66c2a0a3d37f5a42e786c4e9b.tar.gz
lisp-ae2a13cdadc6ebc66c2a0a3d37f5a42e786c4e9b.tar.bz2
lisp-ae2a13cdadc6ebc66c2a0a3d37f5a42e786c4e9b.zip
dev-lisp/clsql: Drop dependency on dev-db/oracle-instantclient-basic
Signed-off-by: Ulrich Müller <ulm@gentoo.org>
-rw-r--r--dev-lisp/clsql/clsql-6.7.0.ebuild15
1 files changed, 8 insertions, 7 deletions
diff --git a/dev-lisp/clsql/clsql-6.7.0.ebuild b/dev-lisp/clsql/clsql-6.7.0.ebuild
index 3a160e87..8f5a84ae 100644
--- a/dev-lisp/clsql/clsql-6.7.0.ebuild
+++ b/dev-lisp/clsql/clsql-6.7.0.ebuild
@@ -1,27 +1,27 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit common-lisp-3 flag-o-matic multilib toolchain-funcs
+inherit common-lisp-3 flag-o-matic toolchain-funcs
DESCRIPTION="A multi-platform SQL interface for Common Lisp"
-HOMEPAGE="http://clsql.kpe.io/
- http://www.cliki.net/CLSQL"
+HOMEPAGE="https://clsql.kpe.io/
+ https://www.cliki.net/CLSQL"
SRC_URI="http://files.kpe.io/clsql/${P}.tar.gz"
LICENSE="LLGPL-2.1"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~sparc ~x86"
-IUSE="doc examples mysql odbc oracle postgres sqlite"
+IUSE="doc examples mysql odbc postgres sqlite"
RDEPEND="dev-lisp/md5
>=dev-lisp/uffi-2.0.0
mysql? ( virtual/mysql )
odbc? ( dev-db/unixODBC )
- oracle? ( dev-db/oracle-instantclient-basic )
postgres? ( dev-db/postgresql )
sqlite? ( dev-db/sqlite:3 )"
+ #oracle? ( dev-db/oracle-instantclient-basic )
src_prepare() {
sed -i "s,/usr/lib,/usr/$(get_libdir),g" "${S}"/${PN}-{mysql,uffi}.asd || die
@@ -76,7 +76,8 @@ src_install() {
exeinto /usr/$(get_libdir)/${PN} ; doexe uffi/${PN}_uffi.so
use postgres && install_clsql_postgresql
- for dbtype in mysql odbc oracle sqlite ; do
+ for dbtype in mysql odbc sqlite #oracle
+ do
use ${dbtype} && install_clsql_pkg ${dbtype}
done