summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2017-07-26 11:53:05 -0400
committerMichael Orlitzky <mjo@gentoo.org>2017-07-26 11:53:05 -0400
commit24b77433ba7a83847fda5a75663bf281a0b87c2a (patch)
tree814b764ab97b1c96ede5bc798dc17e5648aca142 /Makefile.am
parentInstall the php-fpm init scripts conditional on --enable-fpm. (diff)
downloadeselect-php-24b77433ba7a83847fda5a75663bf281a0b87c2a.tar.gz
eselect-php-24b77433ba7a83847fda5a75663bf281a0b87c2a.tar.bz2
eselect-php-24b77433ba7a83847fda5a75663bf281a0b87c2a.zip
Use "init.d" and "conf.d" subdirectories of "openrc".
OpenRC's init and conf files need to be named the same, and so we hit problems trying to store them both in the "openrc" directory. This commit puts the conf file in a "conf.d" subdirectory and the init script in an "init.d" subdirectory.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 4 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index 08359dc..1d3122a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -2,7 +2,7 @@ eselectdir = $(datadir)/eselect/modules
nodist_eselect_DATA = $(srcdir)/src/php.eselect
# Without EXTRA_DIST, these files don't wind up in the tarball.
-EXTRA_DIST = $(srcdir)/src/70_mod_php.conf.in openrc/*.*
+EXTRA_DIST = $(srcdir)/src/70_mod_php.conf.in openrc
if APACHE2
# Without these set, we won't try to install the conf file.
@@ -13,10 +13,10 @@ endif
if FPM
# Same as the APACHE2 conditional.
initdir = $(sysconfdir)/init.d
- nodist_init_SCRIPTS = $(srcdir)/openrc/php-fpm
+ nodist_init_SCRIPTS = $(srcdir)/openrc/init.d/php-fpm
confdir = $(sysconfdir)/conf.d
- nodist_conf_DATA = $(srcdir)/openrc/php-fpm.conf
+ nodist_conf_DATA = $(srcdir)/openrc/conf.d/php-fpm
endif
# The next few rules allow us to replace bindir, libdir, etc.
@@ -37,4 +37,4 @@ $(nodist_eselect_DATA) $(nodist_apacheconf_DATA) $(nodist_init_SCRIPTS): Makefil
$(srcdir)/src/php.eselect: $(srcdir)/src/php.eselect.in
$(srcdir)/src/70_mod_php.conf: $(srcdir)/src/70_mod_php.conf.in
-$(srcdir)/openrc/php-fpm: $(srcdir)/openrc/php-fpm.in
+$(srcdir)/openrc/init.d/php-fpm: $(srcdir)/openrc/init.d/php-fpm.in