summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2017-07-25 20:17:53 -0400
committerMichael Orlitzky <mjo@gentoo.org>2017-07-25 20:17:53 -0400
commit0b67931ad054c8d109ea89faa8844b1f5a02e8ec (patch)
treead30dd46e8792afa1e28d19abaf9cdd0470a86ff /Makefile.am
parentMakefile.am: mark openrc/php-fpm as a script and not as data. (diff)
downloadeselect-php-0b67931ad054c8d109ea89faa8844b1f5a02e8ec.tar.gz
eselect-php-0b67931ad054c8d109ea89faa8844b1f5a02e8ec.tar.bz2
eselect-php-0b67931ad054c8d109ea89faa8844b1f5a02e8ec.zip
Install the php-fpm init scripts conditional on --enable-fpm.0.9.3
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am13
1 files changed, 9 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index 15b0ca8..08359dc 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,9 +1,5 @@
eselectdir = $(datadir)/eselect/modules
nodist_eselect_DATA = $(srcdir)/src/php.eselect
-initdir = $(sysconfdir)/init.d
-confdir = $(sysconfdir)/conf.d
-nodist_init_SCRIPTS = $(srcdir)/openrc/php-fpm
-nodist_conf_DATA = $(srcdir)/openrc/php-fpm.conf
# Without EXTRA_DIST, these files don't wind up in the tarball.
EXTRA_DIST = $(srcdir)/src/70_mod_php.conf.in openrc/*.*
@@ -14,6 +10,15 @@ if APACHE2
nodist_apacheconf_DATA = $(srcdir)/src/70_mod_php.conf
endif
+if FPM
+ # Same as the APACHE2 conditional.
+ initdir = $(sysconfdir)/init.d
+ nodist_init_SCRIPTS = $(srcdir)/openrc/php-fpm
+
+ confdir = $(sysconfdir)/conf.d
+ nodist_conf_DATA = $(srcdir)/openrc/php-fpm.conf
+endif
+
# The next few rules allow us to replace bindir, libdir, etc.
# within our script and conf file. The example is taken
# from the autoconf documentation and can be found in the