summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2007-10-21 15:12:08 +0000
committerMart Raudsepp <leio@gentoo.org>2007-10-21 15:12:08 +0000
commit65eb0e1426c68d65a6655fa5d38d813d92503726 (patch)
treeeba542461f67f09d3a878c13a9ced77d3ff53405
parentKill digest files (diff)
downloadleio-65eb0e1426c68d65a6655fa5d38d813d92503726.tar.gz
leio-65eb0e1426c68d65a6655fa5d38d813d92503726.tar.bz2
leio-65eb0e1426c68d65a6655fa5d38d813d92503726.zip
Initial import of wxMUD to my overlay. This is a graphical MUD client with full MXP support and other things, maintained by me upstream
-rw-r--r--games-mud/wxmud/ChangeLog9
-rw-r--r--games-mud/wxmud/Manifest2
-rw-r--r--games-mud/wxmud/metadata.xml11
-rw-r--r--games-mud/wxmud/wxmud-9999.ebuild47
-rw-r--r--profiles/package.mask2
5 files changed, 70 insertions, 1 deletions
diff --git a/games-mud/wxmud/ChangeLog b/games-mud/wxmud/ChangeLog
new file mode 100644
index 0000000..6ca7e4d
--- /dev/null
+++ b/games-mud/wxmud/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for games-mud/wxmud
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+ 21 Oct 2007; Mart Raudsepp <leio@gentoo.org> +metadata.xml,
+ +wxmud-9999.ebuild:
+ Initial import of wxMUD to my overlay. This is a graphical MUD client with
+ full MXP support and other things, maintained by me upstream
+
diff --git a/games-mud/wxmud/Manifest b/games-mud/wxmud/Manifest
new file mode 100644
index 0000000..d60b4c1
--- /dev/null
+++ b/games-mud/wxmud/Manifest
@@ -0,0 +1,2 @@
+EBUILD wxmud-9999.ebuild 998 RMD160 0695aabe0b72bde57b7ab5ced51e830eb42b9f71 SHA1 2ac047208985cd56fa9c710f59d4d3344ce5a783 SHA256 dc427d75defb17ec10b3246e3b7e821e533231b714d3b61420bbe0f141ae8228
+MISC metadata.xml 388 RMD160 c39ae3eb3f0a2539b0f6e8ef6896c62a18d670db SHA1 f15f0e87e4189a9daa251138abbea2d74eadcfc6 SHA256 9c7fef05df7a4d723b31dd7bea2b64a2daab88cb2416048cc6bb309efdce6b7b
diff --git a/games-mud/wxmud/metadata.xml b/games-mud/wxmud/metadata.xml
new file mode 100644
index 0000000..edc0427
--- /dev/null
+++ b/games-mud/wxmud/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+ <email>leio@gentoo.org</email>
+</maintainer>
+<longdescription>
+wxMUD is an open source cross-platform graphical MUD client featuring ANSI color, MCCP, MXP and MSP support, among other features.
+</longdescription>
+</pkgmetadata>
diff --git a/games-mud/wxmud/wxmud-9999.ebuild b/games-mud/wxmud/wxmud-9999.ebuild
new file mode 100644
index 0000000..8a71706
--- /dev/null
+++ b/games-mud/wxmud/wxmud-9999.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+WANT_AUTOCONF=latest
+WANT_AUTOMAKE=latest
+inherit flag-o-matic subversion wxwidgets autotools
+
+DESCRIPTION="Cross-platform MUD client"
+HOMEPAGE="http://wxmud.sourceforge.net/"
+SRC_URI=""
+ESVN_REPO_URI="https://wxmud.svn.sourceforge.net/svnroot/wxmud/trunk"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="python"
+
+RDEPEND="=x11-libs/wxGTK-2.6*
+ >=x11-libs/gtk+-2.4
+ python? ( >=dev-lang/python-2.4 )"
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ WX_GTK_VER=2.6
+ need-wxwidgets unicode
+}
+
+src_unpack() {
+ subversion_src_unpack
+ cd "${S}"
+ AT_M4DIR="m4" eautoreconf
+}
+
+src_compile() {
+ append-flags -fno-strict-aliasing
+ econf --with-wx-config="${WX_CONFIG}" \
+ $(use_enable python) \
+ --disable-audiere \
+ || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS README TODO docs/input.txt docs/scripting.txt
+}
diff --git a/profiles/package.mask b/profiles/package.mask
index 7b65a61..82f5b18 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -1,4 +1,4 @@
# Mart Raudsepp <leio@gentoo.org> (08 Oct 2007)
# Live ebuild from a personal overlay
=media-plugins/gst-plugins-ffmpeg-9999
-
+=games-mud/wxmud-9999