summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-mud/wxmud/wxmud-9999.ebuild')
-rw-r--r--games-mud/wxmud/wxmud-9999.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/games-mud/wxmud/wxmud-9999.ebuild b/games-mud/wxmud/wxmud-9999.ebuild
new file mode 100644
index 0000000..8a71706
--- /dev/null
+++ b/games-mud/wxmud/wxmud-9999.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+WANT_AUTOCONF=latest
+WANT_AUTOMAKE=latest
+inherit flag-o-matic subversion wxwidgets autotools
+
+DESCRIPTION="Cross-platform MUD client"
+HOMEPAGE="http://wxmud.sourceforge.net/"
+SRC_URI=""
+ESVN_REPO_URI="https://wxmud.svn.sourceforge.net/svnroot/wxmud/trunk"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="python"
+
+RDEPEND="=x11-libs/wxGTK-2.6*
+ >=x11-libs/gtk+-2.4
+ python? ( >=dev-lang/python-2.4 )"
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ WX_GTK_VER=2.6
+ need-wxwidgets unicode
+}
+
+src_unpack() {
+ subversion_src_unpack
+ cd "${S}"
+ AT_M4DIR="m4" eautoreconf
+}
+
+src_compile() {
+ append-flags -fno-strict-aliasing
+ econf --with-wx-config="${WX_CONFIG}" \
+ $(use_enable python) \
+ --disable-audiere \
+ || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS README TODO docs/input.txt docs/scripting.txt
+}