summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2010-10-06 17:20:52 +0200
committerGilles Dartiguelongue <eva@gentoo.org>2010-10-06 17:20:52 +0200
commit769d0fa0227100b758871abb4454b1d66b7aabfa (patch)
tree4d572a88b98c369f3ab14189eebc5c330483fd4f /games-puzzle
parentnet-misc/rygel: version bump (diff)
downloadeva-769d0fa0227100b758871abb4454b1d66b7aabfa.tar.gz
eva-769d0fa0227100b758871abb4454b1d66b7aabfa.tar.bz2
eva-769d0fa0227100b758871abb4454b1d66b7aabfa.zip
games-puzzle/gbrainy: initial commit
Imported and updated from gentoo bug #195611.
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/gbrainy/Manifest2
-rw-r--r--games-puzzle/gbrainy/gbrainy-1.42.ebuild37
2 files changed, 39 insertions, 0 deletions
diff --git a/games-puzzle/gbrainy/Manifest b/games-puzzle/gbrainy/Manifest
new file mode 100644
index 0000000..a24fb70
--- /dev/null
+++ b/games-puzzle/gbrainy/Manifest
@@ -0,0 +1,2 @@
+DIST gbrainy-1.42.tar.gz 1276431 RMD160 0271071260ee48a3bce3d3d9b5c2914af0e0556f SHA1 607fd930cfea77a5f1676e90a825d3e746a267d0 SHA256 f6d0be192d73de55ca0e09dc8ddf21bea0ea3d7eaf01932135f7c8745e6d35f2
+EBUILD gbrainy-1.42.ebuild 840 RMD160 1da763d93984191a51c9a889deff96820d11d1e3 SHA1 8532fc2bc349c0008404b20860638a0f27e7f143 SHA256 f76ac9d8561676433b92439fc11236f3b54c7487ec73ebcb0a18e38b6e310e71
diff --git a/games-puzzle/gbrainy/gbrainy-1.42.ebuild b/games-puzzle/gbrainy/gbrainy-1.42.ebuild
new file mode 100644
index 0000000..ec2b22d
--- /dev/null
+++ b/games-puzzle/gbrainy/gbrainy-1.42.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+
+inherit games
+
+DESCRIPTION="gbrainy is a brain teaser game and trainer to have fun and to keep your brain trained."
+HOMEPAGE="http://live.gnome.org/gbrainy"
+SRC_URI="http://gent.softcatala.org/jmas/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~ppc"
+IUSE="plugins"
+
+RDEPEND="dev-libs/glib:2
+ >=dev-lang/mono-1.1.7
+ >=dev-dotnet/gtk-sharp-2.10
+ >=dev-dotnet/gnome-sharp-2.10
+ >=x11-libs/gtk+-2.8
+ >=gnome-base/librsvg-2.2
+ plugins? ( >=dev-dotnet/mono-addins-0.3 )"
+DEPEND="${DEPEND}
+ >=dev-util/intltool-0.35
+ app-text/gnome-doc-utils"
+
+src_configure() {
+ econf $(use_enable plugins addins)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ prepgamesdirs
+}
+