summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-puzzle/gbrainy/gbrainy-1.42.ebuild')
-rw-r--r--games-puzzle/gbrainy/gbrainy-1.42.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/games-puzzle/gbrainy/gbrainy-1.42.ebuild b/games-puzzle/gbrainy/gbrainy-1.42.ebuild
new file mode 100644
index 0000000..ec2b22d
--- /dev/null
+++ b/games-puzzle/gbrainy/gbrainy-1.42.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+
+inherit games
+
+DESCRIPTION="gbrainy is a brain teaser game and trainer to have fun and to keep your brain trained."
+HOMEPAGE="http://live.gnome.org/gbrainy"
+SRC_URI="http://gent.softcatala.org/jmas/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~ppc"
+IUSE="plugins"
+
+RDEPEND="dev-libs/glib:2
+ >=dev-lang/mono-1.1.7
+ >=dev-dotnet/gtk-sharp-2.10
+ >=dev-dotnet/gnome-sharp-2.10
+ >=x11-libs/gtk+-2.8
+ >=gnome-base/librsvg-2.2
+ plugins? ( >=dev-dotnet/mono-addins-0.3 )"
+DEPEND="${DEPEND}
+ >=dev-util/intltool-0.35
+ app-text/gnome-doc-utils"
+
+src_configure() {
+ econf $(use_enable plugins addins)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ prepgamesdirs
+}
+