summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDane Smith <c1pher@gentoo.org>2012-02-01 13:25:35 -0500
committerDane Smith <c1pher@gentoo.org>2012-02-01 13:25:35 -0500
commit627567e7409af40d2f715a05497b287a71e0100a (patch)
treecfc8cd0e5f222ef25cbbd2bd1af84a4e4c6f1377
parentFound a way to get their download links to work. Correct versioning (diff)
downloadc1pher-627567e7409af40d2f715a05497b287a71e0100a.tar.gz
c1pher-627567e7409af40d2f715a05497b287a71e0100a.tar.bz2
c1pher-627567e7409af40d2f715a05497b287a71e0100a.zip
Initial ebuild for indefero.
-rw-r--r--www-apps/indefero/Manifest4
-rw-r--r--www-apps/indefero/files/indefero-gentoo-pluf.diff13
-rw-r--r--www-apps/indefero/indefero-1.2.ebuild40
-rw-r--r--www-apps/indefero/metadata.xml10
4 files changed, 67 insertions, 0 deletions
diff --git a/www-apps/indefero/Manifest b/www-apps/indefero/Manifest
new file mode 100644
index 0000000..793c56c
--- /dev/null
+++ b/www-apps/indefero/Manifest
@@ -0,0 +1,4 @@
+AUX indefero-gentoo-pluf.diff 529 RMD160 c7e7ea57ee4b7aa362041a98f3c83f968a4cc01c SHA1 05bc152b1daf436f1b88fd6ee7ccb8498f059a42 SHA256 bda6a9135ec58dec74a6b677577904c566e8001b815712c8160a2c6c29cf7c25
+DIST indefero-1.2.zip 954890 RMD160 3d9272e1f95673ec7c0b9522494f70fe4c3c6af4 SHA1 962b7b542b62b5d9a3ffa4072e0c2f37be8dcbd6 SHA256 f67f542f6f253945d4b5ec7a2b81d842a63aa23200adef1cb2dede3d7bd15ef1
+EBUILD indefero-1.2.ebuild 941 RMD160 d368559084e545964d0f546200ee98c53064f77b SHA1 1ea180bbe08ebaa1db054c89aba6fcbdeb84bbc1 SHA256 ab43a45154d774e66877cacc317b5733af47f6f9ad2c50b21c0c9638242d0638
+MISC metadata.xml 252 RMD160 0d6b4d4e9e2fc0a9fc73289b6f3234195a3a1405 SHA1 6d719654a220ceff01851fa059936c79ca6bf9be SHA256 50fba57de1e11a48fbf58020c096095ebf9ec5defa2b5bcda9ed44e5be159d3f
diff --git a/www-apps/indefero/files/indefero-gentoo-pluf.diff b/www-apps/indefero/files/indefero-gentoo-pluf.diff
new file mode 100644
index 0000000..549260d
--- /dev/null
+++ b/www-apps/indefero/files/indefero-gentoo-pluf.diff
@@ -0,0 +1,13 @@
+diff --git a/src/IDF/conf/path.php-dist b/src/IDF/conf/path.php-dist
+index d8c90ca..9c566e4 100644
+--- a/src/IDF/conf/path.php-dist
++++ b/src/IDF/conf/path.php-dist
+@@ -29,7 +29,7 @@
+ * PLUF_PATH: path to the folder containing the Pluf.php file.
+ * IDF_PATH: path to the folder containing the IDF folder.
+ */
+-define('PLUF_PATH', dirname(__FILE__).'/../../../../pluf/src');
++define('PLUF_PATH', dirname(__FILE__).'/usr/share/php/pluf/');
+ define('IDF_PATH', dirname(__FILE__).'/../..');
+
+ set_include_path(get_include_path()
diff --git a/www-apps/indefero/indefero-1.2.ebuild b/www-apps/indefero/indefero-1.2.ebuild
new file mode 100644
index 0000000..f0a1290
--- /dev/null
+++ b/www-apps/indefero/indefero-1.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+inherit eutils webapp
+
+DESCRIPTION="An open source Google Code clone"
+HOMEPAGE="http://www.indefero.net/"
+SRC_URI="http://projects.ceondo.com/p/${PN}/downloads/get/${P}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+DEPEND="app-arch/unzip"
+RDEPEND="${DEPEND}
+ dev-lang/php[gd]
+ dev-php/pluf
+ "
+
+src_prepare(){
+ #Expect pluf to be installed in the normal location.
+ epatch "${FILESDIR}/${PN}-gentoo-pluf.diff"
+}
+
+src_install(){
+ webapp_src_preinst
+ rm COPYING INSTALL.mdtext
+ dodoc doc/* NEWS.mdtext AUTHORS CONTRIBUTE.mdtext
+ rm -rf doc
+ mv src/IDF/conf/idf.php-dist src/IDF/conf/idf.php
+
+ cp -R . "${D}/${MY_HTDOCSDIR}"
+ webapp_configfile "${MY_HTDOCSDIR}/src/IDF/conf/idf.php"
+ #Write a postinstall doc
+ #webapp_postinstall_txt en "${FILESDIR}/postinstall-en-${PV}.txt"
+ webapp_src_install
+}
diff --git a/www-apps/indefero/metadata.xml b/www-apps/indefero/metadata.xml
new file mode 100644
index 0000000..2ba872d
--- /dev/null
+++ b/www-apps/indefero/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>no-herd</herd>
+ <maintainer>
+ <email>c1pher@gentoo.org</email>
+ <name>Dane Smith</name>
+ </maintainer>
+</pkgmetadata>
+