summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-apps/indefero/indefero-1.2.ebuild')
-rw-r--r--www-apps/indefero/indefero-1.2.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/www-apps/indefero/indefero-1.2.ebuild b/www-apps/indefero/indefero-1.2.ebuild
new file mode 100644
index 0000000..f0a1290
--- /dev/null
+++ b/www-apps/indefero/indefero-1.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+inherit eutils webapp
+
+DESCRIPTION="An open source Google Code clone"
+HOMEPAGE="http://www.indefero.net/"
+SRC_URI="http://projects.ceondo.com/p/${PN}/downloads/get/${P}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+DEPEND="app-arch/unzip"
+RDEPEND="${DEPEND}
+ dev-lang/php[gd]
+ dev-php/pluf
+ "
+
+src_prepare(){
+ #Expect pluf to be installed in the normal location.
+ epatch "${FILESDIR}/${PN}-gentoo-pluf.diff"
+}
+
+src_install(){
+ webapp_src_preinst
+ rm COPYING INSTALL.mdtext
+ dodoc doc/* NEWS.mdtext AUTHORS CONTRIBUTE.mdtext
+ rm -rf doc
+ mv src/IDF/conf/idf.php-dist src/IDF/conf/idf.php
+
+ cp -R . "${D}/${MY_HTDOCSDIR}"
+ webapp_configfile "${MY_HTDOCSDIR}/src/IDF/conf/idf.php"
+ #Write a postinstall doc
+ #webapp_postinstall_txt en "${FILESDIR}/postinstall-en-${PV}.txt"
+ webapp_src_install
+}