summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-apps/xedit/xedit-1.0.0.ebuild')
-rw-r--r--x11-apps/xedit/xedit-1.0.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/x11-apps/xedit/xedit-1.0.0.ebuild b/x11-apps/xedit/xedit-1.0.0.ebuild
new file mode 100644
index 000000000000..59c1cac648df
--- /dev/null
+++ b/x11-apps/xedit/xedit-1.0.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xedit/xedit-1.0.0.ebuild,v 1.1 2005/12/18 19:32:03 joshuabaergen Exp $
+
+# Must be before x-modular eclass is inherited
+#SNAPSHOT="yes"
+
+inherit x-modular
+
+DESCRIPTION="X.Org xedit application"
+KEYWORDS="~amd64 ~mips ~sparc ~x86"
+IUSE="xprint"
+RDEPEND="x11-libs/libXprintUtil
+ x11-libs/libXaw
+ xprint? ( x11-libs/libXprintUtil )"
+DEPEND="${RDEPEND}"
+
+CONFIGURE_OPTIONS="$(use_enable xprint)"
+
+pkg_setup() {
+ if use xprint && ! built_with_use x11-libs/libXaw xprint; then
+ die "Build x11-libs/libXaw with USE=xprint."
+ fi
+}
+
+#src_compile() {
+# x-modular_src_configure
+# emake -j1 || die "emake failed"
+#}