summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/libperl/libperl-5.8.4.ebuild')
-rw-r--r--sys-devel/libperl/libperl-5.8.4.ebuild10
1 files changed, 8 insertions, 2 deletions
diff --git a/sys-devel/libperl/libperl-5.8.4.ebuild b/sys-devel/libperl/libperl-5.8.4.ebuild
index 3b33bf3c3cef..67d08a66dba4 100644
--- a/sys-devel/libperl/libperl-5.8.4.ebuild
+++ b/sys-devel/libperl/libperl-5.8.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/libperl/libperl-5.8.4.ebuild,v 1.15 2004/09/22 18:00:12 rac Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/libperl/libperl-5.8.4.ebuild,v 1.16 2004/09/27 11:33:08 mcummings Exp $
# The basic theory based on comments from Daniel Robbins <drobbins@gentoo.org>.
#
@@ -53,7 +53,7 @@
# Martin Schlemmer <azarah@gentoo.org> (28 Dec 2002).
# fix manifest
-IUSE="berkdb gdbm ithreads"
+IUSE="berkdb debug gdbm ithreads"
inherit eutils flag-o-matic
@@ -176,6 +176,12 @@ src_compile() {
# <rac@gentoo.org> 2003.06.26
myconf="${myconf} -Dd_u32align"
fi
+
+ if use debug
+ then
+ CFLAGS="${CFLAGS} -g"
+ fi
+
if use sparc
then
myconf="${myconf} -Ud_longdbl"