summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-lang/perl/ChangeLog7
-rw-r--r--dev-lang/perl/perl-5.8.2-r1.ebuild10
-rw-r--r--dev-lang/perl/perl-5.8.3.ebuild10
-rw-r--r--dev-lang/perl/perl-5.8.4-r1.ebuild10
-rw-r--r--dev-lang/perl/perl-5.8.4.ebuild10
-rw-r--r--dev-lang/perl/perl-5.8.5.ebuild10
-rw-r--r--sys-devel/libperl/ChangeLog8
-rw-r--r--sys-devel/libperl/libperl-5.8.2-r1.ebuild10
-rw-r--r--sys-devel/libperl/libperl-5.8.2.ebuild10
-rw-r--r--sys-devel/libperl/libperl-5.8.3.ebuild10
-rw-r--r--sys-devel/libperl/libperl-5.8.4-r1.ebuild10
-rw-r--r--sys-devel/libperl/libperl-5.8.4.ebuild10
-rw-r--r--sys-devel/libperl/libperl-5.8.5-r1.ebuild10
-rw-r--r--sys-devel/libperl/libperl-5.8.5.ebuild10
14 files changed, 109 insertions, 26 deletions
diff --git a/dev-lang/perl/ChangeLog b/dev-lang/perl/ChangeLog
index 2f0a0c5fb3f8..d2d3728426b7 100644
--- a/dev-lang/perl/ChangeLog
+++ b/dev-lang/perl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/perl
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/perl/ChangeLog,v 1.86 2004/09/25 00:46:57 rac Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/perl/ChangeLog,v 1.87 2004/09/27 11:33:14 mcummings Exp $
+
+ 27 Sep 2004; Michael Cummings <mcummings@gentoo.org> perl-5.8.2-r1.ebuild,
+ perl-5.8.3.ebuild, perl-5.8.4-r1.ebuild, perl-5.8.4.ebuild,
+ perl-5.8.5.ebuild:
+ Added perl debugging support, bug 60775
24 Sep 2004; Robert Coie <rac@gentoo.org> perl-5.8.4-r1.ebuild,
perl-5.8.5.ebuild:
diff --git a/dev-lang/perl/perl-5.8.2-r1.ebuild b/dev-lang/perl/perl-5.8.2-r1.ebuild
index 1912e6935567..2554d4165e8f 100644
--- a/dev-lang/perl/perl-5.8.2-r1.ebuild
+++ b/dev-lang/perl/perl-5.8.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/perl/perl-5.8.2-r1.ebuild,v 1.19 2004/09/22 17:52:01 rac Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/perl/perl-5.8.2-r1.ebuild,v 1.20 2004/09/27 11:33:14 mcummings Exp $
inherit eutils flag-o-matic gcc
@@ -17,7 +17,7 @@ SLOT="0"
LIBPERL="libperl.so.${PERLSLOT}.${SHORT_PV}"
LICENSE="Artistic GPL-2"
KEYWORDS="x86 amd64 sparc ppc alpha mips hppa ia64 ppc64"
-IUSE="berkdb doc gdbm ithreads uclibc"
+IUSE="berkdb debug doc gdbm ithreads uclibc"
DEPEND="!uclibc? ( sys-apps/groff )
berkdb? ( sys-libs/db )
@@ -144,6 +144,12 @@ src_compile() {
# <rac@gentoo.org> 2003.06.26
myconf="${myconf} -Dd_u32align"
fi
+
+ if use debug
+ then
+ CFLAGS="${CFLAGS} -g"
+ fi
+
if use sparc
then
myconf="${myconf} -Ud_longdbl"
diff --git a/dev-lang/perl/perl-5.8.3.ebuild b/dev-lang/perl/perl-5.8.3.ebuild
index 1f271ca09deb..929b1a5a47c4 100644
--- a/dev-lang/perl/perl-5.8.3.ebuild
+++ b/dev-lang/perl/perl-5.8.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/perl/perl-5.8.3.ebuild,v 1.12 2004/09/22 17:52:01 rac Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/perl/perl-5.8.3.ebuild,v 1.13 2004/09/27 11:33:14 mcummings Exp $
inherit eutils flag-o-matic gcc
@@ -17,7 +17,7 @@ LIBPERL="libperl.so.${PERLSLOT}.${SHORT_PV}"
LICENSE="Artistic GPL-2"
SLOT="0"
KEYWORDS="~x86 ~ppc ~ppc64 ~sparc ~mips ~alpha arm ~hppa ~amd64 ~ia64 s390"
-IUSE="berkdb doc gdbm ithreads"
+IUSE="berkdb debug doc gdbm ithreads"
DEPEND="sys-apps/groff
berkdb? ( sys-libs/db )
@@ -143,6 +143,12 @@ src_compile() {
# <rac@gentoo.org> 2003.06.26
myconf="${myconf} -Dd_u32align"
fi
+
+ if use debug
+ then
+ CFLAGS="${CFLAGS} -g"
+ fi
+
if use sparc
then
myconf="${myconf} -Ud_longdbl"
diff --git a/dev-lang/perl/perl-5.8.4-r1.ebuild b/dev-lang/perl/perl-5.8.4-r1.ebuild
index abe7fc7a7faa..31b78bdba420 100644
--- a/dev-lang/perl/perl-5.8.4-r1.ebuild
+++ b/dev-lang/perl/perl-5.8.4-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/perl/perl-5.8.4-r1.ebuild,v 1.12 2004/09/25 00:46:57 rac Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/perl/perl-5.8.4-r1.ebuild,v 1.13 2004/09/27 11:33:14 mcummings Exp $
inherit eutils flag-o-matic gcc
@@ -17,7 +17,7 @@ LIBPERL="libperl.so.${PERLSLOT}.${SHORT_PV}"
LICENSE="Artistic GPL-2"
SLOT="0"
KEYWORDS="x86 ~ppc sparc mips alpha arm ~hppa amd64 ~ia64 ~ppc64 ~s390"
-IUSE="berkdb doc gdbm ithreads uclibc"
+IUSE="berkdb debug doc gdbm ithreads uclibc"
DEPEND="!uclibc? ( sys-apps/groff )
berkdb? ( sys-libs/db )
@@ -166,6 +166,12 @@ src_configure() {
# <rac@gentoo.org> 2003.06.26
myconf="${myconf} -Dd_u32align"
fi
+
+ if use debug
+ then
+ CFLAGS="${CFLAGS} -g"
+ fi
+
if use sparc
then
myconf="${myconf} -Ud_longdbl"
diff --git a/dev-lang/perl/perl-5.8.4.ebuild b/dev-lang/perl/perl-5.8.4.ebuild
index 8c67fbca83a4..6801ede252b8 100644
--- a/dev-lang/perl/perl-5.8.4.ebuild
+++ b/dev-lang/perl/perl-5.8.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/perl/perl-5.8.4.ebuild,v 1.23 2004/09/22 17:52:01 rac Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/perl/perl-5.8.4.ebuild,v 1.24 2004/09/27 11:33:14 mcummings Exp $
inherit eutils flag-o-matic gcc
@@ -17,7 +17,7 @@ LIBPERL="libperl.so.${PERLSLOT}.${SHORT_PV}"
LICENSE="Artistic GPL-2"
SLOT="0"
KEYWORDS="x86 ~ppc sparc ~mips alpha ~arm hppa amd64 ~ia64 ~ppc64 s390"
-IUSE="berkdb doc gdbm ithreads uclibc"
+IUSE="berkdb debug doc gdbm ithreads uclibc"
DEPEND="!uclibc? ( sys-apps/groff )
berkdb? ( sys-libs/db )
@@ -155,6 +155,12 @@ src_compile() {
# <rac@gentoo.org> 2003.06.26
myconf="${myconf} -Dd_u32align"
fi
+
+ if use debug
+ then
+ CFLAGS="${CFLAGS} -g"
+ fi
+
if use sparc
then
myconf="${myconf} -Ud_longdbl"
diff --git a/dev-lang/perl/perl-5.8.5.ebuild b/dev-lang/perl/perl-5.8.5.ebuild
index dfaed869c84d..2d3ba854375f 100644
--- a/dev-lang/perl/perl-5.8.5.ebuild
+++ b/dev-lang/perl/perl-5.8.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/perl/perl-5.8.5.ebuild,v 1.6 2004/09/25 00:46:57 rac Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/perl/perl-5.8.5.ebuild,v 1.7 2004/09/27 11:33:14 mcummings Exp $
inherit eutils flag-o-matic gcc
@@ -17,7 +17,7 @@ LIBPERL="libperl.so.${PERLSLOT}.${SHORT_PV}"
LICENSE="Artistic GPL-2"
SLOT="0"
KEYWORDS="~x86 ~ppc ~sparc ~mips ~alpha ~arm ~hppa ~amd64 ~ia64 ~ppc64 ~s390"
-IUSE="berkdb doc gdbm ithreads uclibc"
+IUSE="berkdb debug doc gdbm ithreads uclibc"
DEPEND="!uclibc? ( sys-apps/groff )
berkdb? ( sys-libs/db )
@@ -159,6 +159,12 @@ src_configure() {
# <rac@gentoo.org> 2003.06.26
myconf="${myconf} -Dd_u32align"
fi
+
+ if use debug
+ then
+ CFLAGS="${CFLAGS} -g"
+ fi
+
if use sparc
then
myconf="${myconf} -Ud_longdbl"
diff --git a/sys-devel/libperl/ChangeLog b/sys-devel/libperl/ChangeLog
index 9923f7fe4d45..d1b803216e21 100644
--- a/sys-devel/libperl/ChangeLog
+++ b/sys-devel/libperl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-devel/libperl
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/libperl/ChangeLog,v 1.48 2004/09/22 18:00:12 rac Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/libperl/ChangeLog,v 1.49 2004/09/27 11:33:08 mcummings Exp $
+
+ 27 Sep 2004; Michael Cummings <mcummings@gentoo.org>
+ libperl-5.8.2-r1.ebuild, libperl-5.8.2.ebuild, libperl-5.8.3.ebuild,
+ libperl-5.8.4-r1.ebuild, libperl-5.8.4.ebuild, libperl-5.8.5-r1.ebuild,
+ libperl-5.8.5.ebuild:
+ Added perl debugging support, bug 60775
22 Sep 2004; Robert Coie <rac@gentoo.org> libperl-5.8.2-r1.ebuild,
libperl-5.8.2.ebuild, libperl-5.8.3.ebuild, libperl-5.8.4-r1.ebuild,
diff --git a/sys-devel/libperl/libperl-5.8.2-r1.ebuild b/sys-devel/libperl/libperl-5.8.2-r1.ebuild
index 31c2d81f643b..8ad05794cba5 100644
--- a/sys-devel/libperl/libperl-5.8.2-r1.ebuild
+++ b/sys-devel/libperl/libperl-5.8.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/libperl/libperl-5.8.2-r1.ebuild,v 1.7 2004/09/22 18:00:12 rac Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/libperl/libperl-5.8.2-r1.ebuild,v 1.8 2004/09/27 11:33:08 mcummings Exp $
# The basic theory based on comments from Daniel Robbins <drobbins@gentoo.org>.
#
@@ -52,7 +52,7 @@
#
# Martin Schlemmer <azarah@gentoo.org> (28 Dec 2002).
-IUSE="berkdb gdbm ithreads uclibc"
+IUSE="berkdb debug gdbm ithreads uclibc"
inherit eutils flag-o-matic
@@ -172,6 +172,12 @@ src_compile() {
# <rac@gentoo.org> 2003.06.26
myconf="${myconf} -Dd_u32align"
fi
+
+ if use debug
+ then
+ CFLAGS="${CFLAGS} -g"
+ fi
+
if use sparc
then
myconf="${myconf} -Ud_longdbl"
diff --git a/sys-devel/libperl/libperl-5.8.2.ebuild b/sys-devel/libperl/libperl-5.8.2.ebuild
index 6babf1e53a13..91e41df648d6 100644
--- a/sys-devel/libperl/libperl-5.8.2.ebuild
+++ b/sys-devel/libperl/libperl-5.8.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/libperl/libperl-5.8.2.ebuild,v 1.18 2004/09/22 18:00:12 rac Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/libperl/libperl-5.8.2.ebuild,v 1.19 2004/09/27 11:33:08 mcummings Exp $
# The basic theory based on comments from Daniel Robbins <drobbins@gentoo.org>.
#
@@ -52,7 +52,7 @@
#
# Martin Schlemmer <azarah@gentoo.org> (28 Dec 2002).
-IUSE="berkdb gdbm ithreads"
+IUSE="berkdb debug gdbm ithreads"
inherit eutils flag-o-matic
@@ -169,6 +169,12 @@ src_compile() {
# <rac@gentoo.org> 2003.06.26
myconf="${myconf} -Dd_u32align"
fi
+
+ if use debug
+ then
+ CFLAGS="${CFLAGS} -g"
+ fi
+
if use sparc
then
myconf="${myconf} -Ud_longdbl"
diff --git a/sys-devel/libperl/libperl-5.8.3.ebuild b/sys-devel/libperl/libperl-5.8.3.ebuild
index 98eed889d4dd..162d9182a5f2 100644
--- a/sys-devel/libperl/libperl-5.8.3.ebuild
+++ b/sys-devel/libperl/libperl-5.8.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/libperl/libperl-5.8.3.ebuild,v 1.12 2004/09/22 18:00:12 rac Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/libperl/libperl-5.8.3.ebuild,v 1.13 2004/09/27 11:33:08 mcummings Exp $
# The basic theory based on comments from Daniel Robbins <drobbins@gentoo.org>.
#
@@ -52,7 +52,7 @@
#
# Martin Schlemmer <azarah@gentoo.org> (28 Dec 2002).
-IUSE="berkdb gdbm ithreads"
+IUSE="berkdb debug gdbm ithreads"
inherit eutils flag-o-matic
@@ -169,6 +169,12 @@ src_compile() {
# <rac@gentoo.org> 2003.06.26
myconf="${myconf} -Dd_u32align"
fi
+
+ if use debug
+ then
+ CFLAGS="${CFLAGS} -g"
+ fi
+
if use sparc
then
myconf="${myconf} -Ud_longdbl"
diff --git a/sys-devel/libperl/libperl-5.8.4-r1.ebuild b/sys-devel/libperl/libperl-5.8.4-r1.ebuild
index 6fd4063c1f5e..f99b0145282e 100644
--- a/sys-devel/libperl/libperl-5.8.4-r1.ebuild
+++ b/sys-devel/libperl/libperl-5.8.4-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/libperl/libperl-5.8.4-r1.ebuild,v 1.12 2004/09/22 18:00:12 rac Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/libperl/libperl-5.8.4-r1.ebuild,v 1.13 2004/09/27 11:33:08 mcummings Exp $
# The basic theory based on comments from Daniel Robbins <drobbins@gentoo.org>.
#
@@ -52,7 +52,7 @@
#
# Martin Schlemmer <azarah@gentoo.org> (28 Dec 2002).
-IUSE="berkdb gdbm ithreads uclibc"
+IUSE="berkdb debug gdbm ithreads uclibc"
inherit eutils flag-o-matic
@@ -180,6 +180,12 @@ src_compile() {
# <rac@gentoo.org> 2003.06.26
myconf="${myconf} -Dd_u32align"
fi
+
+ if use debug
+ then
+ CFLAGS="${CFLAGS} -g"
+ fi
+
if use sparc
then
myconf="${myconf} -Ud_longdbl"
diff --git a/sys-devel/libperl/libperl-5.8.4.ebuild b/sys-devel/libperl/libperl-5.8.4.ebuild
index 3b33bf3c3cef..67d08a66dba4 100644
--- a/sys-devel/libperl/libperl-5.8.4.ebuild
+++ b/sys-devel/libperl/libperl-5.8.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/libperl/libperl-5.8.4.ebuild,v 1.15 2004/09/22 18:00:12 rac Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/libperl/libperl-5.8.4.ebuild,v 1.16 2004/09/27 11:33:08 mcummings Exp $
# The basic theory based on comments from Daniel Robbins <drobbins@gentoo.org>.
#
@@ -53,7 +53,7 @@
# Martin Schlemmer <azarah@gentoo.org> (28 Dec 2002).
# fix manifest
-IUSE="berkdb gdbm ithreads"
+IUSE="berkdb debug gdbm ithreads"
inherit eutils flag-o-matic
@@ -176,6 +176,12 @@ src_compile() {
# <rac@gentoo.org> 2003.06.26
myconf="${myconf} -Dd_u32align"
fi
+
+ if use debug
+ then
+ CFLAGS="${CFLAGS} -g"
+ fi
+
if use sparc
then
myconf="${myconf} -Ud_longdbl"
diff --git a/sys-devel/libperl/libperl-5.8.5-r1.ebuild b/sys-devel/libperl/libperl-5.8.5-r1.ebuild
index 0c17bb135a38..2094ff13da40 100644
--- a/sys-devel/libperl/libperl-5.8.5-r1.ebuild
+++ b/sys-devel/libperl/libperl-5.8.5-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/libperl/libperl-5.8.5-r1.ebuild,v 1.1 2004/09/22 17:40:02 rac Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/libperl/libperl-5.8.5-r1.ebuild,v 1.2 2004/09/27 11:33:08 mcummings Exp $
# The basic theory based on comments from Daniel Robbins <drobbins@gentoo.org>.
#
@@ -52,7 +52,7 @@
#
# Martin Schlemmer <azarah@gentoo.org> (28 Dec 2002).
-IUSE="berkdb gdbm ithreads uclibc"
+IUSE="berkdb debug gdbm ithreads uclibc"
inherit eutils flag-o-matic
@@ -182,6 +182,12 @@ src_compile() {
# <rac@gentoo.org> 2003.06.26
myconf="${myconf} -Dd_u32align"
fi
+
+ if use debug
+ then
+ CFLAGS="${CFLAGS} -g"
+ fi
+
if use sparc
then
myconf="${myconf} -Ud_longdbl"
diff --git a/sys-devel/libperl/libperl-5.8.5.ebuild b/sys-devel/libperl/libperl-5.8.5.ebuild
index 5786bb3b3894..1079e45602a8 100644
--- a/sys-devel/libperl/libperl-5.8.5.ebuild
+++ b/sys-devel/libperl/libperl-5.8.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/libperl/libperl-5.8.5.ebuild,v 1.4 2004/09/22 18:00:12 rac Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/libperl/libperl-5.8.5.ebuild,v 1.5 2004/09/27 11:33:08 mcummings Exp $
# The basic theory based on comments from Daniel Robbins <drobbins@gentoo.org>.
#
@@ -52,7 +52,7 @@
#
# Martin Schlemmer <azarah@gentoo.org> (28 Dec 2002).
-IUSE="berkdb gdbm ithreads uclibc"
+IUSE="berkdb debug gdbm ithreads uclibc"
inherit eutils flag-o-matic
@@ -180,6 +180,12 @@ src_compile() {
# <rac@gentoo.org> 2003.06.26
myconf="${myconf} -Dd_u32align"
fi
+
+ if use debug
+ then
+ CFLAGS="${CFLAGS} -g"
+ fi
+
if use sparc
then
myconf="${myconf} -Ud_longdbl"