summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/fail2ban/ChangeLog6
-rw-r--r--net-analyzer/fail2ban/fail2ban-0.8.4-r1.ebuild14
-rw-r--r--net-analyzer/fail2ban/fail2ban-0.8.4-r2.ebuild12
-rw-r--r--net-analyzer/fail2ban/fail2ban-0.8.4.ebuild18
4 files changed, 37 insertions, 13 deletions
diff --git a/net-analyzer/fail2ban/ChangeLog b/net-analyzer/fail2ban/ChangeLog
index e95ba764ffc0..f7d3de73adf3 100644
--- a/net-analyzer/fail2ban/ChangeLog
+++ b/net-analyzer/fail2ban/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-analyzer/fail2ban
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/fail2ban/ChangeLog,v 1.63 2011/02/10 23:35:21 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/fail2ban/ChangeLog,v 1.64 2011/03/11 20:56:27 arfrever Exp $
+
+ 11 Mar 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ fail2ban-0.8.4.ebuild, fail2ban-0.8.4-r1.ebuild, fail2ban-0.8.4-r2.ebuild:
+ Use Python 2 (bug #315073).
10 Feb 2011; Markos Chandras <hwoarang@gentoo.org> fail2ban-0.8.4-r2.ebuild:
Stable on amd64 wrt bug #351803
diff --git a/net-analyzer/fail2ban/fail2ban-0.8.4-r1.ebuild b/net-analyzer/fail2ban/fail2ban-0.8.4-r1.ebuild
index 166a2e13f09e..d1f8cd1be459 100644
--- a/net-analyzer/fail2ban/fail2ban-0.8.4-r1.ebuild
+++ b/net-analyzer/fail2ban/fail2ban-0.8.4-r1.ebuild
@@ -1,9 +1,8 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/fail2ban/fail2ban-0.8.4-r1.ebuild,v 1.1 2010/11/05 15:05:51 hwoarang Exp $
-
-EAPI=2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/fail2ban/fail2ban-0.8.4-r1.ebuild,v 1.2 2011/03/11 20:56:27 arfrever Exp $
+EAPI="3"
PYTHON_DEPEND="2"
inherit distutils eutils
@@ -21,6 +20,11 @@ RDEPEND="net-misc/whois
virtual/mta
net-firewall/iptables"
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
src_prepare() {
epatch "${FILESDIR}"/${P}-hashlib.patch \
"${FILESDIR}"/${P}-sshd-breakin.patch
@@ -51,6 +55,8 @@ pkg_preinst() {
}
pkg_postinst() {
+ distutils_pkg_postinst
+
if [[ $previous_less_than_0_7 = 0 ]] ; then
elog
elog "Configuration files are now in /etc/fail2ban/"
diff --git a/net-analyzer/fail2ban/fail2ban-0.8.4-r2.ebuild b/net-analyzer/fail2ban/fail2ban-0.8.4-r2.ebuild
index 40c3b87a9883..0427287e0d5b 100644
--- a/net-analyzer/fail2ban/fail2ban-0.8.4-r2.ebuild
+++ b/net-analyzer/fail2ban/fail2ban-0.8.4-r2.ebuild
@@ -1,9 +1,8 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/fail2ban/fail2ban-0.8.4-r2.ebuild,v 1.4 2011/02/10 23:35:21 hwoarang Exp $
-
-EAPI=2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/fail2ban/fail2ban-0.8.4-r2.ebuild,v 1.5 2011/03/11 20:56:27 arfrever Exp $
+EAPI="3"
PYTHON_DEPEND="2"
inherit distutils eutils
@@ -21,6 +20,11 @@ RDEPEND="net-misc/whois
virtual/mta
net-firewall/iptables"
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
src_prepare() {
epatch "${FILESDIR}"/${P}-hashlib.patch \
"${FILESDIR}"/${P}-sshd-breakin.patch \
@@ -48,6 +52,8 @@ pkg_preinst() {
}
pkg_postinst() {
+ distutils_pkg_postinst
+
if [[ $previous_less_than_0_7 = 0 ]] ; then
elog
elog "Configuration files are now in /etc/fail2ban/"
diff --git a/net-analyzer/fail2ban/fail2ban-0.8.4.ebuild b/net-analyzer/fail2ban/fail2ban-0.8.4.ebuild
index fc2465c5c7b7..acaafa501762 100644
--- a/net-analyzer/fail2ban/fail2ban-0.8.4.ebuild
+++ b/net-analyzer/fail2ban/fail2ban-0.8.4.ebuild
@@ -1,6 +1,9 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/fail2ban/fail2ban-0.8.4.ebuild,v 1.6 2010/01/06 19:54:48 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/fail2ban/fail2ban-0.8.4.ebuild,v 1.7 2011/03/11 20:56:27 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
inherit distutils
@@ -13,11 +16,14 @@ SLOT="0"
KEYWORDS="amd64 hppa ppc ppc64 ~sparc x86 ~x86-fbsd"
IUSE=""
-DEPEND=">=dev-lang/python-2.4"
-RDEPEND="${DEPEND}
- net-misc/whois
+RDEPEND="net-misc/whois
virtual/mta"
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
src_install() {
distutils_src_install
@@ -42,6 +48,8 @@ pkg_preinst() {
}
pkg_postinst() {
+ distutils_pkg_postinst
+
if [[ $previous_less_than_0_7 = 0 ]] ; then
elog
elog "Configuration files are now in /etc/fail2ban/"