summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/fail2ban/fail2ban-0.8.4-r2.ebuild')
-rw-r--r--net-analyzer/fail2ban/fail2ban-0.8.4-r2.ebuild12
1 files changed, 9 insertions, 3 deletions
diff --git a/net-analyzer/fail2ban/fail2ban-0.8.4-r2.ebuild b/net-analyzer/fail2ban/fail2ban-0.8.4-r2.ebuild
index 40c3b87a9883..0427287e0d5b 100644
--- a/net-analyzer/fail2ban/fail2ban-0.8.4-r2.ebuild
+++ b/net-analyzer/fail2ban/fail2ban-0.8.4-r2.ebuild
@@ -1,9 +1,8 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/fail2ban/fail2ban-0.8.4-r2.ebuild,v 1.4 2011/02/10 23:35:21 hwoarang Exp $
-
-EAPI=2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/fail2ban/fail2ban-0.8.4-r2.ebuild,v 1.5 2011/03/11 20:56:27 arfrever Exp $
+EAPI="3"
PYTHON_DEPEND="2"
inherit distutils eutils
@@ -21,6 +20,11 @@ RDEPEND="net-misc/whois
virtual/mta
net-firewall/iptables"
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
src_prepare() {
epatch "${FILESDIR}"/${P}-hashlib.patch \
"${FILESDIR}"/${P}-sshd-breakin.patch \
@@ -48,6 +52,8 @@ pkg_preinst() {
}
pkg_postinst() {
+ distutils_pkg_postinst
+
if [[ $previous_less_than_0_7 = 0 ]] ; then
elog
elog "Configuration files are now in /etc/fail2ban/"