summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/cherrypy/ChangeLog8
-rw-r--r--dev-python/cherrypy/cherrypy-2.3.0.ebuild46
-rw-r--r--dev-python/cherrypy/cherrypy-3.1.2.ebuild35
3 files changed, 53 insertions, 36 deletions
diff --git a/dev-python/cherrypy/ChangeLog b/dev-python/cherrypy/ChangeLog
index 1727a33ffa11..bcdfea5b1f9c 100644
--- a/dev-python/cherrypy/ChangeLog
+++ b/dev-python/cherrypy/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/cherrypy
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/cherrypy/ChangeLog,v 1.38 2009/11/26 17:25:22 armin76 Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/cherrypy/ChangeLog,v 1.39 2010/04/02 18:49:55 arfrever Exp $
+
+ 02 Apr 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ cherrypy-2.3.0.ebuild, cherrypy-3.1.2.ebuild:
+ Set SUPPORT_PYTHON_ABIS.
26 Nov 2009; Raúl Porcel <armin76@gentoo.org> cherrypy-3.1.2.ebuild:
ia64 stable wrt #294109
diff --git a/dev-python/cherrypy/cherrypy-2.3.0.ebuild b/dev-python/cherrypy/cherrypy-2.3.0.ebuild
index 695d96fe7cc6..d61e2448153a 100644
--- a/dev-python/cherrypy/cherrypy-2.3.0.ebuild
+++ b/dev-python/cherrypy/cherrypy-2.3.0.ebuild
@@ -1,35 +1,39 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/cherrypy/cherrypy-2.3.0.ebuild,v 1.2 2009/02/15 14:31:56 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/cherrypy/cherrypy-2.3.0.ebuild,v 1.3 2010/04/02 18:49:55 arfrever Exp $
-inherit eutils distutils
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
-MY_P=CherryPy-${PV}
+inherit distutils eutils
+
+MY_P="CherryPy-${PV}"
DESCRIPTION="CherryPy is a pythonic, object-oriented web development framework."
-SRC_URI="http://download.cherrypy.org/cherrypy/${PV}/${MY_P}.tar.gz"
-HOMEPAGE="http://www.cherrypy.org/"
-IUSE="doc test"
+HOMEPAGE="http://www.cherrypy.org/ http://pypi.python.org/pypi/CherryPy"
+SRC_URI="http://download.cherrypy.org/${PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-LICENSE="BSD"
+IUSE="doc test"
DEPEND="dev-python/setuptools
test? ( >=dev-python/webtest-1.0 )
app-arch/unzip"
RDEPEND=""
+RESTRICT_PYTHON_ABIS="3.*"
-S=${WORKDIR}/${MY_P}
+S="${WORKDIR}/${MY_P}"
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- #Remove test_cache_filter, only works outside of portage
+src_prepare() {
+ # Remove test_cache_filter, only works outside of portage
sed -i \
-e '/raw_input/d' \
-e "/'test_cache_filter',/d" \
cherrypy/test/test.py || die "sed failed"
+
sed -i \
-e 's/"cherrypy.tutorial",//' \
-e "/('cherrypy\/tutorial',/, /),/d" \
@@ -37,14 +41,18 @@ src_unpack() {
setup.py || die "sed failed"
}
+src_test() {
+ testing() {
+ PYTHONPATH="build-${PYTHON_ABI}/lib" "$(PYTHON)" cherrypy/test/test.py
+ }
+ python_execute_function testing
+}
+
src_install() {
distutils_src_install
- if use doc ; then
+
+ if use doc; then
insinto /usr/share/doc/${PF}
doins -r cherrypy/tutorial
fi
}
-
-src_test() {
- PYTHONPATH=. "${python}" cherrypy/test/test.py || die "test failed"
-}
diff --git a/dev-python/cherrypy/cherrypy-3.1.2.ebuild b/dev-python/cherrypy/cherrypy-3.1.2.ebuild
index ef8966a95349..c3d821b50b76 100644
--- a/dev-python/cherrypy/cherrypy-3.1.2.ebuild
+++ b/dev-python/cherrypy/cherrypy-3.1.2.ebuild
@@ -1,44 +1,49 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/cherrypy/cherrypy-3.1.2.ebuild,v 1.6 2009/11/26 17:25:22 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/cherrypy/cherrypy-3.1.2.ebuild,v 1.7 2010/04/02 18:49:55 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
inherit distutils
-MY_P=CherryPy-${PV}
+MY_P="CherryPy-${PV}"
DESCRIPTION="CherryPy is a pythonic, object-oriented web development framework."
HOMEPAGE="http://www.cherrypy.org/ http://pypi.python.org/pypi/CherryPy"
SRC_URI="http://download.cherrypy.org/${PN}/${PV}/${MY_P}.tar.gz"
-IUSE="doc"
+LICENSE="BSD"
SLOT="0"
KEYWORDS="amd64 ia64 ppc x86 ~amd64-linux ~x86-linux ~x86-macos"
-LICENSE="BSD"
+IUSE="doc"
DEPEND=""
RDEPEND=""
+RESTRICT_PYTHON_ABIS="3.*"
S="${WORKDIR}/${MY_P}"
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
+src_prepare() {
sed -i \
-e 's/"cherrypy.tutorial",//' \
-e "/('cherrypy\/tutorial',/, /),/d" \
setup.py || die "sed failed"
+}
+src_test() {
+ testing() {
+ PYTHONPATH="build-${PYTHON_ABI}/lib" "$(PYTHON)" cherrypy/test/test.py --dumb
+ }
+ python_execute_function testing
}
src_install() {
distutils_src_install
- if use doc ; then
- insinto "/usr/share/doc/${PF}"
+
+ if use doc; then
+ insinto /usr/share/doc/${PF}
doins -r cherrypy/tutorial
fi
}
-
-src_test() {
- PYTHONPATH=. "${python}" cherrypy/test/test.py --dumb || die "test failed"
-}