summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/cherrypy/cherrypy-2.3.0.ebuild')
-rw-r--r--dev-python/cherrypy/cherrypy-2.3.0.ebuild46
1 files changed, 27 insertions, 19 deletions
diff --git a/dev-python/cherrypy/cherrypy-2.3.0.ebuild b/dev-python/cherrypy/cherrypy-2.3.0.ebuild
index 695d96fe7cc6..d61e2448153a 100644
--- a/dev-python/cherrypy/cherrypy-2.3.0.ebuild
+++ b/dev-python/cherrypy/cherrypy-2.3.0.ebuild
@@ -1,35 +1,39 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/cherrypy/cherrypy-2.3.0.ebuild,v 1.2 2009/02/15 14:31:56 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/cherrypy/cherrypy-2.3.0.ebuild,v 1.3 2010/04/02 18:49:55 arfrever Exp $
-inherit eutils distutils
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
-MY_P=CherryPy-${PV}
+inherit distutils eutils
+
+MY_P="CherryPy-${PV}"
DESCRIPTION="CherryPy is a pythonic, object-oriented web development framework."
-SRC_URI="http://download.cherrypy.org/cherrypy/${PV}/${MY_P}.tar.gz"
-HOMEPAGE="http://www.cherrypy.org/"
-IUSE="doc test"
+HOMEPAGE="http://www.cherrypy.org/ http://pypi.python.org/pypi/CherryPy"
+SRC_URI="http://download.cherrypy.org/${PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-LICENSE="BSD"
+IUSE="doc test"
DEPEND="dev-python/setuptools
test? ( >=dev-python/webtest-1.0 )
app-arch/unzip"
RDEPEND=""
+RESTRICT_PYTHON_ABIS="3.*"
-S=${WORKDIR}/${MY_P}
+S="${WORKDIR}/${MY_P}"
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- #Remove test_cache_filter, only works outside of portage
+src_prepare() {
+ # Remove test_cache_filter, only works outside of portage
sed -i \
-e '/raw_input/d' \
-e "/'test_cache_filter',/d" \
cherrypy/test/test.py || die "sed failed"
+
sed -i \
-e 's/"cherrypy.tutorial",//' \
-e "/('cherrypy\/tutorial',/, /),/d" \
@@ -37,14 +41,18 @@ src_unpack() {
setup.py || die "sed failed"
}
+src_test() {
+ testing() {
+ PYTHONPATH="build-${PYTHON_ABI}/lib" "$(PYTHON)" cherrypy/test/test.py
+ }
+ python_execute_function testing
+}
+
src_install() {
distutils_src_install
- if use doc ; then
+
+ if use doc; then
insinto /usr/share/doc/${PF}
doins -r cherrypy/tutorial
fi
}
-
-src_test() {
- PYTHONPATH=. "${python}" cherrypy/test/test.py || die "test failed"
-}