summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text')
-rw-r--r--app-text/libwpd/ChangeLog7
-rw-r--r--app-text/libwpd/files/digest-libwpd-0.8.21
-rw-r--r--app-text/libwpd/libwpd-0.8.2.ebuild31
3 files changed, 38 insertions, 1 deletions
diff --git a/app-text/libwpd/ChangeLog b/app-text/libwpd/ChangeLog
index 5dc694c6cd0f..06661449ffa9 100644
--- a/app-text/libwpd/ChangeLog
+++ b/app-text/libwpd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/libwpd
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/libwpd/ChangeLog,v 1.14 2005/07/16 02:52:56 weeve Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/libwpd/ChangeLog,v 1.15 2005/07/25 12:57:40 hanno Exp $
+
+*libwpd-0.8.2 (25 Jul 2005)
+
+ 25 Jul 2005; Hanno Boeck <hanno@gentoo.org> +libwpd-0.8.2.ebuild:
+ Version bump.
16 Jul 2005; Jason Wever <weeve@gentoo.org> libwpd-0.7.2.ebuild:
Added ~sparc keyword.
diff --git a/app-text/libwpd/files/digest-libwpd-0.8.2 b/app-text/libwpd/files/digest-libwpd-0.8.2
new file mode 100644
index 000000000000..d8a861335a67
--- /dev/null
+++ b/app-text/libwpd/files/digest-libwpd-0.8.2
@@ -0,0 +1 @@
+MD5 264e955e19c7e961e22382db09e19597 libwpd-0.8.2.tar.gz 486490
diff --git a/app-text/libwpd/libwpd-0.8.2.ebuild b/app-text/libwpd/libwpd-0.8.2.ebuild
new file mode 100644
index 000000000000..44c90739b318
--- /dev/null
+++ b/app-text/libwpd/libwpd-0.8.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/libwpd/libwpd-0.8.2.ebuild,v 1.1 2005/07/25 12:57:40 hanno Exp $
+
+inherit eutils
+
+DESCRIPTION="WordPerfect Document import/export library"
+HOMEPAGE="http://libwpd.sf.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~ppc ~sparc"
+IUSE="doc"
+
+RDEPEND=">=dev-libs/glib-2
+ >=gnome-extra/libgsf-1.6
+ doc? ( app-doc/doxygen )"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_compile() {
+ econf $(use_with doc docs) || die
+ emake || die
+}
+
+src_install() {
+ einstall || die
+ dodoc CHANGES COPYING CREDITS INSTALL README TODO
+}