summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/libwpd/libwpd-0.8.2.ebuild')
-rw-r--r--app-text/libwpd/libwpd-0.8.2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-text/libwpd/libwpd-0.8.2.ebuild b/app-text/libwpd/libwpd-0.8.2.ebuild
new file mode 100644
index 000000000000..44c90739b318
--- /dev/null
+++ b/app-text/libwpd/libwpd-0.8.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/libwpd/libwpd-0.8.2.ebuild,v 1.1 2005/07/25 12:57:40 hanno Exp $
+
+inherit eutils
+
+DESCRIPTION="WordPerfect Document import/export library"
+HOMEPAGE="http://libwpd.sf.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~ppc ~sparc"
+IUSE="doc"
+
+RDEPEND=">=dev-libs/glib-2
+ >=gnome-extra/libgsf-1.6
+ doc? ( app-doc/doxygen )"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_compile() {
+ econf $(use_with doc docs) || die
+ emake || die
+}
+
+src_install() {
+ einstall || die
+ dodoc CHANGES COPYING CREDITS INSTALL README TODO
+}