summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-lang/v8/ChangeLog6
-rw-r--r--dev-lang/v8/files/v8-vfp2-r0.patch12
-rw-r--r--dev-lang/v8/v8-3.13.7.5.ebuild3
-rw-r--r--dev-lang/v8/v8-3.14.5.3.ebuild6
-rw-r--r--dev-lang/v8/v8-3.15.11.1.ebuild6
5 files changed, 29 insertions, 4 deletions
diff --git a/dev-lang/v8/ChangeLog b/dev-lang/v8/ChangeLog
index 48120d670fd4..9f77b8aceee9 100644
--- a/dev-lang/v8/ChangeLog
+++ b/dev-lang/v8/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lang/v8
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/ChangeLog,v 1.264 2012/12/20 01:14:53 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/ChangeLog,v 1.265 2012/12/20 17:07:15 phajdan.jr Exp $
+
+ 20 Dec 2012; Pawel Hajdan jr <phajdan.jr@gentoo.org> +files/v8-vfp2-r0.patch,
+ v8-3.13.7.5.ebuild, v8-3.14.5.3.ebuild, v8-3.15.11.1.ebuild:
+ Backport upstream patch for vfp2 support, bug #441792 by chithanh.
*v8-3.14.5.3 (20 Dec 2012)
diff --git a/dev-lang/v8/files/v8-vfp2-r0.patch b/dev-lang/v8/files/v8-vfp2-r0.patch
new file mode 100644
index 000000000000..fa4fe4d87be2
--- /dev/null
+++ b/dev-lang/v8/files/v8-vfp2-r0.patch
@@ -0,0 +1,12 @@
+diff -ur a/build/common.gypi b/build/common.gypi
+--- a/build/common.gypi 2012-10-13 09:07:14.000000000 +0200
++++ b/build/common.gypi 2012-11-05 00:41:32.338031279 +0100
+@@ -152,7 +152,7 @@
+ [ 'v8_use_arm_eabi_hardfloat=="true"', {
+ 'defines': [
+ 'USE_EABI_HARDFLOAT=1',
+- 'CAN_USE_VFP3_INSTRUCTIONS',
++ 'CAN_USE_VFP2_INSTRUCTIONS',
+ ],
+ 'target_conditions': [
+ ['_toolset=="target"', {
diff --git a/dev-lang/v8/v8-3.13.7.5.ebuild b/dev-lang/v8/v8-3.13.7.5.ebuild
index 72b84a7e1f4c..974f6d065022 100644
--- a/dev-lang/v8/v8-3.13.7.5.ebuild
+++ b/dev-lang/v8/v8-3.13.7.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/v8-3.13.7.5.ebuild,v 1.3 2012/11/07 16:20:37 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/v8-3.13.7.5.ebuild,v 1.4 2012/12/20 17:07:15 phajdan.jr Exp $
EAPI="4"
@@ -24,6 +24,7 @@ pkg_setup() {
src_prepare() {
epatch "${FILESDIR}"/${PN}-3.10.8.10-freebsd9.patch
+ epatch "${FILESDIR}"/${PN}-vfp2-r0.patch
}
src_compile() {
diff --git a/dev-lang/v8/v8-3.14.5.3.ebuild b/dev-lang/v8/v8-3.14.5.3.ebuild
index fde6234c0266..6004dd9ed1cb 100644
--- a/dev-lang/v8/v8-3.14.5.3.ebuild
+++ b/dev-lang/v8/v8-3.14.5.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/v8-3.14.5.3.ebuild,v 1.1 2012/12/20 01:14:53 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/v8-3.14.5.3.ebuild,v 1.2 2012/12/20 17:07:15 phajdan.jr Exp $
EAPI="5"
PYTHON_COMPAT=( python2_{6,7} )
@@ -19,6 +19,10 @@ IUSE=""
DEPEND="${PYTHON_DEPS}"
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-vfp2-r0.patch
+}
+
src_compile() {
tc-export AR CC CXX RANLIB
export LINK=${CXX}
diff --git a/dev-lang/v8/v8-3.15.11.1.ebuild b/dev-lang/v8/v8-3.15.11.1.ebuild
index badc4332244e..a4a5dd84a1fb 100644
--- a/dev-lang/v8/v8-3.15.11.1.ebuild
+++ b/dev-lang/v8/v8-3.15.11.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/v8-3.15.11.1.ebuild,v 1.1 2012/12/15 23:26:20 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/v8-3.15.11.1.ebuild,v 1.2 2012/12/20 17:07:15 phajdan.jr Exp $
EAPI="5"
PYTHON_COMPAT=( python2_{6,7} )
@@ -19,6 +19,10 @@ IUSE=""
DEPEND="${PYTHON_DEPS}"
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-vfp2-r0.patch
+}
+
src_compile() {
tc-export AR CC CXX RANLIB
export LINK=${CXX}