summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Mende <angelos@gentoo.org>2011-04-06 16:54:58 +0000
committerChristoph Mende <angelos@gentoo.org>2011-04-06 16:54:58 +0000
commitb3449b0678d09b9ad664f7e5bf046d63af454d42 (patch)
tree889e08229dfd25ddb1b36a9d46c20fcdcd3d4394 /xfce-base/garcon
parentFix compilation problem with =dev-libs/boost-1.46, #362243; thanks few and xa... (diff)
downloadgentoo-2-b3449b0678d09b9ad664f7e5bf046d63af454d42.tar.gz
gentoo-2-b3449b0678d09b9ad664f7e5bf046d63af454d42.tar.bz2
gentoo-2-b3449b0678d09b9ad664f7e5bf046d63af454d42.zip
Version bump
(Portage version: 2.2.0_alpha29/cvs/Linux x86_64)
Diffstat (limited to 'xfce-base/garcon')
-rw-r--r--xfce-base/garcon/ChangeLog7
-rw-r--r--xfce-base/garcon/garcon-0.1.6.ebuild33
2 files changed, 39 insertions, 1 deletions
diff --git a/xfce-base/garcon/ChangeLog b/xfce-base/garcon/ChangeLog
index 1e717d8031f5..66b51392384d 100644
--- a/xfce-base/garcon/ChangeLog
+++ b/xfce-base/garcon/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for xfce-base/garcon
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-base/garcon/ChangeLog,v 1.20 2011/02/14 19:19:48 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/garcon/ChangeLog,v 1.21 2011/04/06 16:54:58 angelos Exp $
+
+*garcon-0.1.6 (06 Apr 2011)
+
+ 06 Apr 2011; Christoph Mende <angelos@gentoo.org> +garcon-0.1.6.ebuild:
+ Version bump
14 Feb 2011; Samuli Suominen <ssuominen@gentoo.org> garcon-0.1.5.ebuild:
alpha/ia64/sh/sparc stable wrt #349053
diff --git a/xfce-base/garcon/garcon-0.1.6.ebuild b/xfce-base/garcon/garcon-0.1.6.ebuild
new file mode 100644
index 000000000000..8b6b90c3c915
--- /dev/null
+++ b/xfce-base/garcon/garcon-0.1.6.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/garcon/garcon-0.1.6.ebuild,v 1.1 2011/04/06 16:54:57 angelos Exp $
+
+EAPI=4
+inherit xfconf
+
+DESCRIPTION="Xfce's freedesktop.org specification compatible menu implementation library"
+HOMEPAGE="http://www.xfce.org/projects/libraries/"
+SRC_URI="mirror://xfce/src/libs/${PN}/0.1/${P}.tar.bz2"
+
+LICENSE="LGPL-2 FDL-1.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="debug"
+
+RDEPEND=">=dev-libs/glib-2.14:2
+ !<xfce-base/xfdesktop-4.7.0"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ dev-util/intltool
+ sys-devel/gettext"
+
+pkg_setup() {
+ XFCONF=(
+ --disable-dependency-tracking
+ --disable-static
+ $(xfconf_use_debug)
+ --with-html-dir="${EPREFIX}"/usr/share/doc/${PF}/html
+ )
+
+ DOCS="AUTHORS ChangeLog HACKING NEWS README STATUS TODO"
+}