summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'xfce-base/garcon/garcon-0.1.6.ebuild')
-rw-r--r--xfce-base/garcon/garcon-0.1.6.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/xfce-base/garcon/garcon-0.1.6.ebuild b/xfce-base/garcon/garcon-0.1.6.ebuild
new file mode 100644
index 000000000000..8b6b90c3c915
--- /dev/null
+++ b/xfce-base/garcon/garcon-0.1.6.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/garcon/garcon-0.1.6.ebuild,v 1.1 2011/04/06 16:54:57 angelos Exp $
+
+EAPI=4
+inherit xfconf
+
+DESCRIPTION="Xfce's freedesktop.org specification compatible menu implementation library"
+HOMEPAGE="http://www.xfce.org/projects/libraries/"
+SRC_URI="mirror://xfce/src/libs/${PN}/0.1/${P}.tar.bz2"
+
+LICENSE="LGPL-2 FDL-1.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="debug"
+
+RDEPEND=">=dev-libs/glib-2.14:2
+ !<xfce-base/xfdesktop-4.7.0"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ dev-util/intltool
+ sys-devel/gettext"
+
+pkg_setup() {
+ XFCONF=(
+ --disable-dependency-tracking
+ --disable-static
+ $(xfconf_use_debug)
+ --with-html-dir="${EPREFIX}"/usr/share/doc/${PF}/html
+ )
+
+ DOCS="AUTHORS ChangeLog HACKING NEWS README STATUS TODO"
+}