summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2010-06-28 22:00:04 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2010-06-28 22:00:04 +0000
commitb65b475aa7a0848a59245373d77be0a261095bc2 (patch)
treec0b228c534db015f1df04134e2ba949e8dcfb661 /x11-plugins/wmfire/wmfire-1.2.4-r1.ebuild
parentStable on amd64 wrt bug #326065 (diff)
downloadgentoo-2-b65b475aa7a0848a59245373d77be0a261095bc2.tar.gz
gentoo-2-b65b475aa7a0848a59245373d77be0a261095bc2.tar.bz2
gentoo-2-b65b475aa7a0848a59245373d77be0a261095bc2.zip
Fix support with gtk+ >= 2.18, bug #304087
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'x11-plugins/wmfire/wmfire-1.2.4-r1.ebuild')
-rw-r--r--x11-plugins/wmfire/wmfire-1.2.4-r1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/x11-plugins/wmfire/wmfire-1.2.4-r1.ebuild b/x11-plugins/wmfire/wmfire-1.2.4-r1.ebuild
new file mode 100644
index 000000000000..a3869dfa28a4
--- /dev/null
+++ b/x11-plugins/wmfire/wmfire-1.2.4-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmfire/wmfire-1.2.4-r1.ebuild,v 1.1 2010/06/28 22:00:03 voyageur Exp $
+
+EAPI=2
+inherit autotools eutils
+
+DESCRIPTION="Load monitoring dockapp displaying dancing flame."
+HOMEPAGE="http://www.swanson.ukfsn.org/#wmfire"
+SRC_URI="http://www.swanson.ukfsn.org/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="session"
+
+RDEPEND="x11-libs/gtk+:2
+ >=gnome-base/libgtop-2
+ x11-libs/libX11
+ x11-libs/libXext
+ session? ( x11-libs/libSM
+ x11-libs/libICE )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.2.3-stringh.patch
+ epatch "${FILESDIR}"/${P}-no_display.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ $(use_enable session)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc ALL_I_GET_IS_A_GREY_BOX AUTHORS ChangeLog NEWS README
+}