summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2010-06-28 22:00:04 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2010-06-28 22:00:04 +0000
commitb65b475aa7a0848a59245373d77be0a261095bc2 (patch)
treec0b228c534db015f1df04134e2ba949e8dcfb661 /x11-plugins
parentStable on amd64 wrt bug #326065 (diff)
downloadgentoo-2-b65b475aa7a0848a59245373d77be0a261095bc2.tar.gz
gentoo-2-b65b475aa7a0848a59245373d77be0a261095bc2.tar.bz2
gentoo-2-b65b475aa7a0848a59245373d77be0a261095bc2.zip
Fix support with gtk+ >= 2.18, bug #304087
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/wmfire/ChangeLog9
-rw-r--r--x11-plugins/wmfire/files/wmfire-1.2.4-no_display.patch19
-rw-r--r--x11-plugins/wmfire/metadata.xml3
-rw-r--r--x11-plugins/wmfire/wmfire-1.2.4-r1.ebuild41
4 files changed, 71 insertions, 1 deletions
diff --git a/x11-plugins/wmfire/ChangeLog b/x11-plugins/wmfire/ChangeLog
index 897f009774b2..935a4a60fce3 100644
--- a/x11-plugins/wmfire/ChangeLog
+++ b/x11-plugins/wmfire/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-plugins/wmfire
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmfire/ChangeLog,v 1.15 2010/03/15 22:03:02 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmfire/ChangeLog,v 1.16 2010/06/28 22:00:03 voyageur Exp $
+
+*wmfire-1.2.4-r1 (28 Jun 2010)
+
+ 28 Jun 2010; Bernard Cafarelli <voyageur@gentoo.org>
+ +wmfire-1.2.4-r1.ebuild, +files/wmfire-1.2.4-no_display.patch,
+ metadata.xml:
+ Fix support with gtk+ >= 2.18, bug #304087
*wmfire-1.2.4 (15 Mar 2010)
diff --git a/x11-plugins/wmfire/files/wmfire-1.2.4-no_display.patch b/x11-plugins/wmfire/files/wmfire-1.2.4-no_display.patch
new file mode 100644
index 000000000000..a2540a247cf6
--- /dev/null
+++ b/x11-plugins/wmfire/files/wmfire-1.2.4-no_display.patch
@@ -0,0 +1,19 @@
+--- src/wmfire.c.orig 2010-06-28 23:53:35.000000000 +0200
++++ src/wmfire.c 2010-06-28 23:54:35.000000000 +0200
+@@ -150,6 +150,8 @@
+ int
+ main(int argc, char **argv)
+ {
++ /* This is needed to proper dockapp work on >=GTK+-2.18 */
++ setenv("GDK_NATIVE_WINDOWS", "1", 0);
+ GdkEvent *event;
+ GdkCursor *cursor;
+ int i;
+@@ -632,6 +634,7 @@
+
+ /* Moved after gdk_window_show due to change in GTK 2.4 */
+ XSetWMHints(GDK_WINDOW_XDISPLAY(bm.win), win, &wmhints);
++ gdk_window_show(bm.iconwin);
+
+ if (bm.x > 0 || bm.y > 0)
+ gdk_window_move(bm.win, bm.x, bm.y);
diff --git a/x11-plugins/wmfire/metadata.xml b/x11-plugins/wmfire/metadata.xml
index 2383f97840cd..93b239563828 100644
--- a/x11-plugins/wmfire/metadata.xml
+++ b/x11-plugins/wmfire/metadata.xml
@@ -7,4 +7,7 @@ wmfire is an eye-candy dock applet for Window Maker that displays generated
fire, possibly according to how much load the system is experiencing, or from a
number somewhere in a file. wmfire requires very little CPU.
</longdescription>
+<use>
+ <flag name='session'>Enable session management</flag>
+</use>
</pkgmetadata>
diff --git a/x11-plugins/wmfire/wmfire-1.2.4-r1.ebuild b/x11-plugins/wmfire/wmfire-1.2.4-r1.ebuild
new file mode 100644
index 000000000000..a3869dfa28a4
--- /dev/null
+++ b/x11-plugins/wmfire/wmfire-1.2.4-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmfire/wmfire-1.2.4-r1.ebuild,v 1.1 2010/06/28 22:00:03 voyageur Exp $
+
+EAPI=2
+inherit autotools eutils
+
+DESCRIPTION="Load monitoring dockapp displaying dancing flame."
+HOMEPAGE="http://www.swanson.ukfsn.org/#wmfire"
+SRC_URI="http://www.swanson.ukfsn.org/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="session"
+
+RDEPEND="x11-libs/gtk+:2
+ >=gnome-base/libgtop-2
+ x11-libs/libX11
+ x11-libs/libXext
+ session? ( x11-libs/libSM
+ x11-libs/libICE )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.2.3-stringh.patch
+ epatch "${FILESDIR}"/${P}-no_display.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ $(use_enable session)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc ALL_I_GET_IS_A_GREY_BOX AUTHORS ChangeLog NEWS README
+}