summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Nigbur <pyrania@gentoo.org>2004-03-06 03:25:19 +0000
committerMarkus Nigbur <pyrania@gentoo.org>2004-03-06 03:25:19 +0000
commit1c018b944892f6290c4bc957f969c580bd2c412d (patch)
treeb6fa607d0efd663c2f6df68f4e7b98263f9cd472 /x11-misc
parentwe license under gpl2, not gpl2 or later (diff)
downloadgentoo-2-1c018b944892f6290c4bc957f969c580bd2c412d.tar.gz
gentoo-2-1c018b944892f6290c4bc957f969c580bd2c412d.tar.bz2
gentoo-2-1c018b944892f6290c4bc957f969c580bd2c412d.zip
Version bump.
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/xlockmore/Manifest2
-rw-r--r--x11-misc/xlockmore/files/digest-xlockmore-5.11.11
-rw-r--r--x11-misc/xlockmore/xlockmore-5.11.1.ebuild73
3 files changed, 76 insertions, 0 deletions
diff --git a/x11-misc/xlockmore/Manifest b/x11-misc/xlockmore/Manifest
index b47b8683d595..f67994a9b762 100644
--- a/x11-misc/xlockmore/Manifest
+++ b/x11-misc/xlockmore/Manifest
@@ -1,6 +1,8 @@
MD5 e4418cc678794fdee37fc8b5251ca66c xlockmore-5.04.ebuild 1845
MD5 80d34edfdca895db75f407cd3e2e061e xlockmore-5.08.2.ebuild 1901
+MD5 ab6057ca04f4e8ba28e0078797ea6b25 xlockmore-5.11.1.ebuild 1904
MD5 c41d2278c3088d8d2f01591df4a87a8a ChangeLog 3920
MD5 fe402b096905cae8dcb4a503d3a838ac metadata.xml 173
MD5 589c4732f3e791a2cad0f52c7ec09908 files/digest-xlockmore-5.04 68
MD5 7c6285fb6c9ff44a2590f166ecd553ef files/digest-xlockmore-5.08.2 70
+MD5 ed71265bdbcff414270728e5eef3196d files/digest-xlockmore-5.11.1 70
diff --git a/x11-misc/xlockmore/files/digest-xlockmore-5.11.1 b/x11-misc/xlockmore/files/digest-xlockmore-5.11.1
new file mode 100644
index 000000000000..bf68dc74a748
--- /dev/null
+++ b/x11-misc/xlockmore/files/digest-xlockmore-5.11.1
@@ -0,0 +1 @@
+MD5 d71b4429ae9af1f469ff441365cb28db xlockmore-5.11.1.tar.bz2 1514029
diff --git a/x11-misc/xlockmore/xlockmore-5.11.1.ebuild b/x11-misc/xlockmore/xlockmore-5.11.1.ebuild
new file mode 100644
index 000000000000..37d28b5fea2d
--- /dev/null
+++ b/x11-misc/xlockmore/xlockmore-5.11.1.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xlockmore/xlockmore-5.11.1.ebuild,v 1.1 2004/03/06 03:25:19 pyrania Exp $
+
+inherit gnuconfig
+
+IUSE="nas esd motif opengl truetype gtk pam"
+
+S=${WORKDIR}/${P}
+
+DESCRIPTION="Just another screensaver application for X"
+SRC_URI="http://ftp.tux.org/pub/tux/bagleyd/xlockmore/${P}.tar.bz2"
+HOMEPAGE="http://www.tux.org/~bagleyd/xlockmore.html"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~x86 ~sparc ~amd64"
+
+DEPEND="virtual/x11
+ media-libs/freetype
+ opengl? ( virtual/opengl )
+ pam? ( sys-libs/pam )
+ nas? ( media-libs/nas )
+ esd? ( media-sound/esound )
+ motif? ( x11-libs/openmotif )
+ gtk? ( =x11-libs/gtk+-1.2* )"
+
+src_compile() {
+ gnuconfig_update
+
+ local myconf
+ myconf="--enable-vtlock"
+ use pam && myconf="${myconf} --enable-pam" \
+ || myconf="${myconf} --disable-pam --enable-xlockrc"
+ use nas || myconf="${myconf} --without-nas"
+ use esd && myconf="${myconf} --with-esound"
+ use opengl || myconf="${myconf} --without-opengl --without-gltt --without-mesa"
+ use truetype || myconf="${myconf} --without-ttf"
+
+ use motif || myconf="${myconf} --without-motif"
+ use gtk || myconf="${myconf} --without-gtk"
+
+ ./configure \
+ --prefix=/usr \
+ --mandir=${prefix}/share/man/man1 \
+ --sharedstatedir=/usr/share/xlockmore \
+ --host=${CHOST} ${myconf} || die "Configure failed"
+
+ emake || die "Make failed"
+
+}
+
+src_install() {
+ make install \
+ prefix=${D}/usr \
+ mandir=${D}/usr/share/man/man1 \
+ xapploaddir=${D}/usr/X11R6/lib/X11/app-defaults \
+ || die "Install failed"
+
+ #Install pam.d file and unset setuid root
+ if use pam; then
+ insinto /etc/pam.d
+ newins etc/xlock.pamd xlock
+ chmod 111 ${D}/usr/bin/xlock
+ fi
+
+ insinto /usr/share/xlockmore/sounds
+ doins sounds/*
+
+ dodoc docs/* README
+ dohtml docs/*.html
+ rm ${D}/usr/share/doc/${PF}/*.html.gz
+}