summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/xlockmore/xlockmore-5.11.1.ebuild')
-rw-r--r--x11-misc/xlockmore/xlockmore-5.11.1.ebuild73
1 files changed, 73 insertions, 0 deletions
diff --git a/x11-misc/xlockmore/xlockmore-5.11.1.ebuild b/x11-misc/xlockmore/xlockmore-5.11.1.ebuild
new file mode 100644
index 000000000000..37d28b5fea2d
--- /dev/null
+++ b/x11-misc/xlockmore/xlockmore-5.11.1.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xlockmore/xlockmore-5.11.1.ebuild,v 1.1 2004/03/06 03:25:19 pyrania Exp $
+
+inherit gnuconfig
+
+IUSE="nas esd motif opengl truetype gtk pam"
+
+S=${WORKDIR}/${P}
+
+DESCRIPTION="Just another screensaver application for X"
+SRC_URI="http://ftp.tux.org/pub/tux/bagleyd/xlockmore/${P}.tar.bz2"
+HOMEPAGE="http://www.tux.org/~bagleyd/xlockmore.html"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~x86 ~sparc ~amd64"
+
+DEPEND="virtual/x11
+ media-libs/freetype
+ opengl? ( virtual/opengl )
+ pam? ( sys-libs/pam )
+ nas? ( media-libs/nas )
+ esd? ( media-sound/esound )
+ motif? ( x11-libs/openmotif )
+ gtk? ( =x11-libs/gtk+-1.2* )"
+
+src_compile() {
+ gnuconfig_update
+
+ local myconf
+ myconf="--enable-vtlock"
+ use pam && myconf="${myconf} --enable-pam" \
+ || myconf="${myconf} --disable-pam --enable-xlockrc"
+ use nas || myconf="${myconf} --without-nas"
+ use esd && myconf="${myconf} --with-esound"
+ use opengl || myconf="${myconf} --without-opengl --without-gltt --without-mesa"
+ use truetype || myconf="${myconf} --without-ttf"
+
+ use motif || myconf="${myconf} --without-motif"
+ use gtk || myconf="${myconf} --without-gtk"
+
+ ./configure \
+ --prefix=/usr \
+ --mandir=${prefix}/share/man/man1 \
+ --sharedstatedir=/usr/share/xlockmore \
+ --host=${CHOST} ${myconf} || die "Configure failed"
+
+ emake || die "Make failed"
+
+}
+
+src_install() {
+ make install \
+ prefix=${D}/usr \
+ mandir=${D}/usr/share/man/man1 \
+ xapploaddir=${D}/usr/X11R6/lib/X11/app-defaults \
+ || die "Install failed"
+
+ #Install pam.d file and unset setuid root
+ if use pam; then
+ insinto /etc/pam.d
+ newins etc/xlock.pamd xlock
+ chmod 111 ${D}/usr/bin/xlock
+ fi
+
+ insinto /usr/share/xlockmore/sounds
+ doins sounds/*
+
+ dodoc docs/* README
+ dohtml docs/*.html
+ rm ${D}/usr/share/doc/${PF}/*.html.gz
+}