summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Loeser <halcy0n@gentoo.org>2006-05-02 00:49:39 +0000
committerMark Loeser <halcy0n@gentoo.org>2006-05-02 00:49:39 +0000
commit1d12f8c920ce2debb67d6249323c5fd32f09b052 (patch)
tree68bcf3d6a607ec400128f0db1853028a2aa32920 /x11-misc/fbdesk/fbdesk-1.2.1.ebuild
parentPreserve LIBGL_DRIVERS_PATH (diff)
downloadgentoo-2-1d12f8c920ce2debb67d6249323c5fd32f09b052.tar.gz
gentoo-2-1d12f8c920ce2debb67d6249323c5fd32f09b052.tar.bz2
gentoo-2-1d12f8c920ce2debb67d6249323c5fd32f09b052.zip
Add patch to fix compilation with gcc-4.1 by Robert Führicht <the_master_of_disaster AT gmx DOT at>; bug #130825
(Portage version: 2.1_pre10)
Diffstat (limited to 'x11-misc/fbdesk/fbdesk-1.2.1.ebuild')
-rw-r--r--x11-misc/fbdesk/fbdesk-1.2.1.ebuild11
1 files changed, 10 insertions, 1 deletions
diff --git a/x11-misc/fbdesk/fbdesk-1.2.1.ebuild b/x11-misc/fbdesk/fbdesk-1.2.1.ebuild
index a310dd2d79b8..829364c16796 100644
--- a/x11-misc/fbdesk/fbdesk-1.2.1.ebuild
+++ b/x11-misc/fbdesk/fbdesk-1.2.1.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/fbdesk/fbdesk-1.2.1.ebuild,v 1.6 2006/01/30 19:21:44 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/fbdesk/fbdesk-1.2.1.ebuild,v 1.7 2006/05/02 00:49:39 halcy0n Exp $
+
+inherit eutils
DESCRIPTION="fluxbox-util application that creates and manage icons on your Fluxbox desktop"
HOMEPAGE="http://www.fluxbox.org/fbdesk/"
@@ -16,6 +18,13 @@ RDEPEND="png? ( media-libs/libpng )
DEPEND="${RDEPEND}
|| ( ( x11-proto/xextproto ) virtual/x11 )"
+src_unpack() {
+ unpack ${A}
+
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-gcc41.patch
+}
+
src_compile() {
econf \
$(use_enable debug) \