summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Loeser <halcy0n@gentoo.org>2006-05-02 00:49:39 +0000
committerMark Loeser <halcy0n@gentoo.org>2006-05-02 00:49:39 +0000
commit1d12f8c920ce2debb67d6249323c5fd32f09b052 (patch)
tree68bcf3d6a607ec400128f0db1853028a2aa32920 /x11-misc
parentPreserve LIBGL_DRIVERS_PATH (diff)
downloadgentoo-2-1d12f8c920ce2debb67d6249323c5fd32f09b052.tar.gz
gentoo-2-1d12f8c920ce2debb67d6249323c5fd32f09b052.tar.bz2
gentoo-2-1d12f8c920ce2debb67d6249323c5fd32f09b052.zip
Add patch to fix compilation with gcc-4.1 by Robert Führicht <the_master_of_disaster AT gmx DOT at>; bug #130825
(Portage version: 2.1_pre10)
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/fbdesk/ChangeLog7
-rw-r--r--x11-misc/fbdesk/fbdesk-1.2.1.ebuild11
-rw-r--r--x11-misc/fbdesk/files/digest-fbdesk-1.2.12
-rw-r--r--x11-misc/fbdesk/files/fbdesk-1.2.1-gcc41.patch29
4 files changed, 47 insertions, 2 deletions
diff --git a/x11-misc/fbdesk/ChangeLog b/x11-misc/fbdesk/ChangeLog
index 8fef03bc3c61..b18c613f222e 100644
--- a/x11-misc/fbdesk/ChangeLog
+++ b/x11-misc/fbdesk/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/fbdesk
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/fbdesk/ChangeLog,v 1.16 2006/01/30 19:21:44 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/fbdesk/ChangeLog,v 1.17 2006/05/02 00:49:39 halcy0n Exp $
+
+ 02 May 2006; Mark Loeser <halcy0n@gentoo.org>
+ +files/fbdesk-1.2.1-gcc41.patch, fbdesk-1.2.1.ebuild:
+ Add patch to fix compilation with gcc-4.1 by Robert Führicht
+ <the_master_of_disaster AT gmx DOT at>; bug #130825
30 Jan 2006; Robin H. Johnson <robbat2@gentoo.org> fbdesk-1.2.1.ebuild:
Modular-X fixing.
diff --git a/x11-misc/fbdesk/fbdesk-1.2.1.ebuild b/x11-misc/fbdesk/fbdesk-1.2.1.ebuild
index a310dd2d79b8..829364c16796 100644
--- a/x11-misc/fbdesk/fbdesk-1.2.1.ebuild
+++ b/x11-misc/fbdesk/fbdesk-1.2.1.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/fbdesk/fbdesk-1.2.1.ebuild,v 1.6 2006/01/30 19:21:44 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/fbdesk/fbdesk-1.2.1.ebuild,v 1.7 2006/05/02 00:49:39 halcy0n Exp $
+
+inherit eutils
DESCRIPTION="fluxbox-util application that creates and manage icons on your Fluxbox desktop"
HOMEPAGE="http://www.fluxbox.org/fbdesk/"
@@ -16,6 +18,13 @@ RDEPEND="png? ( media-libs/libpng )
DEPEND="${RDEPEND}
|| ( ( x11-proto/xextproto ) virtual/x11 )"
+src_unpack() {
+ unpack ${A}
+
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-gcc41.patch
+}
+
src_compile() {
econf \
$(use_enable debug) \
diff --git a/x11-misc/fbdesk/files/digest-fbdesk-1.2.1 b/x11-misc/fbdesk/files/digest-fbdesk-1.2.1
index 29af04e6b60d..8ff051103f1f 100644
--- a/x11-misc/fbdesk/files/digest-fbdesk-1.2.1
+++ b/x11-misc/fbdesk/files/digest-fbdesk-1.2.1
@@ -1 +1,3 @@
MD5 382a32a6e26b3f3d3a647fa4bdc81b7a fbdesk-1.2.1.tar.gz 388679
+RMD160 a3ae892c5c733351b1525e874875c09078ac5aa7 fbdesk-1.2.1.tar.gz 388679
+SHA256 64366e367c0bd8c29fc9a96eb095c15b4f839d2c83819e744d809127d6be5016 fbdesk-1.2.1.tar.gz 388679
diff --git a/x11-misc/fbdesk/files/fbdesk-1.2.1-gcc41.patch b/x11-misc/fbdesk/files/fbdesk-1.2.1-gcc41.patch
new file mode 100644
index 000000000000..917b8687dc18
--- /dev/null
+++ b/x11-misc/fbdesk/files/fbdesk-1.2.1-gcc41.patch
@@ -0,0 +1,29 @@
+--- src/FbDesk.cc.org 2006-04-22 14:29:20.000000000 +0200
++++ src/FbDesk.cc 2006-04-22 14:37:45.000000000 +0200
+@@ -43,6 +43,8 @@
+ using namespace std;
+ using namespace FbTk;
+
++namespace FbTk {
++
+ template <>
+ void Resource<int>::setFromString(const char *str) {
+ sscanf(str, "%d", &*(*this));
+@@ -65,8 +67,6 @@
+ return (*this)->c_str();
+ }
+
+-
+-
+ template <>
+ std::string Resource<FbDesk::Icon::TextPlacement>::getString() {
+ switch (*(*this)) {
+@@ -97,6 +97,8 @@
+ *(*this) = FbDesk::Icon::TEXTPLACE_BOTTOM;
+ }
+
++}
++
+ namespace FbDesk {
+
+ FbDesk::FbDesk(const char *config_filename):