summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-05-25 14:24:27 +0000
committerJustin Lecher <jlec@gentoo.org>2012-05-25 14:24:27 +0000
commitd2de307938d50615240d28becbc477dd1259898f (patch)
tree81619c7d15c4719d2dda861a1f8d4bff158ab9cd /x11-libs
parentRemove old versions (diff)
downloadgentoo-2-d2de307938d50615240d28becbc477dd1259898f.tar.gz
gentoo-2-d2de307938d50615240d28becbc477dd1259898f.tar.bz2
gentoo-2-d2de307938d50615240d28becbc477dd1259898f.zip
x11-libs/xbae: Moved to EAPI=4 and autotools.eclas to handle static-libs
(Portage version: 2.2.0_alpha108/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/xbae/ChangeLog6
-rw-r--r--x11-libs/xbae/metadata.xml4
-rw-r--r--x11-libs/xbae/xbae-4.60.4.ebuild49
3 files changed, 33 insertions, 26 deletions
diff --git a/x11-libs/xbae/ChangeLog b/x11-libs/xbae/ChangeLog
index 6a3564e14219..661138b9ab72 100644
--- a/x11-libs/xbae/ChangeLog
+++ b/x11-libs/xbae/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-libs/xbae
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/xbae/ChangeLog,v 1.16 2012/02/09 09:46:56 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/xbae/ChangeLog,v 1.17 2012/05/25 14:24:27 jlec Exp $
+
+ 25 May 2012; Justin Lecher <jlec@gentoo.org> xbae-4.60.4.ebuild,
+ metadata.xml:
+ Moved to EAPI=4 and autotools.eclas to handle static-libs
09 Feb 2012; Justin Lecher <jlec@gentoo.org> xbae-4.60.4.ebuild:
Keyworded for ~-linux prefix
diff --git a/x11-libs/xbae/metadata.xml b/x11-libs/xbae/metadata.xml
index e86f2b27228a..d32dd96829a7 100644
--- a/x11-libs/xbae/metadata.xml
+++ b/x11-libs/xbae/metadata.xml
@@ -1,8 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>sci</herd>
-<longdescription lang="en">
+ <herd>sci</herd>
+ <longdescription lang="en">
XbaeMatrix is a free Motif(R) table widget (also compatible with the free
LessTif) which presents an editable array of string data to the user in a
scrollable table similar to a spreadsheet. The rows and columns of the Matrix
diff --git a/x11-libs/xbae/xbae-4.60.4.ebuild b/x11-libs/xbae/xbae-4.60.4.ebuild
index 755d4038b510..5fa792a08a94 100644
--- a/x11-libs/xbae/xbae-4.60.4.ebuild
+++ b/x11-libs/xbae/xbae-4.60.4.ebuild
@@ -1,9 +1,10 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/xbae/xbae-4.60.4.ebuild,v 1.15 2012/02/09 09:46:56 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/xbae/xbae-4.60.4.ebuild,v 1.16 2012/05/25 14:24:27 jlec Exp $
-EAPI=3
-inherit eutils
+EAPI=4
+
+inherit autotools-utils
DESCRIPTION="Motif-based widget to display a grid of cells as a spreadsheet"
HOMEPAGE="http://xbae.sourceforge.net/"
@@ -12,9 +13,10 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="BSD"
KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux"
SLOT="0"
-IUSE="doc examples"
+IUSE="doc examples static-libs"
-RDEPEND=">=x11-libs/openmotif-2.3:0
+RDEPEND="
+ x11-libs/openmotif:0
x11-libs/libXau
x11-libs/libXdmcp
x11-libs/libXext
@@ -24,35 +26,36 @@ RDEPEND=">=x11-libs/openmotif-2.3:0
DEPEND="${RDEPEND}"
-src_prepare() {
- epatch "${FILESDIR}"/${P}-tmpl.patch
- epatch "${FILESDIR}"/${P}-lxmp.patch
- epatch "${FILESDIR}"/${P}-Makefile.in.patch
-}
+PATCHES=(
+ "${FILESDIR}"/${P}-tmpl.patch
+ "${FILESDIR}"/${P}-lxmp.patch
+ "${FILESDIR}"/${P}-Makefile.in.patch
+ )
src_configure() {
- econf --enable-production
+ local myeconfargs=( --enable-production )
+ autotools-utils_src_configure
}
src_test() {
cd examples
- emake || die "emake examples failed"
- ./testall
- make clean
+ emake
+ ./testall || die
+ emake clean
}
src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
+ autotools-utils_src_install
+
insinto /usr/share/aclocal
- doins ac_find_xbae.m4 || die
- dodoc README NEWS ChangeLog AUTHORS
- if use doc; then
- dohtml -r doc/* || die
- fi
+ doins ac_find_xbae.m4
+
+ use doc && dohtml -r doc/*
+
if use examples; then
- find examples -name '*akefile*' -exec rm -f {} \;
- rm -f examples/{testall,extest}
+ find examples -name '*akefile*' -delete || die
+ rm -f examples/{testall,extest} || die
insinto /usr/share/doc/${PF}
- doins -r examples || die
+ doins -r examples
fi
}