summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-libs/xbae/xbae-4.60.4.ebuild')
-rw-r--r--x11-libs/xbae/xbae-4.60.4.ebuild49
1 files changed, 26 insertions, 23 deletions
diff --git a/x11-libs/xbae/xbae-4.60.4.ebuild b/x11-libs/xbae/xbae-4.60.4.ebuild
index 755d4038b510..5fa792a08a94 100644
--- a/x11-libs/xbae/xbae-4.60.4.ebuild
+++ b/x11-libs/xbae/xbae-4.60.4.ebuild
@@ -1,9 +1,10 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/xbae/xbae-4.60.4.ebuild,v 1.15 2012/02/09 09:46:56 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/xbae/xbae-4.60.4.ebuild,v 1.16 2012/05/25 14:24:27 jlec Exp $
-EAPI=3
-inherit eutils
+EAPI=4
+
+inherit autotools-utils
DESCRIPTION="Motif-based widget to display a grid of cells as a spreadsheet"
HOMEPAGE="http://xbae.sourceforge.net/"
@@ -12,9 +13,10 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="BSD"
KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux"
SLOT="0"
-IUSE="doc examples"
+IUSE="doc examples static-libs"
-RDEPEND=">=x11-libs/openmotif-2.3:0
+RDEPEND="
+ x11-libs/openmotif:0
x11-libs/libXau
x11-libs/libXdmcp
x11-libs/libXext
@@ -24,35 +26,36 @@ RDEPEND=">=x11-libs/openmotif-2.3:0
DEPEND="${RDEPEND}"
-src_prepare() {
- epatch "${FILESDIR}"/${P}-tmpl.patch
- epatch "${FILESDIR}"/${P}-lxmp.patch
- epatch "${FILESDIR}"/${P}-Makefile.in.patch
-}
+PATCHES=(
+ "${FILESDIR}"/${P}-tmpl.patch
+ "${FILESDIR}"/${P}-lxmp.patch
+ "${FILESDIR}"/${P}-Makefile.in.patch
+ )
src_configure() {
- econf --enable-production
+ local myeconfargs=( --enable-production )
+ autotools-utils_src_configure
}
src_test() {
cd examples
- emake || die "emake examples failed"
- ./testall
- make clean
+ emake
+ ./testall || die
+ emake clean
}
src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
+ autotools-utils_src_install
+
insinto /usr/share/aclocal
- doins ac_find_xbae.m4 || die
- dodoc README NEWS ChangeLog AUTHORS
- if use doc; then
- dohtml -r doc/* || die
- fi
+ doins ac_find_xbae.m4
+
+ use doc && dohtml -r doc/*
+
if use examples; then
- find examples -name '*akefile*' -exec rm -f {} \;
- rm -f examples/{testall,extest}
+ find examples -name '*akefile*' -delete || die
+ rm -f examples/{testall,extest} || die
insinto /usr/share/doc/${PF}
- doins -r examples || die
+ doins -r examples
fi
}