summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2012-05-24 22:48:24 +0000
committerMike Gilbert <floppym@gentoo.org>2012-05-24 22:48:24 +0000
commitb7d1c412603f5103505c04a51db758bc1f83d665 (patch)
tree3c1b9335a2ef5944faa1bd836899964e087b7de5 /www-client/seamonkey
parentConvert DOS line-endings in shell scripts. Bug 391889. (diff)
downloadgentoo-2-b7d1c412603f5103505c04a51db758bc1f83d665.tar.gz
gentoo-2-b7d1c412603f5103505c04a51db758bc1f83d665.tar.bz2
gentoo-2-b7d1c412603f5103505c04a51db758bc1f83d665.zip
Convert DOS line-endings in shell scripts. Bug 391889.
(Portage version: 2.2.0_alpha107/cvs/Linux x86_64)
Diffstat (limited to 'www-client/seamonkey')
-rw-r--r--www-client/seamonkey/ChangeLog6
-rw-r--r--www-client/seamonkey/seamonkey-2.9.1-r1.ebuild9
-rw-r--r--www-client/seamonkey/seamonkey-2.9.ebuild9
3 files changed, 21 insertions, 3 deletions
diff --git a/www-client/seamonkey/ChangeLog b/www-client/seamonkey/ChangeLog
index 45b121426ce1..e4ee1a8a5c98 100644
--- a/www-client/seamonkey/ChangeLog
+++ b/www-client/seamonkey/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for www-client/seamonkey
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/seamonkey/ChangeLog,v 1.380 2012/05/24 08:04:26 polynomial-c Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/seamonkey/ChangeLog,v 1.381 2012/05/24 22:48:24 floppym Exp $
+
+ 24 May 2012; Mike Gilbert <floppym@gentoo.org> seamonkey-2.9.1-r1.ebuild,
+ seamonkey-2.9.ebuild:
+ Convert DOS line-endings in shell scripts. Bug 391889.
24 May 2012; Lars Wendler <polynomial-c@gentoo.org>
seamonkey-2.9.1-r1.ebuild:
diff --git a/www-client/seamonkey/seamonkey-2.9.1-r1.ebuild b/www-client/seamonkey/seamonkey-2.9.1-r1.ebuild
index 5b70b7e2b79f..5a24b00679df 100644
--- a/www-client/seamonkey/seamonkey-2.9.1-r1.ebuild
+++ b/www-client/seamonkey/seamonkey-2.9.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/seamonkey/seamonkey-2.9.1-r1.ebuild,v 1.2 2012/05/24 08:04:26 polynomial-c Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/seamonkey/seamonkey-2.9.1-r1.ebuild,v 1.3 2012/05/24 22:48:24 floppym Exp $
EAPI="3"
WANT_AUTOCONF="2.1"
@@ -117,6 +117,13 @@ src_prepare() {
epatch "${DISTDIR}"/${PN}-2.9-revert-system-cairo-breakage.patch.bz2
+ # Shell scripts sometimes contain DOS line endings; bug 391889
+ grep -rlZ --include="*.sh" $'\r$' . |
+ while read -r -d $'\0' file ; do
+ einfo edos2unix "${file}"
+ edos2unix "${file}" || die
+ done
+
# Allow user to apply any additional patches without modifing ebuild
epatch_user
diff --git a/www-client/seamonkey/seamonkey-2.9.ebuild b/www-client/seamonkey/seamonkey-2.9.ebuild
index 5e0158b006d1..a029af43266a 100644
--- a/www-client/seamonkey/seamonkey-2.9.ebuild
+++ b/www-client/seamonkey/seamonkey-2.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/seamonkey/seamonkey-2.9.ebuild,v 1.7 2012/05/08 09:31:49 polynomial-c Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/seamonkey/seamonkey-2.9.ebuild,v 1.8 2012/05/24 22:48:24 floppym Exp $
EAPI="3"
WANT_AUTOCONF="2.1"
@@ -117,6 +117,13 @@ src_prepare() {
epatch "${DISTDIR}"/${PN}-2.9-revert-system-cairo-breakage.patch.bz2
+ # Shell scripts sometimes contain DOS line endings; bug 391889
+ grep -rlZ --include="*.sh" $'\r$' . |
+ while read -r -d $'\0' file ; do
+ einfo edos2unix "${file}"
+ edos2unix "${file}" || die
+ done
+
# Allow user to apply any additional patches without modifing ebuild
epatch_user