summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-client/seamonkey/seamonkey-2.9.ebuild')
-rw-r--r--www-client/seamonkey/seamonkey-2.9.ebuild9
1 files changed, 8 insertions, 1 deletions
diff --git a/www-client/seamonkey/seamonkey-2.9.ebuild b/www-client/seamonkey/seamonkey-2.9.ebuild
index 5e0158b006d1..a029af43266a 100644
--- a/www-client/seamonkey/seamonkey-2.9.ebuild
+++ b/www-client/seamonkey/seamonkey-2.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/seamonkey/seamonkey-2.9.ebuild,v 1.7 2012/05/08 09:31:49 polynomial-c Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/seamonkey/seamonkey-2.9.ebuild,v 1.8 2012/05/24 22:48:24 floppym Exp $
EAPI="3"
WANT_AUTOCONF="2.1"
@@ -117,6 +117,13 @@ src_prepare() {
epatch "${DISTDIR}"/${PN}-2.9-revert-system-cairo-breakage.patch.bz2
+ # Shell scripts sometimes contain DOS line endings; bug 391889
+ grep -rlZ --include="*.sh" $'\r$' . |
+ while read -r -d $'\0' file ; do
+ einfo edos2unix "${file}"
+ edos2unix "${file}" || die
+ done
+
# Allow user to apply any additional patches without modifing ebuild
epatch_user