summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-03-15 02:40:37 +0000
committerMike Frysinger <vapier@gentoo.org>2006-03-15 02:40:37 +0000
commitb6ea6ce0438635a510f08f7b91e1bb3ccc3c07e0 (patch)
tree29c72e6fa420bb13284f32aa869a1dbc80f31111 /sys-libs/glibc/glibc-2.4.ebuild
parentStable on amd64. Bug #122609. (diff)
downloadgentoo-2-b6ea6ce0438635a510f08f7b91e1bb3ccc3c07e0.tar.gz
gentoo-2-b6ea6ce0438635a510f08f7b91e1bb3ccc3c07e0.tar.bz2
gentoo-2-b6ea6ce0438635a510f08f7b91e1bb3ccc3c07e0.zip
add a die message to src_compile
(Portage version: 2.1_pre6-r2)
Diffstat (limited to 'sys-libs/glibc/glibc-2.4.ebuild')
-rw-r--r--sys-libs/glibc/glibc-2.4.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/sys-libs/glibc/glibc-2.4.ebuild b/sys-libs/glibc/glibc-2.4.ebuild
index 376755bcf64a..618127604926 100644
--- a/sys-libs/glibc/glibc-2.4.ebuild
+++ b/sys-libs/glibc/glibc-2.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.4.ebuild,v 1.8 2006/03/15 01:48:51 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.4.ebuild,v 1.9 2006/03/15 02:40:37 vapier Exp $
# TODO:
# - fix warning from glibc build system:
@@ -248,14 +248,14 @@ toolchain-glibc_src_compile() {
if want_linuxthreads ; then
glibc_do_configure linuxthreads
einfo "Building GLIBC with linuxthreads..."
- make PARALLELMFLAGS="${MAKEOPTS}" ${MAKEFLAGS} || die
+ make PARALLELMFLAGS="${MAKEOPTS}" ${MAKEFLAGS} || die "make for ${ABI} failed"
fi
if want_nptl ; then
# ... and then do the optional nptl build
unset LD_ASSUME_KERNEL
glibc_do_configure nptl
einfo "Building GLIBC with NPTL..."
- make PARALLELMFLAGS="${MAKEOPTS}" ${MAKEFLAGS} || die
+ make PARALLELMFLAGS="${MAKEOPTS}" ${MAKEFLAGS} || die "make for ${ABI} failed"
fi
}