summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-03-15 02:40:37 +0000
committerMike Frysinger <vapier@gentoo.org>2006-03-15 02:40:37 +0000
commitb6ea6ce0438635a510f08f7b91e1bb3ccc3c07e0 (patch)
tree29c72e6fa420bb13284f32aa869a1dbc80f31111 /sys-libs
parentStable on amd64. Bug #122609. (diff)
downloadgentoo-2-b6ea6ce0438635a510f08f7b91e1bb3ccc3c07e0.tar.gz
gentoo-2-b6ea6ce0438635a510f08f7b91e1bb3ccc3c07e0.tar.bz2
gentoo-2-b6ea6ce0438635a510f08f7b91e1bb3ccc3c07e0.zip
add a die message to src_compile
(Portage version: 2.1_pre6-r2)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/glibc/glibc-2.3.6-r1.ebuild6
-rw-r--r--sys-libs/glibc/glibc-2.3.6-r2.ebuild6
-rw-r--r--sys-libs/glibc/glibc-2.3.6-r3.ebuild6
-rw-r--r--sys-libs/glibc/glibc-2.3.6.ebuild6
-rw-r--r--sys-libs/glibc/glibc-2.4.ebuild6
5 files changed, 15 insertions, 15 deletions
diff --git a/sys-libs/glibc/glibc-2.3.6-r1.ebuild b/sys-libs/glibc/glibc-2.3.6-r1.ebuild
index ca07155b50a9..a669ec42a040 100644
--- a/sys-libs/glibc/glibc-2.3.6-r1.ebuild
+++ b/sys-libs/glibc/glibc-2.3.6-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.6-r1.ebuild,v 1.17 2006/03/15 01:48:51 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.6-r1.ebuild,v 1.18 2006/03/15 02:40:36 vapier Exp $
# Here's how the cross-compile logic breaks down ...
# CTARGET - machine that will target the binaries
@@ -240,14 +240,14 @@ toolchain-glibc_src_compile() {
if want_linuxthreads ; then
glibc_do_configure linuxthreads
einfo "Building GLIBC with linuxthreads..."
- make PARALLELMFLAGS="${MAKEOPTS}" ${MAKEFLAGS} || die
+ make PARALLELMFLAGS="${MAKEOPTS}" ${MAKEFLAGS} || die "make for ${ABI} failed"
fi
if want_nptl ; then
# ... and then do the optional nptl build
unset LD_ASSUME_KERNEL
glibc_do_configure nptl
einfo "Building GLIBC with NPTL..."
- make PARALLELMFLAGS="${MAKEOPTS}" ${MAKEFLAGS} || die
+ make PARALLELMFLAGS="${MAKEOPTS}" ${MAKEFLAGS} || die "make for ${ABI} failed"
fi
}
diff --git a/sys-libs/glibc/glibc-2.3.6-r2.ebuild b/sys-libs/glibc/glibc-2.3.6-r2.ebuild
index 2becf048477a..5d0dfc4a1681 100644
--- a/sys-libs/glibc/glibc-2.3.6-r2.ebuild
+++ b/sys-libs/glibc/glibc-2.3.6-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.6-r2.ebuild,v 1.14 2006/03/15 01:48:51 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.6-r2.ebuild,v 1.15 2006/03/15 02:40:37 vapier Exp $
# TODO:
# - fix warning from glibc build system:
@@ -248,14 +248,14 @@ toolchain-glibc_src_compile() {
if want_linuxthreads ; then
glibc_do_configure linuxthreads
einfo "Building GLIBC with linuxthreads..."
- make PARALLELMFLAGS="${MAKEOPTS}" ${MAKEFLAGS} || die
+ make PARALLELMFLAGS="${MAKEOPTS}" ${MAKEFLAGS} || die "make for ${ABI} failed"
fi
if want_nptl ; then
# ... and then do the optional nptl build
unset LD_ASSUME_KERNEL
glibc_do_configure nptl
einfo "Building GLIBC with NPTL..."
- make PARALLELMFLAGS="${MAKEOPTS}" ${MAKEFLAGS} || die
+ make PARALLELMFLAGS="${MAKEOPTS}" ${MAKEFLAGS} || die "make for ${ABI} failed"
fi
}
diff --git a/sys-libs/glibc/glibc-2.3.6-r3.ebuild b/sys-libs/glibc/glibc-2.3.6-r3.ebuild
index 8ae65bd63e30..7cc0fa9ce7c9 100644
--- a/sys-libs/glibc/glibc-2.3.6-r3.ebuild
+++ b/sys-libs/glibc/glibc-2.3.6-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.6-r3.ebuild,v 1.5 2006/03/15 01:48:51 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.6-r3.ebuild,v 1.6 2006/03/15 02:40:37 vapier Exp $
# TODO:
# - fix warning from glibc build system:
@@ -248,14 +248,14 @@ toolchain-glibc_src_compile() {
if want_linuxthreads ; then
glibc_do_configure linuxthreads
einfo "Building GLIBC with linuxthreads..."
- make PARALLELMFLAGS="${MAKEOPTS}" ${MAKEFLAGS} || die
+ make PARALLELMFLAGS="${MAKEOPTS}" ${MAKEFLAGS} || die "make for ${ABI} failed"
fi
if want_nptl ; then
# ... and then do the optional nptl build
unset LD_ASSUME_KERNEL
glibc_do_configure nptl
einfo "Building GLIBC with NPTL..."
- make PARALLELMFLAGS="${MAKEOPTS}" ${MAKEFLAGS} || die
+ make PARALLELMFLAGS="${MAKEOPTS}" ${MAKEFLAGS} || die "make for ${ABI} failed"
fi
}
diff --git a/sys-libs/glibc/glibc-2.3.6.ebuild b/sys-libs/glibc/glibc-2.3.6.ebuild
index 9055114b178e..96f33aff05df 100644
--- a/sys-libs/glibc/glibc-2.3.6.ebuild
+++ b/sys-libs/glibc/glibc-2.3.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.6.ebuild,v 1.16 2006/01/25 04:39:50 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.6.ebuild,v 1.17 2006/03/15 02:40:37 vapier Exp $
# Here's how the cross-compile logic breaks down ...
# CTARGET - machine that will target the binaries
@@ -236,14 +236,14 @@ toolchain-glibc_src_compile() {
if want_linuxthreads ; then
glibc_do_configure linuxthreads
einfo "Building GLIBC with linuxthreads..."
- make PARALLELMFLAGS="${MAKEOPTS}" ${MAKEFLAGS} || die
+ make PARALLELMFLAGS="${MAKEOPTS}" ${MAKEFLAGS} || die "make for ${ABI} failed"
fi
if want_nptl ; then
# ... and then do the optional nptl build
unset LD_ASSUME_KERNEL
glibc_do_configure nptl
einfo "Building GLIBC with NPTL..."
- make PARALLELMFLAGS="${MAKEOPTS}" ${MAKEFLAGS} || die
+ make PARALLELMFLAGS="${MAKEOPTS}" ${MAKEFLAGS} || die "make for ${ABI} failed"
fi
}
diff --git a/sys-libs/glibc/glibc-2.4.ebuild b/sys-libs/glibc/glibc-2.4.ebuild
index 376755bcf64a..618127604926 100644
--- a/sys-libs/glibc/glibc-2.4.ebuild
+++ b/sys-libs/glibc/glibc-2.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.4.ebuild,v 1.8 2006/03/15 01:48:51 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.4.ebuild,v 1.9 2006/03/15 02:40:37 vapier Exp $
# TODO:
# - fix warning from glibc build system:
@@ -248,14 +248,14 @@ toolchain-glibc_src_compile() {
if want_linuxthreads ; then
glibc_do_configure linuxthreads
einfo "Building GLIBC with linuxthreads..."
- make PARALLELMFLAGS="${MAKEOPTS}" ${MAKEFLAGS} || die
+ make PARALLELMFLAGS="${MAKEOPTS}" ${MAKEFLAGS} || die "make for ${ABI} failed"
fi
if want_nptl ; then
# ... and then do the optional nptl build
unset LD_ASSUME_KERNEL
glibc_do_configure nptl
einfo "Building GLIBC with NPTL..."
- make PARALLELMFLAGS="${MAKEOPTS}" ${MAKEFLAGS} || die
+ make PARALLELMFLAGS="${MAKEOPTS}" ${MAKEFLAGS} || die "make for ${ABI} failed"
fi
}