summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2007-08-29 18:33:27 +0000
committerStefan Schweizer <genstef@gentoo.org>2007-08-29 18:33:27 +0000
commitd6c12e3b6fa5fe895e4f6bdb1bbb380fbc99d57e (patch)
tree1f9c02a2d08692360cb679d0d21ef8775f8b3e5b /sys-fs
parentRemoving kaiowas from metadata due to his retirement (see #61930 for reference). (diff)
downloadgentoo-2-d6c12e3b6fa5fe895e4f6bdb1bbb380fbc99d57e.tar.gz
gentoo-2-d6c12e3b6fa5fe895e4f6bdb1bbb380fbc99d57e.tar.bz2
gentoo-2-d6c12e3b6fa5fe895e4f6bdb1bbb380fbc99d57e.zip
Fix kernel 2.6.22 thanks to Alexander Skwar <askwar@digitalprojects.com> in bug 189561
(Portage version: 2.1.3.7)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/cloop/ChangeLog9
-rw-r--r--sys-fs/cloop/cloop-2.05.ebuild11
-rw-r--r--sys-fs/cloop/files/cloop-2.05-kernel_2.6.22.patch12
3 files changed, 29 insertions, 3 deletions
diff --git a/sys-fs/cloop/ChangeLog b/sys-fs/cloop/ChangeLog
index 77bf1a758691..f0a51b01a432 100644
--- a/sys-fs/cloop/ChangeLog
+++ b/sys-fs/cloop/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-fs/cloop
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/cloop/ChangeLog,v 1.17 2007/05/12 02:13:08 dsd Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/cloop/ChangeLog,v 1.18 2007/08/29 18:33:26 genstef Exp $
+
+*cloop-2.05.ebuild (29 Aug 2007)
+
+ 29 Aug 2007; Stefan Schweizer <genstef@gentoo.org>
+ +files/cloop-2.05-kernel_2.6.22.patch, cloop-2.05.ebuild:
+ Fix kernel 2.6.22 thanks to Alexander Skwar <askwar@digitalprojects.com> in
+ bug 189561
12 May 2007; Daniel Drake <dsd@gentoo.org> metadata.xml:
Move from kernel to kernel-misc herd
diff --git a/sys-fs/cloop/cloop-2.05.ebuild b/sys-fs/cloop/cloop-2.05.ebuild
index 0bcffc2837ec..de1a20d72fe4 100644
--- a/sys-fs/cloop/cloop-2.05.ebuild
+++ b/sys-fs/cloop/cloop-2.05.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/cloop/cloop-2.05.ebuild,v 1.1 2006/12/07 19:41:51 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/cloop/cloop-2.05.ebuild,v 1.2 2007/08/29 18:33:26 genstef Exp $
inherit linux-mod
@@ -14,6 +14,13 @@ IUSE=""
S=${WORKDIR}/${P}~20060829
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ # This should only be applied on Kernel >= 2.6.22
+ kernel_is ge 2 6 22 && epatch ${FILESDIR}/${P}-kernel_2.6.22.patch
+}
+
pkg_setup() {
kernel_is 2 4 && die "kernel 2.4 is not supported"
CONFIG_CHECK="ZLIB_INFLATE"
diff --git a/sys-fs/cloop/files/cloop-2.05-kernel_2.6.22.patch b/sys-fs/cloop/files/cloop-2.05-kernel_2.6.22.patch
new file mode 100644
index 000000000000..8b790e911043
--- /dev/null
+++ b/sys-fs/cloop/files/cloop-2.05-kernel_2.6.22.patch
@@ -0,0 +1,12 @@
+diff -ur cloop-2.05~20060829.original/compressed_loop.c cloop-2.05~20060829/compressed_loop.c
+--- cloop-2.05~20060829.original/compressed_loop.c 2006-12-04 00:07:02.000000000 +0100
++++ cloop-2.05~20060829/compressed_loop.c 2007-08-20 09:20:20.289119997 +0200
+@@ -625,7 +625,7 @@
+ if(clo->compressed_buffer) { vfree(clo->compressed_buffer); clo->compressed_buffer = NULL; }
+ zlib_inflateEnd(&clo->zstream);
+ if(clo->zstream.workspace) { vfree(clo->zstream.workspace); clo->zstream.workspace = NULL; }
+- invalidate_bdev(bdev, 0);
++ invalidate_bdev(bdev);
+ set_capacity(clo->disk, 0);
+ return 0;
+ }