summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs/cloop/cloop-2.05.ebuild')
-rw-r--r--sys-fs/cloop/cloop-2.05.ebuild11
1 files changed, 9 insertions, 2 deletions
diff --git a/sys-fs/cloop/cloop-2.05.ebuild b/sys-fs/cloop/cloop-2.05.ebuild
index 0bcffc2837ec..de1a20d72fe4 100644
--- a/sys-fs/cloop/cloop-2.05.ebuild
+++ b/sys-fs/cloop/cloop-2.05.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/cloop/cloop-2.05.ebuild,v 1.1 2006/12/07 19:41:51 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/cloop/cloop-2.05.ebuild,v 1.2 2007/08/29 18:33:26 genstef Exp $
inherit linux-mod
@@ -14,6 +14,13 @@ IUSE=""
S=${WORKDIR}/${P}~20060829
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ # This should only be applied on Kernel >= 2.6.22
+ kernel_is ge 2 6 22 && epatch ${FILESDIR}/${P}-kernel_2.6.22.patch
+}
+
pkg_setup() {
kernel_is 2 4 && die "kernel 2.4 is not supported"
CONFIG_CHECK="ZLIB_INFLATE"