summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2006-09-05 16:27:52 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2006-09-05 16:27:52 +0000
commitaeff188b019e199551f7a655e7cb99db910c73a1 (patch)
tree491ac9f29eb9478b4ec9ce1e9fbab72e2c197f78 /sys-fs
parentAdded ~alpha to 2.6.16-r13, which works for me and was used to build a LiveCD. (diff)
downloadgentoo-2-aeff188b019e199551f7a655e7cb99db910c73a1.tar.gz
gentoo-2-aeff188b019e199551f7a655e7cb99db910c73a1.tar.bz2
gentoo-2-aeff188b019e199551f7a655e7cb99db910c73a1.zip
Version bump. Closing bug #145676.
(Portage version: 2.1.1_rc1-r1)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/squashfs-tools/ChangeLog8
-rw-r--r--sys-fs/squashfs-tools/files/digest-squashfs-tools-3.1_p23
-rw-r--r--sys-fs/squashfs-tools/squashfs-tools-3.1.ebuild4
-rw-r--r--sys-fs/squashfs-tools/squashfs-tools-3.1_p2.ebuild35
4 files changed, 47 insertions, 3 deletions
diff --git a/sys-fs/squashfs-tools/ChangeLog b/sys-fs/squashfs-tools/ChangeLog
index c7953d2a1635..2834f33b4300 100644
--- a/sys-fs/squashfs-tools/ChangeLog
+++ b/sys-fs/squashfs-tools/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-fs/squashfs-tools
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/squashfs-tools/ChangeLog,v 1.38 2006/08/28 18:43:35 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/squashfs-tools/ChangeLog,v 1.39 2006/09/05 16:27:52 wolf31o2 Exp $
+
+*squashfs-tools-3.1_p2 (05 Sep 2006)
+
+ 05 Sep 2006; Chris Gianelloni <wolf31o2@gentoo.org>
+ squashfs-tools-3.1.ebuild, +squashfs-tools-3.1_p2.ebuild:
+ Version bump. Closing bug #145676.
*squashfs-tools-3.1 (28 Aug 2006)
diff --git a/sys-fs/squashfs-tools/files/digest-squashfs-tools-3.1_p2 b/sys-fs/squashfs-tools/files/digest-squashfs-tools-3.1_p2
new file mode 100644
index 000000000000..714e331205df
--- /dev/null
+++ b/sys-fs/squashfs-tools/files/digest-squashfs-tools-3.1_p2
@@ -0,0 +1,3 @@
+MD5 c252e5286b142afa54ca49829c51a33f squashfs3.1-r2.tar.gz 476346
+RMD160 8dfcc48262941f6d809119fbb367e8953141a2be squashfs3.1-r2.tar.gz 476346
+SHA256 ec3159feae5324e78f7fc09f8f534bd6a3e7ed735144ee8a8e9e7871e77115e0 squashfs3.1-r2.tar.gz 476346
diff --git a/sys-fs/squashfs-tools/squashfs-tools-3.1.ebuild b/sys-fs/squashfs-tools/squashfs-tools-3.1.ebuild
index 4bb3e133b43a..e8cca3bc87c6 100644
--- a/sys-fs/squashfs-tools/squashfs-tools-3.1.ebuild
+++ b/sys-fs/squashfs-tools/squashfs-tools-3.1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/squashfs-tools/squashfs-tools-3.1.ebuild,v 1.1 2006/08/28 18:43:35 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/squashfs-tools/squashfs-tools-3.1.ebuild,v 1.2 2006/09/05 16:27:52 wolf31o2 Exp $
inherit toolchain-funcs
-MY_PV=${PV/_p/r}
+MY_PV=${PV/_p/-r}
DESCRIPTION="Tool for creating compressed filesystem type squashfs"
HOMEPAGE="http://squashfs.sourceforge.net/"
SRC_URI="mirror://sourceforge/squashfs/squashfs${MY_PV}.tar.gz"
diff --git a/sys-fs/squashfs-tools/squashfs-tools-3.1_p2.ebuild b/sys-fs/squashfs-tools/squashfs-tools-3.1_p2.ebuild
new file mode 100644
index 000000000000..9c5bd9e92319
--- /dev/null
+++ b/sys-fs/squashfs-tools/squashfs-tools-3.1_p2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/squashfs-tools/squashfs-tools-3.1_p2.ebuild,v 1.1 2006/09/05 16:27:52 wolf31o2 Exp $
+
+inherit toolchain-funcs
+
+MY_PV=${PV/_p/-r}
+DESCRIPTION="Tool for creating compressed filesystem type squashfs"
+HOMEPAGE="http://squashfs.sourceforge.net/"
+SRC_URI="mirror://sourceforge/squashfs/squashfs${MY_PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+RDEPEND="sys-libs/zlib"
+
+S=${WORKDIR}/squashfs${PV/_p/-r}/squashfs-tools
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i "s:-O2:${CFLAGS}:" Makefile
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" || die
+}
+
+src_install() {
+ dobin mksquashfs unsquashfs || die
+ cd ..
+ dodoc README ACKNOWLEDGEMENTS CHANGES PERFORMANCE.README README-3.1
+}