summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs/squashfs-tools/squashfs-tools-3.1_p2.ebuild')
-rw-r--r--sys-fs/squashfs-tools/squashfs-tools-3.1_p2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/sys-fs/squashfs-tools/squashfs-tools-3.1_p2.ebuild b/sys-fs/squashfs-tools/squashfs-tools-3.1_p2.ebuild
new file mode 100644
index 000000000000..9c5bd9e92319
--- /dev/null
+++ b/sys-fs/squashfs-tools/squashfs-tools-3.1_p2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/squashfs-tools/squashfs-tools-3.1_p2.ebuild,v 1.1 2006/09/05 16:27:52 wolf31o2 Exp $
+
+inherit toolchain-funcs
+
+MY_PV=${PV/_p/-r}
+DESCRIPTION="Tool for creating compressed filesystem type squashfs"
+HOMEPAGE="http://squashfs.sourceforge.net/"
+SRC_URI="mirror://sourceforge/squashfs/squashfs${MY_PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+RDEPEND="sys-libs/zlib"
+
+S=${WORKDIR}/squashfs${PV/_p/-r}/squashfs-tools
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i "s:-O2:${CFLAGS}:" Makefile
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" || die
+}
+
+src_install() {
+ dobin mksquashfs unsquashfs || die
+ cd ..
+ dodoc README ACKNOWLEDGEMENTS CHANGES PERFORMANCE.README README-3.1
+}