summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2010-10-17 00:54:13 +0000
committerMichael Weber <xmw@gentoo.org>2010-10-17 00:54:13 +0000
commit59a81fd0a0dfbc74e26f5e5848adcaf2ff11ddf4 (patch)
tree92853856cfe8a698947e36a439a8dc93e197a6a0 /sys-auth
parentVersion bump. (diff)
downloadgentoo-2-59a81fd0a0dfbc74e26f5e5848adcaf2ff11ddf4.tar.gz
gentoo-2-59a81fd0a0dfbc74e26f5e5848adcaf2ff11ddf4.tar.bz2
gentoo-2-59a81fd0a0dfbc74e26f5e5848adcaf2ff11ddf4.zip
initial import
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/libfprint/ChangeLog11
-rw-r--r--sys-auth/libfprint/libfprint-0.0.6.ebuild45
-rw-r--r--sys-auth/libfprint/libfprint-0.1.0_pre2.ebuild50
-rw-r--r--sys-auth/libfprint/metadata.xml10
4 files changed, 116 insertions, 0 deletions
diff --git a/sys-auth/libfprint/ChangeLog b/sys-auth/libfprint/ChangeLog
new file mode 100644
index 000000000000..a513ce5bc2b2
--- /dev/null
+++ b/sys-auth/libfprint/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for sys-auth/libfprint
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/libfprint/ChangeLog,v 1.1 2010/10/17 00:54:13 xmw Exp $
+
+*libfprint-0.1.0_pre2 (17 Oct 2010)
+*libfprint-0.0.6 (17 Oct 2010)
+
+ 17 Oct 2010; Michael Weber <xmw@gentoo.org> +libfprint-0.0.6.ebuild,
+ +libfprint-0.1.0_pre2.ebuild, +metadata.xml:
+ Initial import, fixes bug 341107 by Jan Buecken <jb.faq@gmx.de>
+
diff --git a/sys-auth/libfprint/libfprint-0.0.6.ebuild b/sys-auth/libfprint/libfprint-0.0.6.ebuild
new file mode 100644
index 000000000000..29ecec9e8eac
--- /dev/null
+++ b/sys-auth/libfprint/libfprint-0.0.6.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/libfprint/libfprint-0.0.6.ebuild,v 1.1 2010/10/17 00:54:13 xmw Exp $
+
+EAPI=3
+
+DESCRIPTION="library to add support for consumer fingerprint readers"
+HOMEPAGE="http://www.reactivated.net/fprint/wiki/Libfprint"
+SRC_URI="mirror://sourceforge/${PN/lib/}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="X debug examples static-libs"
+
+RDEPEND="dev-libs/glib:2
+ dev-libs/libusb
+ dev-libs/openssl
+ media-gfx/imagemagick
+ X? ( examples? (
+ x11-libs/libX11
+ x11-libs/libXv ) )"
+DEPEND="${DEPEND}
+ dev-util/pkgconfig"
+
+src_configure() {
+ local my_conf="$(use_enable examples examples-build)"
+ if use X ; then
+ my_conf="${my_conf} $(use_enable examples x11-examples-build)"
+ fi
+ econf ${my_conf} \
+ $(use_enable debug debug-log) \
+ $(use_enable static-libs static) || die
+}
+
+src_install(){
+ emake DESTDIR="${D}" install || die
+ if use examples ; then
+ dobin examples/.libs/{enroll,img_capture,verify{,_live}} || die
+ if use X ; then
+ dobin examples/.libs/img_capture_continuous || die
+ fi
+ fi
+ dodoc AUTHORS ChangeLog HACKING NEWS README THANKS TODO || die
+}
diff --git a/sys-auth/libfprint/libfprint-0.1.0_pre2.ebuild b/sys-auth/libfprint/libfprint-0.1.0_pre2.ebuild
new file mode 100644
index 000000000000..9ca81f9fc39c
--- /dev/null
+++ b/sys-auth/libfprint/libfprint-0.1.0_pre2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/libfprint/libfprint-0.1.0_pre2.ebuild,v 1.1 2010/10/17 00:54:13 xmw Exp $
+
+EAPI=3
+
+inherit versionator
+
+MY_PV=$(replace_version_separator 3 -)
+DESCRIPTION="library to add support for consumer fingerprint readers"
+HOMEPAGE="http://www.reactivated.net/fprint/wiki/Libfprint"
+SRC_URI="mirror://sourceforge/${PN/lib/}/${PN}-${MY_PV}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="X debug examples static-libs"
+
+RDEPEND="dev-libs/glib:2
+ dev-libs/libusb:1
+ dev-libs/openssl
+ media-gfx/imagemagick
+ X? ( examples? (
+ x11-libs/libXv ) )"
+
+DEPEND="${DEPEND}
+ dev-util/pkgconfig"
+
+S=${WORKDIR}/${PN}-${MY_PV}
+
+src_configure(){
+ local my_conf="$(use_enable examples examples-build)"
+ if use X ; then
+ my_conf="${my_conf} $(use_enable examples x11-examples-build)"
+ fi
+ econf ${my_conf} \
+ $(use_enable debug debug-log) \
+ $(use_enable static-libs static) || die
+}
+
+src_install(){
+ emake DESTDIR="${D}" install || die
+ if use examples ; then
+ dobin examples/.libs/{enroll,img_capture,verify{,_live}} || die
+ if use X ; then
+ dobin examples/.libs/img_capture_continuous || die
+ fi
+ fi
+ dodoc AUTHORS ChangeLog HACKING NEWS README THANKS TODO || die
+}
diff --git a/sys-auth/libfprint/metadata.xml b/sys-auth/libfprint/metadata.xml
new file mode 100644
index 000000000000..02b909e46b7e
--- /dev/null
+++ b/sys-auth/libfprint/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+<email>xmw@gentoo.org</email>
+<name>Michael Weber</name>
+</maintainer>
+</pkgmetadata>
+