summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-auth/libfprint/libfprint-0.1.0_pre2.ebuild')
-rw-r--r--sys-auth/libfprint/libfprint-0.1.0_pre2.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/sys-auth/libfprint/libfprint-0.1.0_pre2.ebuild b/sys-auth/libfprint/libfprint-0.1.0_pre2.ebuild
new file mode 100644
index 000000000000..9ca81f9fc39c
--- /dev/null
+++ b/sys-auth/libfprint/libfprint-0.1.0_pre2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/libfprint/libfprint-0.1.0_pre2.ebuild,v 1.1 2010/10/17 00:54:13 xmw Exp $
+
+EAPI=3
+
+inherit versionator
+
+MY_PV=$(replace_version_separator 3 -)
+DESCRIPTION="library to add support for consumer fingerprint readers"
+HOMEPAGE="http://www.reactivated.net/fprint/wiki/Libfprint"
+SRC_URI="mirror://sourceforge/${PN/lib/}/${PN}-${MY_PV}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="X debug examples static-libs"
+
+RDEPEND="dev-libs/glib:2
+ dev-libs/libusb:1
+ dev-libs/openssl
+ media-gfx/imagemagick
+ X? ( examples? (
+ x11-libs/libXv ) )"
+
+DEPEND="${DEPEND}
+ dev-util/pkgconfig"
+
+S=${WORKDIR}/${PN}-${MY_PV}
+
+src_configure(){
+ local my_conf="$(use_enable examples examples-build)"
+ if use X ; then
+ my_conf="${my_conf} $(use_enable examples x11-examples-build)"
+ fi
+ econf ${my_conf} \
+ $(use_enable debug debug-log) \
+ $(use_enable static-libs static) || die
+}
+
+src_install(){
+ emake DESTDIR="${D}" install || die
+ if use examples ; then
+ dobin examples/.libs/{enroll,img_capture,verify{,_live}} || die
+ if use X ; then
+ dobin examples/.libs/img_capture_continuous || die
+ fi
+ fi
+ dodoc AUTHORS ChangeLog HACKING NEWS README THANKS TODO || die
+}