summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2007-10-09 23:39:47 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2007-10-09 23:39:47 +0000
commit4910779b6a0e6908c737e784bf995212a7d45b30 (patch)
tree1d8342661a2013b8822c172e8b54beda6d490064 /sys-auth/nss_ldap/nss_ldap-254.ebuild
parent~amd64 keyword as per bug #195303 thanks to Sergio Bevilacqua (diff)
downloadgentoo-2-4910779b6a0e6908c737e784bf995212a7d45b30.tar.gz
gentoo-2-4910779b6a0e6908c737e784bf995212a7d45b30.tar.bz2
gentoo-2-4910779b6a0e6908c737e784bf995212a7d45b30.zip
Fix quoting for all ebuilds.
(Portage version: 2.1.3.12)
Diffstat (limited to 'sys-auth/nss_ldap/nss_ldap-254.ebuild')
-rw-r--r--sys-auth/nss_ldap/nss_ldap-254.ebuild20
1 files changed, 10 insertions, 10 deletions
diff --git a/sys-auth/nss_ldap/nss_ldap-254.ebuild b/sys-auth/nss_ldap/nss_ldap-254.ebuild
index 0c8ed89877bd..d8f024b19912 100644
--- a/sys-auth/nss_ldap/nss_ldap-254.ebuild
+++ b/sys-auth/nss_ldap/nss_ldap-254.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/nss_ldap/nss_ldap-254.ebuild,v 1.1 2007/02/06 04:50:25 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/nss_ldap/nss_ldap-254.ebuild,v 1.2 2007/10/09 23:39:47 robbat2 Exp $
inherit fixheadtails eutils multilib
@@ -22,22 +22,22 @@ RDEPEND="${DEPEND}
src_unpack() {
unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/nsswitch.ldap.diff
- epatch ${FILESDIR}/${PN}-239-tls-security-bug.patch
- epatch ${FILESDIR}/${PN}-249-sasl-compile.patch
- EPATCH_OPTS="-p1 -d ${S}" epatch ${FILESDIR}/${PN}-252-reconnect-timeouts.patch
- EPATCH_OPTS="-p1 -d ${S}" epatch ${FILESDIR}/${PN}-254-nss_getgrent_skipmembers.patch
+ cd "${S}"
+ epatch "${FILESDIR}"/nsswitch.ldap.diff
+ epatch "${FILESDIR}"/${PN}-239-tls-security-bug.patch
+ epatch "${FILESDIR}"/${PN}-249-sasl-compile.patch
+ EPATCH_OPTS="-p1 -d ${S}" epatch "${FILESDIR}"/${PN}-252-reconnect-timeouts.patch
+ EPATCH_OPTS="-p1 -d ${S}" epatch "${FILESDIR}"/${PN}-254-nss_getgrent_skipmembers.patch
sed -i.orig \
-e '/^ @(#)\$Id: ldap.conf,v/s,^,#,' \
- ${S}/ldap.conf || die "failed to clean up initial version marker"
+ "${S}"/ldap.conf || die "failed to clean up initial version marker"
# fix head/tail stuff
- ht_fix_file ${S}/Makefile.am ${S}/Makefile.in ${S}/depcomp
+ ht_fix_file "${S}"/Makefile.am "${S}"/Makefile.in "${S}"/depcomp
# fix build borkage
for i in Makefile.{in,am}; do
sed -i.orig \
-e '/^install-exec-local: nss_ldap.so/s,nss_ldap.so,,g' \
- ${S}/$i
+ "${S}"/$i
done
}