summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2007-10-09 23:39:47 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2007-10-09 23:39:47 +0000
commit4910779b6a0e6908c737e784bf995212a7d45b30 (patch)
tree1d8342661a2013b8822c172e8b54beda6d490064 /sys-auth/nss_ldap
parent~amd64 keyword as per bug #195303 thanks to Sergio Bevilacqua (diff)
downloadgentoo-2-4910779b6a0e6908c737e784bf995212a7d45b30.tar.gz
gentoo-2-4910779b6a0e6908c737e784bf995212a7d45b30.tar.bz2
gentoo-2-4910779b6a0e6908c737e784bf995212a7d45b30.zip
Fix quoting for all ebuilds.
(Portage version: 2.1.3.12)
Diffstat (limited to 'sys-auth/nss_ldap')
-rw-r--r--sys-auth/nss_ldap/ChangeLog8
-rw-r--r--sys-auth/nss_ldap/nss_ldap-239-r1.ebuild12
-rw-r--r--sys-auth/nss_ldap/nss_ldap-249.ebuild14
-rw-r--r--sys-auth/nss_ldap/nss_ldap-250-r1.ebuild16
-rw-r--r--sys-auth/nss_ldap/nss_ldap-250.ebuild14
-rw-r--r--sys-auth/nss_ldap/nss_ldap-252.ebuild18
-rw-r--r--sys-auth/nss_ldap/nss_ldap-253-r1.ebuild18
-rw-r--r--sys-auth/nss_ldap/nss_ldap-253.ebuild18
-rw-r--r--sys-auth/nss_ldap/nss_ldap-254.ebuild20
-rw-r--r--sys-auth/nss_ldap/nss_ldap-257.ebuild22
10 files changed, 83 insertions, 77 deletions
diff --git a/sys-auth/nss_ldap/ChangeLog b/sys-auth/nss_ldap/ChangeLog
index 5c15226cc0a6..ebdf28a7a470 100644
--- a/sys-auth/nss_ldap/ChangeLog
+++ b/sys-auth/nss_ldap/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-auth/nss_ldap
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/nss_ldap/ChangeLog,v 1.41 2007/09/18 23:18:35 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/nss_ldap/ChangeLog,v 1.42 2007/10/09 23:39:47 robbat2 Exp $
+
+ 09 Oct 2007; Robin H. Johnson <robbat2@gentoo.org> nss_ldap-239-r1.ebuild,
+ nss_ldap-249.ebuild, nss_ldap-250.ebuild, nss_ldap-250-r1.ebuild,
+ nss_ldap-252.ebuild, nss_ldap-253.ebuild, nss_ldap-253-r1.ebuild,
+ nss_ldap-254.ebuild, nss_ldap-257.ebuild:
+ Fix quoting for all ebuilds.
*nss_ldap-257 (18 Sep 2007)
diff --git a/sys-auth/nss_ldap/nss_ldap-239-r1.ebuild b/sys-auth/nss_ldap/nss_ldap-239-r1.ebuild
index 18312604bb5b..dcc26c5fbf7f 100644
--- a/sys-auth/nss_ldap/nss_ldap-239-r1.ebuild
+++ b/sys-auth/nss_ldap/nss_ldap-239-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/nss_ldap/nss_ldap-239-r1.ebuild,v 1.12 2007/01/05 09:12:30 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/nss_ldap/nss_ldap-239-r1.ebuild,v 1.13 2007/10/09 23:39:47 robbat2 Exp $
inherit fixheadtails eutils multilib
@@ -19,11 +19,11 @@ RDEPEND="${DEPEND}"
src_unpack() {
unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/nsswitch.ldap.diff
- epatch ${FILESDIR}/${PN}-239-tls-security-bug.patch
+ cd "${S}"
+ epatch "${FILESDIR}"/nsswitch.ldap.diff
+ epatch "${FILESDIR}"/${PN}-239-tls-security-bug.patch
# fix head/tail stuff
- ht_fix_file ${S}/Makefile.am ${S}/Makefile.in ${S}/depcomp
+ ht_fix_file "${S}"/Makefile.am "${S}"/Makefile.in "${S}"/depcomp
}
src_compile() {
@@ -44,7 +44,7 @@ src_compile() {
src_install() {
dodir /$(get_libdir)
- make DESTDIR=${D} install || die "make install failed"
+ make DESTDIR="${D}" install || die "make install failed"
insinto /etc
doins ldap.conf
diff --git a/sys-auth/nss_ldap/nss_ldap-249.ebuild b/sys-auth/nss_ldap/nss_ldap-249.ebuild
index 6131a1f9938f..c7bd6c1458fd 100644
--- a/sys-auth/nss_ldap/nss_ldap-249.ebuild
+++ b/sys-auth/nss_ldap/nss_ldap-249.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/nss_ldap/nss_ldap-249.ebuild,v 1.7 2007/01/05 09:12:30 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/nss_ldap/nss_ldap-249.ebuild,v 1.8 2007/10/09 23:39:47 robbat2 Exp $
inherit fixheadtails eutils multilib
@@ -19,12 +19,12 @@ RDEPEND="${DEPEND}"
src_unpack() {
unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/nsswitch.ldap.diff
- epatch ${FILESDIR}/${PN}-239-tls-security-bug.patch
- epatch ${FILESDIR}/${PN}-249-sasl-compile.patch
+ cd "${S}"
+ epatch "${FILESDIR}"/nsswitch.ldap.diff
+ epatch "${FILESDIR}"/${PN}-239-tls-security-bug.patch
+ epatch "${FILESDIR}"/${PN}-249-sasl-compile.patch
# fix head/tail stuff
- ht_fix_file ${S}/Makefile.am ${S}/Makefile.in ${S}/depcomp
+ ht_fix_file "${S}"/Makefile.am "${S}"/Makefile.in "${S}"/depcomp
}
src_compile() {
@@ -45,7 +45,7 @@ src_compile() {
src_install() {
dodir /$(get_libdir)
- make DESTDIR=${D} install || die "make install failed"
+ make DESTDIR="${D}" install || die "make install failed"
insinto /etc
doins ldap.conf
diff --git a/sys-auth/nss_ldap/nss_ldap-250-r1.ebuild b/sys-auth/nss_ldap/nss_ldap-250-r1.ebuild
index 706be1ff7bf0..e09c222a81d3 100644
--- a/sys-auth/nss_ldap/nss_ldap-250-r1.ebuild
+++ b/sys-auth/nss_ldap/nss_ldap-250-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/nss_ldap/nss_ldap-250-r1.ebuild,v 1.2 2007/01/05 09:12:30 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/nss_ldap/nss_ldap-250-r1.ebuild,v 1.3 2007/10/09 23:39:47 robbat2 Exp $
inherit fixheadtails eutils multilib
@@ -20,18 +20,18 @@ RDEPEND="${DEPEND}"
src_unpack() {
unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/nsswitch.ldap.diff
- epatch ${FILESDIR}/${PN}-239-tls-security-bug.patch
- epatch ${FILESDIR}/${PN}-249-sasl-compile.patch
- epatch ${FILESDIR}/${PN}-250-reconnect-timeouts.patch
+ cd "${S}"
+ epatch "${FILESDIR}"/nsswitch.ldap.diff
+ epatch "${FILESDIR}"/${PN}-239-tls-security-bug.patch
+ epatch "${FILESDIR}"/${PN}-249-sasl-compile.patch
+ epatch "${FILESDIR}"/${PN}-250-reconnect-timeouts.patch
# fix head/tail stuff
- ht_fix_file ${S}/Makefile.am ${S}/Makefile.in ${S}/depcomp
+ ht_fix_file "${S}"/Makefile.am "${S}"/Makefile.in "${S}"/depcomp
# fix build borkage
for i in Makefile.{in,am}; do
sed -i.orig \
-e '/^install-exec-local: nss_ldap.so/s,nss_ldap.so,,g' \
- ${S}/$i
+ "${S}"/$i
done
}
diff --git a/sys-auth/nss_ldap/nss_ldap-250.ebuild b/sys-auth/nss_ldap/nss_ldap-250.ebuild
index c70790172d2b..e402abc6e5e5 100644
--- a/sys-auth/nss_ldap/nss_ldap-250.ebuild
+++ b/sys-auth/nss_ldap/nss_ldap-250.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/nss_ldap/nss_ldap-250.ebuild,v 1.3 2007/01/05 09:12:30 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/nss_ldap/nss_ldap-250.ebuild,v 1.4 2007/10/09 23:39:47 robbat2 Exp $
inherit fixheadtails eutils multilib
@@ -20,17 +20,17 @@ RDEPEND="${DEPEND}"
src_unpack() {
unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/nsswitch.ldap.diff
- epatch ${FILESDIR}/${PN}-239-tls-security-bug.patch
- epatch ${FILESDIR}/${PN}-249-sasl-compile.patch
+ cd "${S}"
+ epatch "${FILESDIR}"/nsswitch.ldap.diff
+ epatch "${FILESDIR}"/${PN}-239-tls-security-bug.patch
+ epatch "${FILESDIR}"/${PN}-249-sasl-compile.patch
# fix head/tail stuff
- ht_fix_file ${S}/Makefile.am ${S}/Makefile.in ${S}/depcomp
+ ht_fix_file "${S}"/Makefile.am "${S}"/Makefile.in "${S}"/depcomp
# fix build borkage
for i in Makefile.{in,am}; do
sed -i.orig \
-e '/^install-exec-local: nss_ldap.so/s,nss_ldap.so,,g' \
- ${S}/$i
+ "${S}"/$i
done
}
diff --git a/sys-auth/nss_ldap/nss_ldap-252.ebuild b/sys-auth/nss_ldap/nss_ldap-252.ebuild
index 6348dbf3d6df..d88c04e486a6 100644
--- a/sys-auth/nss_ldap/nss_ldap-252.ebuild
+++ b/sys-auth/nss_ldap/nss_ldap-252.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/nss_ldap/nss_ldap-252.ebuild,v 1.2 2007/01/05 09:12:30 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/nss_ldap/nss_ldap-252.ebuild,v 1.3 2007/10/09 23:39:47 robbat2 Exp $
inherit fixheadtails eutils multilib
@@ -21,21 +21,21 @@ RDEPEND="${DEPEND}
src_unpack() {
unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/nsswitch.ldap.diff
- epatch ${FILESDIR}/${PN}-239-tls-security-bug.patch
- epatch ${FILESDIR}/${PN}-249-sasl-compile.patch
- EPATCH_OPTS="-p1 -d ${S}" epatch ${FILESDIR}/${PN}-252-reconnect-timeouts.patch
+ cd "${S}"
+ epatch "${FILESDIR}"/nsswitch.ldap.diff
+ epatch "${FILESDIR}"/${PN}-239-tls-security-bug.patch
+ epatch "${FILESDIR}"/${PN}-249-sasl-compile.patch
+ EPATCH_OPTS="-p1 -d ${S}" epatch "${FILESDIR}"/${PN}-252-reconnect-timeouts.patch
sed -i.orig \
-e '/^ @(#)\$Id: ldap.conf,v/s,^,#,' \
- ${S}/ldap.conf || die "failed to clean up initial version marker"
+ "${S}"/ldap.conf || die "failed to clean up initial version marker"
# fix head/tail stuff
- ht_fix_file ${S}/Makefile.am ${S}/Makefile.in ${S}/depcomp
+ ht_fix_file "${S}"/Makefile.am "${S}"/Makefile.in "${S}"/depcomp
# fix build borkage
for i in Makefile.{in,am}; do
sed -i.orig \
-e '/^install-exec-local: nss_ldap.so/s,nss_ldap.so,,g' \
- ${S}/$i
+ "${S}"/$i
done
}
diff --git a/sys-auth/nss_ldap/nss_ldap-253-r1.ebuild b/sys-auth/nss_ldap/nss_ldap-253-r1.ebuild
index 406c85103ab8..854d0afae462 100644
--- a/sys-auth/nss_ldap/nss_ldap-253-r1.ebuild
+++ b/sys-auth/nss_ldap/nss_ldap-253-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/nss_ldap/nss_ldap-253-r1.ebuild,v 1.1 2007/02/06 04:48:04 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/nss_ldap/nss_ldap-253-r1.ebuild,v 1.2 2007/10/09 23:39:47 robbat2 Exp $
inherit fixheadtails eutils multilib
@@ -22,21 +22,21 @@ RDEPEND="${DEPEND}
src_unpack() {
unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/nsswitch.ldap.diff
- epatch ${FILESDIR}/${PN}-239-tls-security-bug.patch
- epatch ${FILESDIR}/${PN}-249-sasl-compile.patch
- EPATCH_OPTS="-p1 -d ${S}" epatch ${FILESDIR}/${PN}-252-reconnect-timeouts.patch
+ cd "${S}"
+ epatch "${FILESDIR}"/nsswitch.ldap.diff
+ epatch "${FILESDIR}"/${PN}-239-tls-security-bug.patch
+ epatch "${FILESDIR}"/${PN}-249-sasl-compile.patch
+ EPATCH_OPTS="-p1 -d ${S}" epatch "${FILESDIR}"/${PN}-252-reconnect-timeouts.patch
sed -i.orig \
-e '/^ @(#)\$Id: ldap.conf,v/s,^,#,' \
- ${S}/ldap.conf || die "failed to clean up initial version marker"
+ "${S}"/ldap.conf || die "failed to clean up initial version marker"
# fix head/tail stuff
- ht_fix_file ${S}/Makefile.am ${S}/Makefile.in ${S}/depcomp
+ ht_fix_file "${S}"/Makefile.am "${S}"/Makefile.in "${S}"/depcomp
# fix build borkage
for i in Makefile.{in,am}; do
sed -i.orig \
-e '/^install-exec-local: nss_ldap.so/s,nss_ldap.so,,g' \
- ${S}/$i
+ "${S}"/$i
done
}
diff --git a/sys-auth/nss_ldap/nss_ldap-253.ebuild b/sys-auth/nss_ldap/nss_ldap-253.ebuild
index 1d694bf8fc67..1aabc00ccd59 100644
--- a/sys-auth/nss_ldap/nss_ldap-253.ebuild
+++ b/sys-auth/nss_ldap/nss_ldap-253.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/nss_ldap/nss_ldap-253.ebuild,v 1.9 2007/01/27 03:27:17 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/nss_ldap/nss_ldap-253.ebuild,v 1.10 2007/10/09 23:39:47 robbat2 Exp $
inherit fixheadtails eutils multilib
@@ -21,21 +21,21 @@ RDEPEND="${DEPEND}
src_unpack() {
unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/nsswitch.ldap.diff
- epatch ${FILESDIR}/${PN}-239-tls-security-bug.patch
- epatch ${FILESDIR}/${PN}-249-sasl-compile.patch
- EPATCH_OPTS="-p1 -d ${S}" epatch ${FILESDIR}/${PN}-252-reconnect-timeouts.patch
+ cd "${S}"
+ epatch "${FILESDIR}"/nsswitch.ldap.diff
+ epatch "${FILESDIR}"/${PN}-239-tls-security-bug.patch
+ epatch "${FILESDIR}"/${PN}-249-sasl-compile.patch
+ EPATCH_OPTS="-p1 -d ${S}" epatch "${FILESDIR}"/${PN}-252-reconnect-timeouts.patch
sed -i.orig \
-e '/^ @(#)\$Id: ldap.conf,v/s,^,#,' \
- ${S}/ldap.conf || die "failed to clean up initial version marker"
+ "${S}"/ldap.conf || die "failed to clean up initial version marker"
# fix head/tail stuff
- ht_fix_file ${S}/Makefile.am ${S}/Makefile.in ${S}/depcomp
+ ht_fix_file "${S}"/Makefile.am "${S}"/Makefile.in "${S}"/depcomp
# fix build borkage
for i in Makefile.{in,am}; do
sed -i.orig \
-e '/^install-exec-local: nss_ldap.so/s,nss_ldap.so,,g' \
- ${S}/$i
+ "${S}"/$i
done
}
diff --git a/sys-auth/nss_ldap/nss_ldap-254.ebuild b/sys-auth/nss_ldap/nss_ldap-254.ebuild
index 0c8ed89877bd..d8f024b19912 100644
--- a/sys-auth/nss_ldap/nss_ldap-254.ebuild
+++ b/sys-auth/nss_ldap/nss_ldap-254.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/nss_ldap/nss_ldap-254.ebuild,v 1.1 2007/02/06 04:50:25 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/nss_ldap/nss_ldap-254.ebuild,v 1.2 2007/10/09 23:39:47 robbat2 Exp $
inherit fixheadtails eutils multilib
@@ -22,22 +22,22 @@ RDEPEND="${DEPEND}
src_unpack() {
unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/nsswitch.ldap.diff
- epatch ${FILESDIR}/${PN}-239-tls-security-bug.patch
- epatch ${FILESDIR}/${PN}-249-sasl-compile.patch
- EPATCH_OPTS="-p1 -d ${S}" epatch ${FILESDIR}/${PN}-252-reconnect-timeouts.patch
- EPATCH_OPTS="-p1 -d ${S}" epatch ${FILESDIR}/${PN}-254-nss_getgrent_skipmembers.patch
+ cd "${S}"
+ epatch "${FILESDIR}"/nsswitch.ldap.diff
+ epatch "${FILESDIR}"/${PN}-239-tls-security-bug.patch
+ epatch "${FILESDIR}"/${PN}-249-sasl-compile.patch
+ EPATCH_OPTS="-p1 -d ${S}" epatch "${FILESDIR}"/${PN}-252-reconnect-timeouts.patch
+ EPATCH_OPTS="-p1 -d ${S}" epatch "${FILESDIR}"/${PN}-254-nss_getgrent_skipmembers.patch
sed -i.orig \
-e '/^ @(#)\$Id: ldap.conf,v/s,^,#,' \
- ${S}/ldap.conf || die "failed to clean up initial version marker"
+ "${S}"/ldap.conf || die "failed to clean up initial version marker"
# fix head/tail stuff
- ht_fix_file ${S}/Makefile.am ${S}/Makefile.in ${S}/depcomp
+ ht_fix_file "${S}"/Makefile.am "${S}"/Makefile.in "${S}"/depcomp
# fix build borkage
for i in Makefile.{in,am}; do
sed -i.orig \
-e '/^install-exec-local: nss_ldap.so/s,nss_ldap.so,,g' \
- ${S}/$i
+ "${S}"/$i
done
}
diff --git a/sys-auth/nss_ldap/nss_ldap-257.ebuild b/sys-auth/nss_ldap/nss_ldap-257.ebuild
index 3eca16b06811..c2fbd68a83f0 100644
--- a/sys-auth/nss_ldap/nss_ldap-257.ebuild
+++ b/sys-auth/nss_ldap/nss_ldap-257.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/nss_ldap/nss_ldap-257.ebuild,v 1.1 2007/09/18 23:18:35 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/nss_ldap/nss_ldap-257.ebuild,v 1.2 2007/10/09 23:39:47 robbat2 Exp $
inherit fixheadtails eutils multilib
@@ -22,24 +22,24 @@ RDEPEND="${DEPEND}
src_unpack() {
unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/nsswitch.ldap.diff
+ cd "${S}"
+ epatch "${FILESDIR}"/nsswitch.ldap.diff
# Applied by upstream
- #epatch ${FILESDIR}/${PN}-239-tls-security-bug.patch
- epatch ${FILESDIR}/${PN}-249-sasl-compile.patch
- EPATCH_OPTS="-p1 -d ${S}" epatch ${FILESDIR}/${PN}-252-reconnect-timeouts.patch
- EPATCH_OPTS="-p1 -d ${S}" epatch ${FILESDIR}/${PN}-254-nss_getgrent_skipmembers.patch
- EPATCH_OPTS="-p1 -d ${S}" epatch ${FILESDIR}/${PN}-257-nss_max_group_depth.patch
+ #epatch "${FILESDIR}"/${PN}-239-tls-security-bug.patch
+ epatch "${FILESDIR}"/${PN}-249-sasl-compile.patch
+ EPATCH_OPTS="-p1 -d ${S}" epatch "${FILESDIR}"/${PN}-252-reconnect-timeouts.patch
+ EPATCH_OPTS="-p1 -d ${S}" epatch "${FILESDIR}"/${PN}-254-nss_getgrent_skipmembers.patch
+ EPATCH_OPTS="-p1 -d ${S}" epatch "${FILESDIR}"/${PN}-257-nss_max_group_depth.patch
sed -i.orig \
-e '/^ @(#)\$Id: ldap.conf,v/s,^,#,' \
- ${S}/ldap.conf || die "failed to clean up initial version marker"
+ "${S}"/ldap.conf || die "failed to clean up initial version marker"
# fix head/tail stuff
- ht_fix_file ${S}/Makefile.am ${S}/Makefile.in ${S}/depcomp
+ ht_fix_file "${S}"/Makefile.am "${S}"/Makefile.in "${S}"/depcomp
# fix build borkage
for i in Makefile.{in,am}; do
sed -i.orig \
-e '/^install-exec-local: nss_ldap.so/s,nss_ldap.so,,g' \
- ${S}/$i
+ "${S}"/$i
done
}