summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Gavin <pete@gentoo.org>2001-07-28 15:49:20 +0000
committerPeter Gavin <pete@gentoo.org>2001-07-28 15:49:20 +0000
commit00370f2de9e5825d29ca212d51ed35388567b48d (patch)
treefbd98eac91baf6271f55be3aa165475eae5ce777 /sys-apps/sh-utils
parentapply a patch that makes it work better with autoconf 2.13 (diff)
downloadgentoo-2-00370f2de9e5825d29ca212d51ed35388567b48d.tar.gz
gentoo-2-00370f2de9e5825d29ca212d51ed35388567b48d.tar.bz2
gentoo-2-00370f2de9e5825d29ca212d51ed35388567b48d.zip
bootcd fixups and additions. set USE=bootcd to build these packages
for the installation cd. autoiso.sh is the cd building automation script. (its not nearly complete though)
Diffstat (limited to 'sys-apps/sh-utils')
-rw-r--r--sys-apps/sh-utils/files/digest-sh-utils-2.0j-r41
-rw-r--r--sys-apps/sh-utils/sh-utils-2.0j-r4.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/sys-apps/sh-utils/files/digest-sh-utils-2.0j-r4 b/sys-apps/sh-utils/files/digest-sh-utils-2.0j-r4
new file mode 100644
index 000000000000..bc4f2b097953
--- /dev/null
+++ b/sys-apps/sh-utils/files/digest-sh-utils-2.0j-r4
@@ -0,0 +1 @@
+MD5 82087d6cc313189c312a0cf8ef875a2c sh-utils-2.0j.tar.gz
diff --git a/sys-apps/sh-utils/sh-utils-2.0j-r4.ebuild b/sys-apps/sh-utils/sh-utils-2.0j-r4.ebuild
new file mode 100644
index 000000000000..c2853ea08510
--- /dev/null
+++ b/sys-apps/sh-utils/sh-utils-2.0j-r4.ebuild
@@ -0,0 +1,66 @@
+
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/sh-utils/sh-utils-2.0j-r4.ebuild,v 1.1 2001/07/28 15:49:20 pete Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="Your standard GNU shell utilities"
+SRC_URI="ftp://alpha.gnu.org/gnu/fetish/${A}"
+
+DEPEND="virtual/glibc
+ nls? ( sys-devel/gettext )"
+
+RDEPEND="virtual/glibc"
+
+src_unpack() {
+
+ unpack ${A}
+ cd ${S}
+ patch -p0 < ${FILESDIR}/${P}-src-sys2.h-gentoo.diff
+}
+
+src_compile() {
+
+ local myconf
+ if [ -z "`use nls`" ]
+ then
+ myconf="--disable-nls"
+ fi
+
+ try CFLAGS=\"${CFLAGS}\" ./configure --host=${CHOST} --build=${CHOST} \
+ --prefix=/usr --mandir=/usr/share/man --infodir=/usr/share/info \
+ --without-included-regex ${myconf}
+
+ if [ -z "`use static`" ]
+ then
+ try make ${MAKEOPTS}
+ else
+ try make ${MAKEOPTS} LDFLAGS=-static
+ fi
+}
+
+src_install() {
+
+ try make prefix=${D}/usr mandir=${D}/usr/share/man infodir=${D}/usr/share/info install
+ rm -rf ${D}/usr/lib
+ dodir /bin
+ cd ${D}/usr/bin
+ mv date echo false pwd stty su true uname ${D}/bin
+
+ if [ -z "`use build`" ] && [ -z "`use bootcd`" ]
+ then
+ # We must use hostname from net-base
+ rm hostname
+ cd ${S}
+ dodoc AUTHORS COPYING ChangeLog ChangeLog.0 \
+ NEWS README THANKS TODO
+ else
+ rm -rf ${D}/usr/lib ${D}/usr/share
+ fi
+
+}
+
+
+